• January 24, 2019, 03:14:21 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: 1 [2] 3 4 ... 7
  Subject Started by Replies Views Last post
DWA-160 Help BiGxChucK 11 10486 Last post August 22, 2014, 06:55:50 AM
by FurryNutz
DWA-160 [SOLVED] granul 4 4499 Last post July 18, 2014, 10:02:57 AM
by FurryNutz
Slow file transferring speed (DWA-160A2 Ad hoc with two Windows 7 laptops) HelenLover 1 8426 Last post May 15, 2014, 09:10:38 AM
by FurryNutz
DWA-160 stops working sometimes templar817 3 4991 Last post April 30, 2014, 09:19:59 AM
by FurryNutz
DWA-160 Not connecting Win xp Kevinbre 9 6679 Last post April 17, 2014, 09:31:17 AM
by FurryNutz
DWA 160 unable to change preferred connection garyjbova 1 1981 Last post April 09, 2014, 12:56:28 PM
by FurryNutz
fixed yuri64 3 6474 Last post March 04, 2014, 10:45:39 AM
by FurryNutz
Can't connect to 802.11n band on Linux with D-Link DWA-160 shmerl 8 17411 Last post January 10, 2014, 10:27:12 AM
by FurryNutz
has anyone tried adding an extension to a wireless adaptor? Kevinbre 1 2117 Last post December 23, 2013, 10:52:02 AM
by FurryNutz
How to update the firmware from 1.40 to latest? ptrsmntc 2 11234 Last post November 12, 2013, 08:26:19 AM
by FurryNutz
DWA-160 connects but no internet while onboard wireless is flawless pabloottawa 1 29791 Last post May 28, 2013, 08:01:13 AM
by FurryNutz
How does one install the driver without installing the connection wizard? zer0nix 4 9700 Last post April 23, 2013, 12:52:45 PM
by zer0nix
DWA 160 quit working - bad adapter? DevalDragon 2 9219 Last post December 18, 2012, 07:03:18 AM
by FurryNutz
Windows 8 Driver hanax84 3 3849 Last post December 12, 2012, 01:01:44 PM
by FurryNutz
Product stopped working? Stvrm 5 6768 Last post November 22, 2012, 11:04:13 AM
by FurryNutz
Unsigned driver error on installation beninho96 9 36730 Last post August 30, 2012, 07:20:43 AM
by FurryNutz
DWA-160 rev A2 doesn't work in USB 3.0 ports « 1 2 » eots 18 22737 Last post March 20, 2012, 07:43:22 AM
by FurryNutz
Latest firmware dumpystig 3 6224 Last post February 29, 2012, 08:54:25 PM
by eots
DWA-160 A2 not connecting to WPA2-AES opers13 1 7807 Last post November 23, 2011, 05:10:45 PM
by Ant@10
D-Link, DWA-160 & Linux Mark_in_Hollywood 0 7371 Last post November 07, 2011, 02:37:02 PM
by Mark_in_Hollywood
Pages: 1 [2] 3 4 ... 7

 

  • Normal Topic
  • Hot Topic (More than 15 replies)
  • Very Hot Topic (More than 25 replies)
  • Locked Topic
  • Sticky Topic
  • Poll