+  D-Link Forums
|-+  D-Link Xtreme N (Platinum Products)» DWA-160
Username:
Password:
Pages: [1] 2 3 ... 6
 
Subject Author Replies Views Last post
Sticky Topic: New D-Link Web Sites - USA FurryNutz 2 25017 Last post February 18, 2014, 08:27:06 AM
by FurryNutz
Sticky Topic: Current Line of Wifi Adapters FurryNutz 0 519 Last post January 25, 2013, 02:43:37 PM
by FurryNutz
Sticky Topic: New - DWA-162 - Wireless N900 Dual Band USB Adapter FurryNutz 0 988 Last post January 25, 2013, 02:22:42 PM
by FurryNutz
Sticky Topic: Installing DWA-160 in Mac OSX Lion auwkeung 5 17853 Last post August 14, 2012, 10:58:13 AM
by FurryNutz
Sticky Topic: Installing OS X Drivers [version 4.0.0.10] gniknalu 5 27091 Last post April 17, 2012, 10:49:11 AM
by scottwhitty
Sticky Topic: United States Support and FAQ's Here! arod 0 4329 Last post January 19, 2009, 01:07:37 PM
by arod
Sticky Topic: Welcome! Lycan 0 3756 Last post April 28, 2008, 11:21:46 AM
by Lycan
Sticky Topic: 300Mbps Connection Requirements! Please Read! Lycan 0 6317 Last post April 28, 2008, 11:21:08 AM
by Lycan
DWA-160 Not connecting Win xp Kevinbre 9 198 Last post April 17, 2014, 09:31:17 AM
by FurryNutz
DWA 160 unable to change preferred connection garyjbova 1 492 Last post April 09, 2014, 12:56:28 PM
by FurryNutz
fixed yuri64 3 2163 Last post March 04, 2014, 10:45:39 AM
by FurryNutz
Can't connect to 802.11n band on Linux with D-Link DWA-160 shmerl 8 3677 Last post January 10, 2014, 10:27:12 AM
by FurryNutz
has anyone tried adding an extension to a wireless adaptor? Kevinbre 1 559 Last post December 23, 2013, 10:52:02 AM
by FurryNutz
How to update the firmware from 1.40 to latest? ptrsmntc 2 5237 Last post November 12, 2013, 08:26:19 AM
by FurryNutz
DWA-162 Window 8 install BILLMC 2 723 Last post November 07, 2013, 05:31:49 PM
by BILLMC
DWA-160 connects but no internet while onboard wireless is flawless pabloottawa 1 15757 Last post May 28, 2013, 08:01:13 AM
by FurryNutz
How does one install the driver without installing the connection wizard? zer0nix 4 5427 Last post April 23, 2013, 12:52:45 PM
by zer0nix
DWA 160 quit working - bad adapter? DevalDragon 2 6445 Last post December 18, 2012, 07:03:18 AM
by FurryNutz
Windows 8 Driver hanax84 3 2039 Last post December 12, 2012, 01:01:44 PM
by FurryNutz
Product stopped working? Stvrm 5 4135 Last post November 22, 2012, 11:04:13 AM
by FurryNutz
Pages: [1] 2 3 ... 6
 
Topic you have posted in
Normal Topic
Hot Topic (More than 15 replies)
Very Hot Topic (More than 25 replies)
Locked Topic
Sticky Topic
Poll
:  
Theme by webtechnica.com.