• October 22, 2020, 09:07:04 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: 1 [2]
  Subject Started by Replies Views Last post
Streaming Media stutters carnagerover 4 6373 Last post August 20, 2008, 03:00:48 PM
by carnagerover
Disabling the internal 4695AGN to use the DWA-643 p5tom 2 4875 Last post August 10, 2008, 05:41:43 AM
by DHonzik
Disconnect when transferring large files kegobeer 2 5134 Last post August 01, 2008, 10:33:29 AM
by j_jon90@hotmail.com
After much review....... Lycan 0 3930 Last post June 10, 2008, 12:36:19 PM
by Lycan
wireless connection manager vista - usable at any point in the future? jparise79 0 3523 Last post June 01, 2008, 05:46:39 AM
by jparise79
Does bluetooth really interfere with dwa-643? random4568 0 3001 Last post April 16, 2008, 07:16:37 AM
by random4568
NAS not accessable when using DWA-643 and DIR-655 with AES Encryption and N only swblind 0 3124 Last post April 01, 2008, 06:42:03 PM
by swblind
Driver Upgrade leads to lost functionality of DLink Connection Manager rmurry9 4 7826 Last post March 07, 2008, 11:43:31 PM
by jamesmartin0226@comcast.n
DWA-643 WPS jamesmartin0226@comcast.n 9 8367 Last post March 07, 2008, 11:33:12 PM
by jamesmartin0226@comcast.n
Very poor DWA-643 connection speeds & Wireless Connection Manager problem « 1 2 » ButchN 17 15138 Last post March 04, 2008, 08:43:50 AM
by ButchN
[SOLVED] DWA-643 acquiring address... miro 2 4238 Last post February 26, 2008, 05:10:50 PM
by miro
DWA-643 Connection Manager Wifi Protected Setup causes a API Init Error. jamesmartin0226@comcast.n 0 4108 Last post January 30, 2008, 10:20:07 PM
by jamesmartin0226@comcast.n
Can't use Dlink card configuration utility 1.10 or 1.20 fooz642 2 5282 Last post January 06, 2008, 09:20:26 PM
by rmurry9
How do I upgrade my drivers without an exe file? hdpwipmonkey 3 5996 Last post January 06, 2008, 09:17:34 PM
by rmurry9
My DWA-643 is Connecting at 130Mbps laidbakguy 2 4065 Last post January 02, 2008, 01:01:12 PM
by Rad Spencer
Vista code 10 - hardware can not start - I need help... zylon 6 6320 Last post January 02, 2008, 12:56:54 PM
by Rad Spencer
Development of Linux drivers kegobeer 1 3419 Last post December 31, 2007, 08:54:40 AM
by Rara Avis
Dell 1720 fit ekalbach 1 3116 Last post December 25, 2007, 09:42:41 PM
by AWDL
DWA-645: "Limited connectivity" under WinXP xo-vision 9 8447 Last post August 14, 2007, 03:42:54 AM
by xo-vision
DWA-643 Windows Vista Drivers OliversAttic 5 7209 Last post August 08, 2007, 11:21:58 AM
by AWDL
Pages: 1 [2]

 

  • Normal Topic
  • Hot Topic (More than 15 replies)
  • Very Hot Topic (More than 25 replies)
  • Locked Topic
  • Sticky Topic
  • Poll