• January 16, 2021, 04:39:36 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: 1 [2]
  Subject Started by Replies Views Last post
Ubuntu + DWA 643 can see networks but not connect justinkelly 0 47632 Last post July 02, 2012, 06:20:18 PM
by justinkelly
Notebook will not shut down with DWA-643 enabled kdm 8 26480 Last post January 25, 2015, 02:20:30 PM
by FurryNutz
Development of Linux drivers kegobeer 1 3439 Last post December 31, 2007, 08:54:40 AM
by Rara Avis
Disconnect when transferring large files kegobeer 2 5161 Last post August 01, 2008, 10:33:29 AM
by j_jon90@hotmail.com
My DWA-643 is Connecting at 130Mbps laidbakguy 2 4101 Last post January 02, 2008, 01:01:12 PM
by Rad Spencer
After much review....... Lycan 0 3949 Last post June 10, 2008, 12:36:19 PM
by Lycan
[SOLVED] DWA-643 acquiring address... miro 2 4271 Last post February 26, 2008, 05:10:50 PM
by miro
windows 7 driver will be released ?? moktay0000 2 15658 Last post January 23, 2010, 02:20:25 AM
by Steef_Holland
DWA-643 Windows Vista Drivers OliversAttic 5 7327 Last post August 08, 2007, 11:21:58 AM
by AWDL
Disabling the internal 4695AGN to use the DWA-643 p5tom 2 4902 Last post August 10, 2008, 05:41:43 AM
by DHonzik
Does bluetooth really interfere with dwa-643? random4568 0 3022 Last post April 16, 2008, 07:16:37 AM
by random4568
Different Rates reported by adapter and router rcigliano 3 8911 Last post September 05, 2008, 06:24:48 PM
by WildSioux
Driver Upgrade leads to lost functionality of DLink Connection Manager rmurry9 4 7862 Last post March 07, 2008, 11:43:31 PM
by jamesmartin0226@comcast.n
Configuring DIR-615 Router for Optimum Speed w DWA-130 & DWA-643 Adapters rosejo 0 73847 Last post May 13, 2011, 06:38:16 PM
by rosejo
Wireless help plz!! Snarl 0 9934 Last post January 23, 2009, 09:34:52 PM
by Snarl
NAS not accessable when using DWA-643 and DIR-655 with AES Encryption and N only swblind 0 3146 Last post April 01, 2008, 06:42:03 PM
by swblind
Intermittent Disconnects vdavap 3 13242 Last post November 06, 2008, 09:36:42 AM
by Alex Molina
Code 10. This device cannot start!! (VistaHome Premium) wolfgang 2 15469 Last post January 15, 2010, 08:48:11 PM
by howard251
DWA-645: "Limited connectivity" under WinXP xo-vision 9 8559 Last post August 14, 2007, 03:42:54 AM
by xo-vision
Vista code 10 - hardware can not start - I need help... zylon 6 6365 Last post January 02, 2008, 12:56:54 PM
by Rad Spencer
Pages: 1 [2]

 

  • Normal Topic
  • Hot Topic (More than 15 replies)
  • Very Hot Topic (More than 25 replies)
  • Locked Topic
  • Sticky Topic
  • Poll