• December 11, 2019, 07:50:41 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Add Firewall Rule is not being saved  (Read 664 times)

ahmadano

  • Level 1 Member
  • *
  • Posts: 1
Add Firewall Rule is not being saved
« on: July 21, 2019, 02:50:33 PM »

My DIR-890L router, Firmware version: 1.20, ISP is Cox.
Tried to add a IPv4 Firewall rule to turn on IPv4 filter with ALLOW rules listed. I configured the rule and successfully added. However, when clicking Save the rule disappear. Tried using IE, Chrome and Firefox and all ended with the same result no rules saved. Please help
Thank you
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47980
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Add Firewall Rule is not being saved
« Reply #1 on: July 21, 2019, 06:06:05 PM »

Link>Welcome!

  • Are you wired or wireless connected to the router?
  • Has a Factory Reset been performed since the last FW update?
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

AmyC

  • Level 1 Member
  • *
  • Posts: 21
Re: Add Firewall Rule is not being saved
« Reply #2 on: September 25, 2019, 11:03:33 AM »

I am having this same problem on the DIR-882 after upgrading to the FW 1.20 today. And yes, factory reset already and started all over again. When you save the rules you created everything disappears because it seems like the drop down toggle reverts back to "Turn IPv4 Filtering Off" no matter what you select. It just won't stick. I've tried both settings to ALLOW and DENY just to see if either works. Neither does. It reverts back to OFF and the rules disappear.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47980
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Add Firewall Rule is not being saved
« Reply #3 on: September 25, 2019, 12:53:38 PM »

What browser are you using?

Try IE11, Firefox or Opera to see if this continues here.

I am having this same problem on the DIR-882 after upgrading to the FW 1.20 today. And yes, factory reset already and started all over again. When you save the rules you created everything disappears because it seems like the drop down toggle reverts back to "Turn IPv4 Filtering Off" no matter what you select. It just won't stick. I've tried both settings to ALLOW and DENY just to see if either works. Neither does. It reverts back to OFF and the rules disappear.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

AmyC

  • Level 1 Member
  • *
  • Posts: 21
Re: Add Firewall Rule is not being saved
« Reply #4 on: September 28, 2019, 08:10:06 AM »

I had tried it previously with both FF 69.0.1 (64-bit), Chrome 77.0.3865.90 (64-bit), and today I just tested IE 11.0.9600.19467. All of them replicate the same issue. I don't have Opera installed. If you really need me to I can try it, but I'm feeling pretty confident since it follows these three browsers, it will also have a problem in Opera.

I am running a 64 bit version of Windows 7 and as stated above the 64 bit browsers. I do not know if that is helpful.
What browser are you using?

Try IE11, Firefox or Opera to see if this continues here.

I am having this same problem on the DIR-882 after upgrading to the FW 1.20 today. And yes, factory reset already and started all over again. When you save the rules you created everything disappears because it seems like the drop down toggle reverts back to "Turn IPv4 Filtering Off" no matter what you select. It just won't stick. I've tried both settings to ALLOW and DENY just to see if either works. Neither does. It reverts back to OFF and the rules disappear.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47980
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Add Firewall Rule is not being saved
« Reply #5 on: September 28, 2019, 11:04:32 AM »

So does turning OFF the router and back on change the behavior?

You may need to do a factory reset and setup from scratch.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

AmyC

  • Level 1 Member
  • *
  • Posts: 21
Re: Add Firewall Rule is not being saved
« Reply #6 on: October 06, 2019, 10:09:06 AM »

So does turning OFF the router and back on change the behavior?

You may need to do a factory reset and setup from scratch.

Well, I did a hard reset (using the pin reset in the back) and started setup all over again after a power off. Still won't save any firewall rules. I don't use IPv6 but I even tried those just to see if they would stick. They won't either. I don't know if this helps track down the bug, but if you just change the dropdown without adding a rule (to turn on a the rules), when you save it, the router does one of it's "Please wait for X seconds" power cycle things. But if you have added a rule when you do this, it just flashes on the screen and never goes into one of those power cycles and it disappears. Ether way, nothing ever sticks to "on."
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47980
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Add Firewall Rule is not being saved
« Reply #7 on: October 06, 2019, 12:54:09 PM »

Was this happening on prior version of FW?
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting