• July 19, 2019, 09:37:17 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: No HTTP access to camera after firmware update  (Read 4295 times)

jwilds1

  • Level 1 Member
  • *
  • Posts: 3
No HTTP access to camera after firmware update
« on: February 05, 2016, 06:49:02 AM »

Hello all,

Got a 5020L last night, and proceeded to set it up.  Here were the steps:
1) used mydlink PC software for initial setup (wifi, etc)
2) Configured home router to assign static IP to DCS-5020L
3) Configured DCS-5020L settings to match IP in router
4) configured port forwarding on router

At this point, I was able to access the camera through the mydlink site, internal web access (on the home network via Chrome and Edge), and external web access (Chrome browser on phone - wasn't able to see anything but was able to access web page served by 5020L).  Everything looked great...

4) installed mydlink app to phone.  Told me that a firmware update was available, gave it the go-ahead.

After this update now, the only things working are related to mydlink - the app works and the web portal works.  I cannot access using the external-facing IP address ( http://68.55.228.84:8084/ ).  In Chrome, it gives me this:



IE8 (I know, work computer I can't upgrade) gives me this:
Code: [Select]
This Page Cannot Be Displayed

--------------------------------------------------------------------------------

Authentication is required to access the requested web site ( 68.55.228.84 ). A valid user ID and password must be entered when prompted.

If you have questions, need assistance with your login information, or feel this is an error, please contact your organization's network administrator and provide the codes shown below.


--------------------------------------------------------------------------------
Notification codes:  (1, WWW_AUTH_REQUIRED, 68.55.228.84)

I tried using some of the URLs listed here http://forums.dlink.com/index.php?topic=57131.msg226605#msg226605 to no avail.

I would revert firmware, but seeing as I can't access the HTTP setup page, I have no means of flashing it back.

Any words of advice????
« Last Edit: February 05, 2016, 06:55:35 AM by jwilds1 »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47572
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: No HTTP access to camera after firmware update
« Reply #1 on: February 05, 2016, 08:29:33 AM »

Camera:
Link>Welcome!

  • What Hardware version is your DCS? Look at the sticker behind or under the camera.
  • Link>What Firmware version is currently loaded? Found on the DCSs web page under status.
  • What region are you located?
Is the camera locally accessible?
What Mfr and model is the main host router?
What wireless modes are you using?

Please review:
Links>mydlink and Browser FAQ
DCS Cloud (L) Series Camera Configuration and Mydlink.com
mydlink.com and Java Application FAQ

Also...
http://www.ghacks.net/2015/04/15/chrome-42-blocks-java-silverlight-other-plugins-by-default-now/
http://support.dlink.com/FAQView.aspx?f=IlkzRfo0ym7ofWgtMitzCA%3d%3d
 
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

jwilds1

  • Level 1 Member
  • *
  • Posts: 3
Re: No HTTP access to camera after firmware update
« Reply #2 on: February 05, 2016, 01:48:29 PM »

At home now - getting the following when trying to access via LAN http address:
Chrome: "The browser you are using..."
Edge on Win10: "The web-based setup page on this device works best in Internet Explorer..."
IE11 on Win10: No issues
Firefox: No issues

Chrome on Win7 (work) - "The browser you are using..."
IE8 on Win7 (work) - requested authentication (as above)
IE11 on Win7 (work - was able to update) - requested authentication (as above)

There were no popup windows on my work PC asking me to enter user name/password, just a failed login.  I tried using some of the URL strings that included them, using admin and the password but it didn't work.  I cannot install Firefox on my work PC, so I need either a Chrome or IE11 solution to view live video (don't need admin remotely, just view).

Now that I can get into the web-based setup in Firefox, I'll make a non-admin account and try that.
Hardware version = A1
Firmware version = 1.13.05
Logged

RYAT3

  • Level 10 Member
  • *****
  • Posts: 2110
Re: No HTTP access to camera after firmware update
« Reply #3 on: February 05, 2016, 02:30:35 PM »

I got prompted for username/password from my Android phone to your camera.
Logged

jwilds1

  • Level 1 Member
  • *
  • Posts: 3
Re: No HTTP access to camera after firmware update
« Reply #4 on: February 08, 2016, 07:28:13 AM »

Update - I cannot access through mydlink at work.  Chrome v48.0.2564.103 gets to the point where it finds the camera and spins infinitely trying to connect.  IE11 will not install the plugin due to work restrictions.  Current version of Java on this machine is 7.51, and I can only upgrade to 7.67

I've checked the ghacks link and do not have the option to enable NPAPI (probably because v48).

HELP!  I'm blowing through my data plan on my phone.
Logged

RYAT3

  • Level 10 Member
  • *****
  • Posts: 2110
Re: No HTTP access to camera after firmware update
« Reply #5 on: February 08, 2016, 02:04:35 PM »

It sounds like everything is working as expected.

You should try to revert back to previous f/w.
Logged

liteknite

  • Level 1 Member
  • *
  • Posts: 1
Re: No HTTP access to camera after firmware update
« Reply #6 on: October 13, 2016, 01:37:37 AM »

I just got the same camera and made the same firmware upgrade and ran into the same issue.  Can original poster update if revert f/w fixed the problem?  Which version of firmware worked to fix viewing directly from Chrome and IE?
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47572
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: No HTTP access to camera after firmware update
« Reply #7 on: October 13, 2016, 06:29:23 AM »

Google disabled plug ins in Chrome a while back. Can you test with FF?

I just got the same camera and made the same firmware upgrade and ran into the same issue.  Can original poster update if revert f/w fixed the problem?  Which version of firmware worked to fix viewing directly from Chrome and IE?
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting