• October 19, 2020, 11:05:15 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Some annoying bugs found  (Read 2648 times)

trepx

  • Level 1 Member
  • *
  • Posts: 4
Some annoying bugs found
« on: December 05, 2015, 01:17:37 AM »

Some annoying bugs found:

1. With "Smart" connect being enabled, I had problems with the speed on a smart TV. Basically even though the TV connected fine to the wireless network, when accessing some shared videos (via DLNA) it was doing a lot of buffering. So even if I was actually accessing something from local network, TV was losing connection.
Workaround found: disable "smart" connect and set each network individually, connect the TV to one of the network. This issue needs to be fixed by D-link

2. Slow Internet connection on computers via wireless: Internet speed was really slow and noticed that router was also advertising IPv6 via DHCP and it was somehow trying to get an IPv6 from ISP.
Workaround found: disable IPv6 of the network card of the computers and also disable "Enable Automatic IPv6 Address Assignment" from the router. This issue needs to be fixed by D-link

3. Printer losing connection to the wireless. From time to time my printer was unable to connect to the wireless network
Workaround found: disable IPv6 from the printer settings as it was getting 2 different IPs (v4 and v6). This issue needs to be fixed. I would propose to have a way to disable for good the IPv6 DHCP form D-Link router

4. No way of setting the Wireless channel in case of 5GHz network. For the 1st 5G network I see only a few channels available (36,40,44,48) while for the 2nd 5GHz the only option is Auto. Seriously? This needs to be fixed ASAP as it's not a browser issue! See some screenshots below:




I really need to setup the channel and get the full channels list (I refer here to the 100+ channels) as sometimes after reboot the stupid router puts me on channels used by other networks, so I do not trust the Auto.

For all the above, setup is as following:
- right after purchase, I've downloaded the latest firmware and installed it. Current FW version 1.08, HW A1
- OS used during tests: Windows 7, 8, 8.1, 10
- Browsers used during tests: latest IE, Firefox, Chrome
- Computer wireless cards: Intel 7265, Intel 7260, Intel 3160
- Computers used: 3 different, from 3 manufacturers
- Smart TV: Samsung ue32h5500
- Printer: HP 8610 Pro
- Wireless networks setup on 890L: each has its own SSID, so different values. You can see other settings in the screenshots above

Considering that I tested on a lot of devices, in soooo many different ways (browsers, OS, clean installs, etc) I would say I did my part. Now it's time for D-Link to do the work and fix the issues, especially the most annoying one which makes me unable to select the channel for each SSID
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49273
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Some annoying bugs found
« Reply #1 on: December 05, 2015, 09:12:58 AM »

Link>Welcome!

  • What region are you located?

When SmartConnect is enabled, can you determine which frequency the TV is connected on?
What frequency does the TV support? 2.4 or 5Ghz?

I recommend setting a Static IP address ON the printer thats outside of the default DHCP IP address pool on the router. I have 3 printers set up on mine and they all are set for Static addresses and work well.

IPv6 should be set for Local Only on the router if your ISP doesn't support IPv6 or you don't use it everyday.

How many other wifi networks are near by? What channels are they using?
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

trepx

  • Level 1 Member
  • *
  • Posts: 4
Re: Some annoying bugs found
« Reply #2 on: December 05, 2015, 07:29:36 PM »

Hello FurryNutz,

I am located in EU - indeed I am not in US, but I would assume it is not a problem since the DIR890L version is the same.

TV is connected on 2.4 and from time to time it wants to connect to the 5 GHz one (because with Smart Connect all networks have the same SSID), but the router rejects the connection, causing poor / intermittent performance. That's why I disabled the SmartConnect - I am fine with this - and manually selected only the 2.4 WLAN.

Good tip with setting a static IP on the printer. As I said, I found a workaround for this issue and now everything is working fine. My ISP does support IPv6 but it's not that stable so I just set it to Local Only. Also for me it doesn't make sense to have local network on IPv6 and the Internet connection on IPv4, I believe it will also make some overhead for the NAT in such setup, considering I have 1Gbps from my provider.

I have about 10 WiFi networks around, channels going from 1 to 36 (confirmed via inSSIDer and Wifi Analyzer on Android). It's strange that on the D-link emulator - which is on the 1.0 version of the FW - I am able to select the channel on any of the wireless networks, but not on the real router. Yesterday I've installed the beta version (with 2 default resets before and after the upgrade just to be sure and manual setup) and I am still unable to choose the channel, no matter the browser I use.

Other than that, I am ok-ish with the router. I am happy that with version 1.09 I now can disable the WiFI protected setup, but I am still missing the system logs. As a network engineer I'd prefer to have the logs available rather than setting up a syslog server.

Some speedtests:
- wireless:


- wired:
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49273
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Some annoying bugs found
« Reply #3 on: December 05, 2015, 07:35:45 PM »

So does v1.09 work better with Smart Connect enabled?

EU region I presume will not have the higher channels on 5Ghz. I believe your region is limited to the lower channels only. There is some freqency policy that is governed in your region for all router Mfr that limits the additional channels from being used in your region.

If your getting 1gb or near that, you may want to be ready to install 10Gb supporting networking at some point:
http://forums.dlink.com/index.php?topic=63449.0

Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

trepx

  • Level 1 Member
  • *
  • Posts: 4
Re: Some annoying bugs found
« Reply #4 on: December 06, 2015, 12:10:27 AM »

I did not try Smart Connect again. Can you check on your side if you disable SC you're able to select the channel number for 2nd 5G network, with version 1.08 or 1.09? Higher channels are not restricted - there are a lot of other wireless routers where I can set them. Also after some reboots, with Auto channel selection, the 890L chose ch 100 eventually, but I want to be able to select it manually. Could you forward this issue to D-Link?
Logged

DuggiEu

  • Level 1 Member
  • *
  • Posts: 1
Re: Some annoying bugs found
« Reply #5 on: December 06, 2015, 12:55:42 AM »

I have the same problem for manually selecting the channel for the 2. 5Ghz. I'm using the 1.08 Firmware. I had tried to downgrade to 1.0 and there it is possible to set the channels for the 2. 5Ghz. But this is not possible with the 1.03 firmware. The 1.09 firmware has the same problem.

I'm running Windows 10 - I have used the I-Explorer. Living in EU/Denmark.

I have done a reset to factory when i updated the firmware and reset the iexplorere cache.

Logged

trepx

  • Level 1 Member
  • *
  • Posts: 4
Re: Some annoying bugs found
« Reply #6 on: December 06, 2015, 01:12:05 AM »

I was also looking at the HTTP traffic during the wireless setup and even though router is capable of higher channels, they are not allowed by the firmware.

While loading Wireless settings page:

Quote
<!-- it does not support 5G high band if channel list is empty. -->
         
         <RadioInfo>
         <RadioID>RADIO_5GHz_2</RadioID>
         <Frequency>5</Frequency>
         <SupportedModes>
            <string>802.11a</string>
            <string>802.11n</string>
            <string>802.11an</string>
            <string>802.11ac</string>
            <string>802.11nac</string>
            <string>802.11anac</string>
         </SupportedModes>
         <Channels>
            <int></int>
</Channels>

So in the XML loaded the person that created the firmware clearly indicates "it does not support 5G high band if channel list is empty" and that list is indeed empty if you look above. However, in the wide channel list, seems it is capable of using them:

Quote
<WideChannel>
   <Channel>157</Channel>
   <SecondaryChannels>
      <int>149</int>
      <int>165</int>
   </SecondaryChannels>
</WideChannel>

I've even modified the HTTP response and added ch 157 in the list to not be empty, selected it, saved the setting, but router is still choosing the ch 100. I checked via wifi scanner and also by intercepting the HTTP traffic again, where I see that router has saved this value and indicates that 2nd 5GHz is on 157. How is it going to 100, since it is not in the WideChannel list? Also, considering that 1.0 firmware lets you select the channel, clearly this is a bug.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49273
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Some annoying bugs found
« Reply #7 on: December 06, 2015, 07:40:09 AM »

Maybe some regions out side of the NA region may be effected by this...Reason for not seeing but only 4 channels on 5Ghz.
 Dynamic Frequency Selection
This was seen here as well: http://forums.dlink.com/index.php?topic=57693.0

Anyone in the EU region, I recommend that you phone contact your regional D-Link support office and ask for help and information regarding this. We find that phone contact has better immediate results over using email. You can refer them to this forum thread for review.
Let us know how it goes please.

I did not try Smart Connect again. Can you check on your side if you disable SC you're able to select the channel number for 2nd 5G network, with version 1.08 or 1.09? Higher channels are not restricted - there are a lot of other wireless routers where I can set them. Also after some reboots, with Auto channel selection, the 890L chose ch 100 eventually, but I want to be able to select it manually. Could you forward this issue to D-Link?
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!