• October 21, 2020, 11:43:40 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Cannot gain access to the admin section of DSL-2680  (Read 1528 times)

Garawa

  • Level 1 Member
  • *
  • Posts: 24
Cannot gain access to the admin section of DSL-2680
« on: November 09, 2014, 02:53:54 AM »

It has been getting harder and harder to access the admin area of the router.  On my old PC it stopped working with Chrome and IE wan unusable on my system as it caused 100% processor lock out for some reason.  Luckily I could use IE on my wife's laptop but now this doesn't work either.  At least 20 attempts failed before it finally let me try but it rejected my username and password.  Tried a cache clearance, refreshed the page and no joy again.  I have a brand new Windows 8.1 PC now and no access is granted for either Chrome or IE on that!

Often these things resolve themselves after a few days and I have just tries again and got the following message:
Unable to load the webpage because the server sent no data. Error code: ERR_EMPTY_RESPONSE

No amount of browser cache clears or anything seems to bring it up.  I have not seen any significant problems, everything connects as it should and 2 new Android phones and my PC have connected to it OK.  I have seen some devices say they have lost connection and then been unable to reconnect unless I click the connect button.  Others have dropped a connection whilst still stating they are connected but disconnecting and reconnecting again solves the problem.  There is obviously a setting wrong somewhere if I could only get into the admin area to look!
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49275
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Cannot gain access to the admin section of DSL-2680
« Reply #1 on: November 10, 2014, 01:47:16 PM »

Link>Welcome!

  • What Hardware version is your modem? Look at the sticker under modem.
  • Link>What Firmware version is currently loaded? Found on the modems web page under status.
  • What region are you located?

Has a factory reset been performed?
Do both wired and wireless connections exhibit the same problem?

PC 3rd Party Security Software Configurations
  • Turn off all anti virus and firewall programs on PC while testing. 3rd party firewalls are not generally needed when using routers as they are effective on blocking malicious inbound traffic.
  • Turn off all devices accept for one wired LAN PC while testing.
  • Disable any downloading client software managers, i.e. Torrents or similar.


PC Web Browser Configurations
What browser are you using?
Try Opera or FF? If IE 8, 9, 10 or 11, set compatibility mode and test again.
Disable any security browser Add-ons like No Script and Ad-Block or configure them to allow All Pages when connected to the router.
Clear all browser caches.
Be sure to log into the Admin account on the router.
Try turning off these features in Chrome:
Top right corner, little bars for options > Settings > Settings (on left) > Show advanced settings.
Uncheck these:
Use a web service to help resolve navigation errors
Use a prediction service to help complete searches and URLs typed in the address bar
Predict network actions to improve page load performance
Enable phishing and malware protection
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!