• November 15, 2019, 09:23:29 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: 1 [2] 3

Author Topic: Issue with AirPlay - Proper PortForwarding is Setup  (Read 19876 times)

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47906
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Issue with AirPlay - Proper PortForwarding is Setup (WORK-AROUND)
« Reply #15 on: May 13, 2014, 10:37:23 AM »

I've passed this onto D-Link for review. I hope they will get it figured out.

Thanks for your support and information.

Please visit again if you need help and information. Use the WRT forums while your using WRT FW.

Have fun.  ;)
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

JoshDi

  • Level 1 Member
  • *
  • Posts: 12
Re: Issue with AirPlay - Proper PortForwarding is Setup (WORK-AROUND)
« Reply #16 on: May 13, 2014, 10:43:57 AM »

I've passed this onto D-Link for review. I hope they will get it figured out.

Thanks for your support and information.

Please visit again if you need help and information. Use the WRT forums while your using WRT FW.

Have fun.  ;)

Thank you again.

The DD-WRT firmware I am running is the following if anyone is experiencing the same issues:

PLEASE NOTE THIS FIRMWARE IS FOR POWER USERS ONLY!!!! This will void your warranty and has a high potential of permanently bricking your router. Consider yourself warned  ;D ;D ;D

Firmware FTP: ftp://ftp.dd-wrt.com/others/eko/BrainSlayer-V24-preSP2/2014/02-19-2014-r23598/dlink-dir868l/

Forum Post with some instructions: http://www.dd-wrt.com/phpBB2/viewtopic.php?t=172121&postdays=0&postorder=asc&start=75
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47906
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Issue with AirPlay - Proper PortForwarding is Setup
« Reply #17 on: May 13, 2014, 10:57:24 AM »

Thanks for the information.

We recommend anyone wanting to use WRT FW on this router, needs to refer to the DD-WRT web and and forums for any and all help and information. D-Link forums are for D0Link OEM FW.

Please review all the WRT information and documentation before attempting to load any WRT FW.

We recommend before loading WRT FW, please exhaust all forum help and official D-Link support before loading WRT FW. Not all issues presented are FW related and can be resolved by doing some troubleshooting with forum help or official D-Link support.
A good place to start is here:  Router Troubleshooting Suggestions and Tips

Generally D-Links OEM FW works well out of the box and D-Link is aware of issues presented here in the forums when they are presented.

Good Luck.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47906
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Issue with AirPlay - Proper PortForwarding is Setup
« Reply #18 on: May 13, 2014, 11:40:23 AM »

Josh,
I'm in contact with D-Link and they'd like a details run down of your configuration before you loaded WRT if possible please.

If you could give us all HW Mfr and Models being used. ISP, Router and Airplay devices.
How it was all connected.
Any and all networking, router and device configurations, use of any router features like Port Forwarding, wireless modes used on main host router, anything that you have that would be helpful so that D-Link can reproduce this issue.

Please list the steps your using to set this all up.

D-Link is reviewing this.

They would like a saved config file to review from the router as well if possible.

We hope that D-Link will change the behavior of the grayed out WMM check box too. They are looking into it.

Any and all information is appreciated.

Thank you.

« Last Edit: May 13, 2014, 02:28:59 PM by FurryNutz »
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47906
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Issue with AirPlay - Proper PortForwarding is Setup
« Reply #19 on: May 13, 2014, 06:23:31 PM »

I forgot I had a Apple Airport Express (1st gen I think, 2.4Ghz G Max Wireless mode) that I had stored away. I went and did some review on how to set up Airplay after work. I bridged my Airport Express to my DIR-810L which is currently my main host router. Using Mixed G and N modes, WPA2 and Auto Cypher, 20/40Mhz on manual channel 11, 20/40 Co-existence and WMM Enabled. IPv4 Multi-cast Streams is enabled too. The Airport Express is bridged to the 2.4Ghz radio on the 810L. I connected a head phone set to the Airport Express's audio jack and started iTunes on OSX 10.7.5  on my Mac Book Pro wirelessly connected to the 5ghz radio on the 810L and heard sounds coming from the head set. Sounds was good and no interruptions or buffering was seen. Streaming music on from the Mac Book Pro thru the 810L to the Airport Express seems to work well with WMM enabled. I can't test WMM disabled to check that setting as it's grayed out. I'll put the 868L online tomorrow and test it with the Airport Express.

Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

JoshDi

  • Level 1 Member
  • *
  • Posts: 12
Re: Issue with AirPlay - Proper PortForwarding is Setup
« Reply #20 on: May 13, 2014, 06:25:53 PM »

Very odd. I tried my airport express as well and had no luck. Must have been. My configuration...... Even though I tried a factory reset a few times. Thank you for the update on this
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47906
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Issue with AirPlay - Proper PortForwarding is Setup
« Reply #21 on: May 13, 2014, 06:29:50 PM »

Please post any configuration settings you were using.

One thing I forgot to mention is that my Airport Express is using a static IP address of 192.168.0.53, default SNM, and DNS and router is pointed to the main host router at 191.168.0.1. Thats about it.

I'll check my 868L tomorrow.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

JoshDi

  • Level 1 Member
  • *
  • Posts: 12
Re: Issue with AirPlay - Proper PortForwarding is Setup
« Reply #22 on: May 13, 2014, 06:34:02 PM »

had the same static DHCP setup for all devices; my only difference is that I used 192.168.1.255/32 as my sub-net.

I PM'ed you my configuration file from my FW 1.07 install.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47906
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Issue with AirPlay - Proper PortForwarding is Setup
« Reply #23 on: May 13, 2014, 06:38:18 PM »

I see..I only have a few devices set up for static. All my PCs, game consoles and phones are Reserved IPs on the router. I wonder if your PCs or other devices(not Airport Express) using static could have contributed to problems.

I'll test my config out on the 868L tomorrow. I got the file.

Thank you for your time and feed back.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

JoshDi

  • Level 1 Member
  • *
  • Posts: 12
Re: Issue with AirPlay - Proper PortForwarding is Setup
« Reply #24 on: May 13, 2014, 06:40:40 PM »

thank you again for your personal attention on this.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47906
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Issue with AirPlay - Proper PortForwarding is Setup
« Reply #25 on: May 14, 2014, 06:36:50 PM »

Ok, so I connected my 868L today as the main host router. Set up the same WiFi settings as I have on the 810L, Enabled WMM and connected the Airport Express. Streaming from my Mac Book Pro was seamless and with out any issues. All I had to do was to power cydle the AE after the 868L v1.07 was powered up.

I streamed a few songs and enjoyed the music over my 7 chl receiver.

I can't produce your issue.  :-\
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47906
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

joelcorrea

  • Level 1 Member
  • *
  • Posts: 2
Re: Issue with AirPlay - Proper PortForwarding is Setup
« Reply #27 on: August 10, 2014, 02:04:56 AM »

Hi,

I got a Dlink Router & am facing the same issue. I believe its a firmware issue but the following fixes it (Patchwork)

1. Disable MultiAP isolation in Wireless Basic settings
2. Remove 'Configure the second IP Address and Subnet Mask for LAN' from Local network settings
3. Go to Advanced Wireless - Turn User Isolation off (if you want airplay to work from iphone to apple tv)
4. Turn User Isolation ON - if you want Airplay to work from PC (Wired) to Apple tv
5. Make sure your country is set to United Arab Emirates (Best setting so far)

The User isolation setting affects with Bonjour services; if its OFF wifi devices can see each other if ON then only Wired devices will be able to see Wifi devices

Try it out & let me know.

J
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47906
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Issue with AirPlay - Proper PortForwarding is Setup
« Reply #28 on: August 10, 2014, 09:40:03 AM »

Link>Welcome!

  • What Hardware version is your router? Look at sticker under router.
  • Link>What Firmware version is currently loaded? Found on the routers web page under status.
  • What region are you located?

I was able to use the following process and still works well to this day:
Apple Airplay Setup FAQ - How To Configure

http://forums.dlink.com/index.php?topic=59133.0

Hi,

I got a Dlink Router & am facing the same issue. I believe its a firmware issue but the following fixes it (Patchwork)

1. Disable MultiAP isolation in Wireless Basic settings
2. Remove 'Configure the second IP Address and Subnet Mask for LAN' from Local network settings
3. Go to Advanced Wireless - Turn User Isolation off (if you want airplay to work from iphone to apple tv)
4. Turn User Isolation ON - if you want Airplay to work from PC (Wired) to Apple tv
5. Make sure your country is set to United Arab Emirates (Best setting so far)

The User isolation setting affects with Bonjour services; if its OFF wifi devices can see each other if ON then only Wired devices will be able to see Wifi devices

Try it out & let me know.

J
« Last Edit: December 12, 2014, 12:17:22 PM by FurryNutz »
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

jcberg

  • Level 1 Member
  • *
  • Posts: 4
Re: Issue with AirPlay - Proper PortForwarding is Setup
« Reply #29 on: December 12, 2014, 12:16:54 PM »

Link>Welcome!

  • What Hardware version is your router? Look at sticker under router.
  • Link>What Firmware version is currently loaded? Found on the routers web page under status.
  • What region are you located?

I was able to use the following process and still works well to this day:
Apple Airplay Setup FAQ - How To Configure

http://forums.dlink.com/index.php?topic=59133.0

Hi,

I got a Dlink Router & am facing the same issue. I believe its a firmware issue but the following fixes it (Patchwork)

1. Disable MultiAP isolation in Wireless Basic settings
2. Remove 'Configure the second IP Address and Subnet Mask for LAN' from Local network settings
3. Go to Advanced Wireless - Turn User Isolation off (if you want airplay to work from iphone to apple tv)
4. Turn User Isolation ON - if you want Airplay to work from PC (Wired) to Apple tv
5. Make sure your country is set to United Arab Emirates (Best setting so far)

The User isolation setting affects with Bonjour services; if its OFF wifi devices can see each other if ON then only Wired devices will be able to see Wifi devices

Try it out & let me know.

J

Your linked solution only works with wireless clients on the same band. I have issues with an iPhone on the 5GHz band and an AirPlay playback unit on wired ethernet.
Logged
Pages: 1 [2] 3