• November 20, 2019, 03:09:48 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: [1] 2 3

Author Topic: Issue with AirPlay - Proper PortForwarding is Setup  (Read 19902 times)

JoshDi

  • Level 1 Member
  • *
  • Posts: 12
Issue with AirPlay - Proper PortForwarding is Setup
« on: April 30, 2014, 12:41:41 PM »

I am having an issue with my DIR-868L router with FW 1.07.

I have the following UDP/TCP ports forwarded correctly: 80,443,554,1900,3813,3689,5020,5297,5298,5350,5351,5353,8080,10443,49152-58049,58052-65535

I also have IPv4 Multicasting ON and SPI OFF.

AirPlay works correctly when using a different router. My Wireless Adapter has IPV6 and QoS disabled on my computer.

I noticed with FW 1.07 that WMM mode cannot be disabled. The box is grayed out.  I believe this is the problem.

How can I disable WMM? Does anyone have any other ideas how to get this working?

Thank you for your help!

Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47915
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Issue with AirPlay - Proper PortForwarding is Setup
« Reply #1 on: April 30, 2014, 12:46:17 PM »

    Link>
Welcome!

  • What region are you located?

D-Link routers most have this enabled by default and it's been grayed out with out any ability to configure it. I believe it's either due to WiFi setting dependency or requirement for WMM or by design of this feature. Can you try setting single mode G, WPA and TPIK only with Auto 20/40 or 20Mhz only and enable HT-20/40Mhz co-existence under Advanced/Adv WiFi settings if you have it? Then try to disable WMM.

Wireless Configurations
Links>Wireless Installation Considerations and Managing Signal Congestion and Good Neighbour Policy
  • Ensure the default (dlink) SSID name is changed. Can be anything and not something that's already in use by any neighboring WiFi routers. Under Setup/Wireless/Manual.
  • What wireless modes are you using?
  • 2.4Ghz Routers only: Try single mode G or N or mixed G and N?

PC Web Browser Configurations
What browser are you using?
Try Opera or FF? If IE 8, 9, 10 or 11, set compatibility mode and test again.
Disable any security browser Add-ons like No Script and Ad-Block or configure them to allow All Pages when connected to the router.
Clear all browser caches.
Be sure to log into the Admin account on the router.
Try turning off these features in Chrome:
Top right corner, little bars for options > Settings > Settings (on left) > Show advanced settings.
Uncheck these:
Use a web service to help resolve navigation errors
Use a prediction service to help complete searches and URLs typed in the address bar
Predict network actions to improve page load performance
Enable phishing and malware protection


Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

JoshDi

  • Level 1 Member
  • *
  • Posts: 12
Re: Issue with AirPlay - Proper PortForwarding is Setup
« Reply #2 on: April 30, 2014, 01:14:22 PM »

What region are you located?

I am in the United States

D-Link routers most have this enabled by default and it's been grayed out with out any ability to configure it. I believe it's either due to WiFi setting dependency or requirement for WMM or by design of this feature. Can you try setting single mode G, WPA and TPIK only with Auto 20/40 or 20Mhz only and enable HT-20/40Mhz co-existence under Advanced/Adv WiFi settings if you have it? Then try to disable WMM.

  • I am using 5.4GHz (802.11AC only) and 2.4GHz (Mixed 802.11n and 802.11g)
  • Channel with is set to Auto 20/40 MHz for both networks (20/40/80 MHz for 5.4GHz)
  • WPA Mode is set to WPA2 Only using AES Cipher

PC Web Browser Configurations
What browser are you using?
Try Opera or FF? If IE 8, 9, 10 or 11, set compatibility mode and test again.
Disable any security browser Add-ons like No Script and Ad-Block or configure them to allow All Pages when connected to the router.
Clear all browser caches.
Be sure to log into the Admin account on the router.
Try turning off these features in Chrome:
Top right corner, little bars for options > Settings > Settings (on left) > Show advanced settings.
Uncheck these:
Use a web service to help resolve navigation errors
Use a prediction service to help complete searches and URLs typed in the address bar
Predict network actions to improve page load performance
Enable phishing and malware protection


All of these options are disabled and no add-ons are enabled for Chrome or Internet Explorer.
WMM is still grayed out with any Security Mode and Cipher Type is chosen
I have also tried to have no security enabled, Auto Channel Scan Off and only 802.11g.

Airplay still wont work


Logged

JoshDi

  • Level 1 Member
  • *
  • Posts: 12
Re: Issue with AirPlay - Proper PortForwarding is Setup
« Reply #3 on: April 30, 2014, 01:19:42 PM »

Additionally, I tried to directly connect my computer with an Ethernet cord. Airplay is not found when using the DIR-868L router, but it is found almost instantly when using a different router.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47915
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Issue with AirPlay - Proper PortForwarding is Setup
« Reply #4 on: April 30, 2014, 01:31:21 PM »

I recommend that you phone contact your regional D-Link support office and ask for help and information regarding this. We find that phone contact has better immediate results over using email. I'll forward this on to D-Link as well as others have asked about this. I'll post back if I get any info.
 
Let us know what you find out please.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

JoshDi

  • Level 1 Member
  • *
  • Posts: 12
Re: Issue with AirPlay - Proper PortForwarding is Setup
« Reply #5 on: April 30, 2014, 01:33:41 PM »

I recommend that you phone contact your regional D-Link support office and ask for help and information regarding this. We find that phone contact has better immediate results over using email. I'll forward this on to D-Link as well as others have asked about this. I'll post back if I get any info.
 
Let us know what you find out please.

I have called D-Link. They suggested that I reset the configuration on my router (which I did). With switching around many of the settings you suggested (and the ones I switched around) and adding the port forwarding, they still could not find a resolution.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47915
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Issue with AirPlay - Proper PortForwarding is Setup
« Reply #6 on: April 30, 2014, 02:09:34 PM »

Ok, seems like the check box is a FW issue. I've asked about this and will post when I get something back if I can. No guarantees.

Only work around suggestion until then, maybe to hook up your other WiFi router and configure it as an AP maybe and use it as your point of connect with the Airplay devices...

Please be patient.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

JoshDi

  • Level 1 Member
  • *
  • Posts: 12
Re: Issue with AirPlay - Proper PortForwarding is Setup
« Reply #7 on: April 30, 2014, 03:04:22 PM »

Ok, seems like the check box is a FW issue. I've asked about this and will post when I get something back if I can. No guarantees.

Only work around suggestion until then, maybe to hook up your other WiFi router and configure it as an AP maybe and use it as your point of connect with the Airplay devices...

Please be patient.

Thank you for your help thus far. I will hold tight until we get some more information back from D-Link
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47915
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Issue with AirPlay - Proper PortForwarding is Setup
« Reply #8 on: May 01, 2014, 08:28:31 AM »

It's in D-Links hands and under review. I don't know if or when we might see information or changes.

I recommend that you phone contact your regional D-Link support office and ask for help and information regarding this. We find that phone contact has better immediate results over using email. While posting issues in this forum is a great means of sharing information with other members and notifying D-Link of issues, D-Link escalates issues for resolution based on the volume of calls received through the official D-Link support desk. If D-Link receives a large number of calls pertaining to the same issue, that issue is more likely to be escalated as a problem for investigation and resolution.
As such, in addition to posting issues in this forum, forum members are encouraged to call the toll free D-Link support desk to report their issue: 1-888-851-6464.

We thank you for your patience.

« Last Edit: May 01, 2014, 10:14:16 AM by FurryNutz »
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

JoshDi

  • Level 1 Member
  • *
  • Posts: 12
Re: Issue with AirPlay - Proper PortForwarding is Setup
« Reply #9 on: May 09, 2014, 12:14:47 PM »

It's in D-Links hands and under review. I don't know if or when we might see information or changes.

I recommend that you phone contact your regional D-Link support office and ask for help and information regarding this. We find that phone contact has better immediate results over using email. While posting issues in this forum is a great means of sharing information with other members and notifying D-Link of issues, D-Link escalates issues for resolution based on the volume of calls received through the official D-Link support desk. If D-Link receives a large number of calls pertaining to the same issue, that issue is more likely to be escalated as a problem for investigation and resolution.
As such, in addition to posting issues in this forum, forum members are encouraged to call the toll free D-Link support desk to report their issue: 1-888-851-6464.

We thank you for your patience.



Has there been any update to this issue? Has anyone else been experiencing these issues?
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47915
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Issue with AirPlay - Proper PortForwarding is Setup
« Reply #10 on: May 09, 2014, 12:19:50 PM »

There hasn't been any info. D-Link said they would review this and that was it.

I would recommend that you phone contact D-Link support and ask for level 2 or higher and let them know about this. I have made my observations regarding the inaccessibility of the WMM check box as I've see it grayed out on other model routers as well. I presume this maybe by optimal use and design. However I do agree, it should be selectable if it's going to be there. I've never had a need to use it and most of my testing and experiences have worked with it. However this is not to say the this doesn't cause the issue with Airplay since I don't use that for streaming music.

Can you detail us what is needed for airplay and any other configurations? I do have iPhones and a Mac Mini and Mac Book Pro that I could set up for Airplay If not much else is needed and see if I can help you test this out. Let us know the steps to take to get this up.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47915
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Issue with AirPlay - Proper PortForwarding is Setup
« Reply #11 on: May 09, 2014, 01:02:03 PM »

I see your looking at this:
http://forums.dlink.com/index.php?topic=46601.0

Let us know if setting Transmission Rate to 54 results in anything...

How is the AE set up? AP or Bridge Mode?
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

JoshDi

  • Level 1 Member
  • *
  • Posts: 12
Re: Issue with AirPlay - Proper PortForwarding is Setup
« Reply #12 on: May 13, 2014, 10:15:15 AM »

No dice :(

I have the DLink router directly setup as a WAN router to my FIOS fiber connection. The Verizon Actiontec router is setup as a bridge LAN to LAN behind the DLink router. It is setup exactly like the following How-To: http://www.dslreports.com/faq/15993

I decided to flash DD-WRT on the DLINK and Airplay now works perfectly. There is a problem with the WMM specifications/Firewall on the DLINK firmware. I have WMM set to ON when using the DD-WRT firmware and I am not having any issues.

I am going to stick with the custom firmware... the router is running much, much smoother and DD-WRT gives me a lot more features for this powerful hardware platform.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47915
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Issue with AirPlay - Proper PortForwarding is Setup
« Reply #13 on: May 13, 2014, 10:17:09 AM »

Glad you got it working well. I'll pass this configuration information on to D-Link for review.

Enjoy.
 ;)
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

JoshDi

  • Level 1 Member
  • *
  • Posts: 12
Re: Issue with AirPlay - Proper PortForwarding is Setup
« Reply #14 on: May 13, 2014, 10:20:55 AM »

Glad you got it working well. I'll pass this configuration information on to D-Link for review.

Enjoy.
 ;)

I'm glad it is working as well. If I use the ActionTec as the router (DLINK router not installed), Airplay works.

The DLink router does not work with Airplay regardless if the ActionTec router is setup in the previous bridge setup or if it is not installed at all. This issue is specific to the DLink v1.07 firmware. I hope the Dlink support team can resolve this for other users.

Thank you for following up on this for me.
Logged
Pages: [1] 2 3