• October 30, 2020, 09:59:35 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: [1] 2

Author Topic: DSL-2750U and POP mail on a Mac  (Read 14566 times)

kmiler12

  • Level 1 Member
  • *
  • Posts: 7
DSL-2750U and POP mail on a Mac
« on: July 10, 2013, 08:26:58 AM »

I have just bought and connected a DSL-2750U router to my iMac but, in Mail, I cannot connect consistently to my POP3 server via port 110. Surfing the net is fine. It seems to wait for connection to the POP server and then after anything from 1 hour to days, will download all mail at once. Same with cable or wireless connection. I have np problem connecting to the SMTP server.

If I use a Windows computer, all is fine.

I have changed cables and router to no avail.

Any ideas?
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49298
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DSL-2750U and POP mail on a Mac
« Reply #1 on: July 10, 2013, 08:30:49 AM »

If windows PC is working and surfing is fine, I would presume that the area you need to review is either networking or the configuration of the email program on the iMac.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

kmiler12

  • Level 1 Member
  • *
  • Posts: 7
Re: DSL-2750U and POP mail on a Mac
« Reply #2 on: July 10, 2013, 12:02:01 PM »

Surfing on the iMac is also fine with no problems. I have full internet access. Any suggestions re the networking and iMac settings to resolve this. Problem is that the CD that comes with the router can only be played on a Windows machine so I had to configure the router from a Windows XP laptop before connecting the iMac.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49298
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DSL-2750U and POP mail on a Mac
« Reply #3 on: July 10, 2013, 12:13:17 PM »

I don't think you need the CD to set up the modem if the modem already had a on board set up wizard. Can you log into the modems web page at 192.168.0.1 or is it .1.1 using Safari or FF or Opera?

I don't have any suggestions for Mac Mail as I don't use it. I use Thunderbird for Mac for my email program.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

kmiler12

  • Level 1 Member
  • *
  • Posts: 7
Re: DSL-2750U and POP mail on a Mac
« Reply #4 on: July 11, 2013, 12:56:56 AM »

Received mail this morning but one hour later received the following message:

"The server returned the error: The server “pop3.telkomsa.net” cannot be contacted on port 110."

Does this not indicate a problem at Telkom's end?

They cannot help as they have little knowledge of Macs.

Gmail works fine.
Logged

Grem

  • Level 1 Member
  • *
  • Posts: 20
  • regular citizen
Re: DSL-2750U and POP mail on a Mac
« Reply #5 on: July 11, 2013, 01:15:38 AM »

Could be.

I'm not Telkom's user, but right now pop3.telkomsa.net is working... at least I can connect to it.
Logged

kmiler12

  • Level 1 Member
  • *
  • Posts: 7
Re: DSL-2750U and POP mail on a Mac
« Reply #6 on: July 15, 2013, 01:50:26 PM »

I have had a long correspondence with Apple and have re-installed OS X on my hard drive. Still got the problem. I have discovered that the problem seems to be linked to the power saving feature on the Mac. If I allow the hard drive to sleep, I lose contact with the POP server (and Gmail) on waking up the computer. As there are others in the house using wireless connections, I have given the Mac a static address but this, on its own, did not help. If I never allow the Mac to sleep, all stays fine. Is there something on the router that doesn't like the Mac going off and then re-applying for a network address when it comes back on?
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49298
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DSL-2750U and POP mail on a Mac
« Reply #7 on: July 15, 2013, 01:54:39 PM »

The problem could be attributed to the LAN or WLAN connections on the Mac during the transitioning of the Power Saving mode. The data flow is always a constant on the Modem, unless the connection is interrupted on the client device. So if there is power saving going on with the Mac, seem that the Mac isn't waking it's connecting devices correctly and reconnecting fully with the Modem and with the POP services.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

kmiler12

  • Level 1 Member
  • *
  • Posts: 7
Re: DSL-2750U and POP mail on a Mac
« Reply #8 on: July 15, 2013, 02:02:06 PM »

Thanks.

Perhaps I should forward your response to the Apple support team. Do you think that it will be necessary for them to slightly modify their OS X to overcome this?
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49298
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DSL-2750U and POP mail on a Mac
« Reply #9 on: July 15, 2013, 02:04:50 PM »

I would test your Mac out on either a different modem/router or different router, say at a friends place or family? I would presume if the problem follows then could be with Mac. Again you have a different device that is working so it leads me to think there is something going on with the Mac.

What region are you located?
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

kmiler12

  • Level 1 Member
  • *
  • Posts: 7
Re: DSL-2750U and POP mail on a Mac
« Reply #10 on: July 15, 2013, 02:12:22 PM »

South Africa.

The problem started when I received a new router from Telkom about 6 weeks ago, the 2750U. Previously, I had a Telkom ADSL 5102G (and still have it).

The old router had no problems, even with the power saving. If I switch back, everything works well.

However, I want to stay with the 2750U because its wireless range is greater.

If I use the new router with Windows or via wireless with my iPhone, I can send and receive mail to the Telkom servers, even at the same time when the Mac cannot.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49298
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DSL-2750U and POP mail on a Mac
« Reply #11 on: July 15, 2013, 02:23:13 PM »

Possibly compatibility with the Mac and the Modem. I would ask if the ISP handles the FW updates, to see if they have a more up to date FW that could be used. If not, I recommend phone contacting D-Link support for your region and ask them if there is some recent FW available and to see if there is any configurations that might help with the Mac.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

kmiler12

  • Level 1 Member
  • *
  • Posts: 7
Re: DSL-2750U and POP mail on a Mac
« Reply #12 on: July 15, 2013, 02:29:22 PM »

I did check the latest FW (firmware) and found a later version. I have installed it on the router.

The local support were not much help; they simply stated that there can be nothing wrong with the modem. 

It seemed a logical response to me if the modem was communicating with the POP server OK from Microsoft Outlook and from my iPhone.

That is why I contacted Apple.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49298
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DSL-2750U and POP mail on a Mac
« Reply #13 on: July 18, 2013, 07:16:47 AM »

It does seem like something on the Mac isn't configured correctly though.
Keep us posted.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

DJ_Kliche

  • Level 1 Member
  • *
  • Posts: 2
Re: DSL-2750U and POP mail on a Mac
« Reply #14 on: October 08, 2013, 11:24:32 PM »

Hi,

I am having the same problem with the same router (DSL-2750U). Any solutions would be greatly appreciated.

It is not just pop mail, but also IMAP and Exchange. Email will work fine when I first log in in the morning, but intermittently various emails will lose connection until they are all lost. The only way to fix it is to restart the macbook.

This is a brand new router, my old router still works fine and doesn't lose connection. Etisalat (the terrible telecommunications company in the UAE) who sold me the router, say it is working fine as it holds a connection on their PC (and mine), so they won't allow me to return it and give me my money back. But it won't work with all macbooks in my house - they say it must be a problem with my macs, but as I said before, no problems with my old router.

Regards, Damien.
Logged
Pages: [1] 2