• October 29, 2020, 04:23:34 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: [1] 2

Author Topic: WMM Lag Spikes  (Read 18304 times)

squared

  • Level 1 Member
  • *
  • Posts: 10
WMM Lag Spikes
« on: January 01, 2013, 12:39:10 PM »

I'm currently running 1.21NA which I believe is the newest for my revision.  I recently upgraded my fios to 50/25 from 20/5.  The wired computer gets ~56Mbps/~34Mbps on average, the wireless gets ~29Mbps/33Mbps on average.  Why is the upload higher?

The wireless computer uses a Rosewill RNX-N2X Wireless N Adapter.  When I check off "WMM Enable" (left disabled in the past), I get the full speeds like I assume should be the case because of N and the transfer speeds and blah blah.  This however gives me slight delay and random minor lag spikes every few minutes in all types of computer games.  All of my testing has been done with only the single wireless computer on the network, and is fine without having WMM on, but then my download speed is capped under 30 Mbps.  Signal quality always hovers above 85% and has always been perfect for years. 

I have turned on and off Short GI, Extra WP, changed channels, etc.

Just wondering if my choice truly is faster download speeds OR lag during games.  Any ideas?  ???
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49298
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: WMM Lag Spikes
« Reply #1 on: January 01, 2013, 04:22:06 PM »

What Hardware version is your router? Look at sticker under router.

Link>Wireless Installation Considerations
What wireless modes are you using? Under Setup/Wireless/Manual.
Try single mode G or mixed G and N on 2.4Ghz and single mode N on 5Ghz?
Channel Width set for Auto 20/40Mhz or try 20Mhz only.
Try setting a manual channel to a open or unused channel. 1, 6 or 11. 11 for single mode N if the channel is clear.
What security mode are you using? Preferred security is WPA-Personal. WPA2/AES Only. Some WiFi adapters don't support AES, so you might want to try TPIK only or Auto.
What wireless devices do you have connected?
Any cordless house phones?
Any other WiFi routers in the area? Link> Use InSSIDer to find out. How many?

Turn off WISH, and WPS under Advanced.
Try turning off Short GI, WLAN Partition,and Extra Wireless Protection if you have it. Under Advanced/Advanced Wireless.
Enable WMM Enable Under Advanced/Advanced Wireless.
Turn off all anti virus and firewall programs on PC while testing. 3rd party firewalls are not generally needed when using routers as they are effective on blocking malicious inbound traffic.
Turn off all devices accept for one wired PC while testing.

Some things to try: - Log into the routers web page at 192.168.0.1. Use IE, Opera or FF to manage the router.
Turn off ALL QoS or Disable Traffic Shaping (DIR only) GameFuel (DGL only and if ON.) options. Advanced/QoS or Gamefuel.
Turn off Advanced DNS Services if you have this option under Setup/Internet/Manual.
Turn on DNS Relay under Setup/Networking.
Setup DHCP reserved IP addresses for all devices ON the router. Setup/Networking. This ensures each devices gets its own IP address when turned on and connected, eliminates IP address conflicts and helps in troubleshooting.
Ensure devices are set to auto obtain an IP address.
Set Firewall settings to Endpoint Independent for TCP and UDP under Advanced/Firewall.
Enable uPnP and Multi-cast Streaming under Advanced/Networking. Disable uPnP for testing Port Forwarding rules.
WAN Port Speed set to Auto or specific speed? Some newer ISP modems support 1000Mb so manually setting to Gb speeds can be supported by the router. Advanced/Advanced Networking/WAN Port Speed
Set Time and Time Zone under Tools/Time.

Actually v1.23 is the last and latest version however let us know what Rev HW your router is before thinking about updating.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

squared

  • Level 1 Member
  • *
  • Posts: 10
Re: WMM Lag Spikes
« Reply #2 on: January 01, 2013, 05:47:34 PM »

Its an A1, sorry should of mentioned that.

I've tried all the modes, but am currently using n+g mixed.

Tried changing channel width.

I've tried channel 1, 6, and 11.  1 is the best for me based on neighbors and line quality.  3 routers in the area but about 1% signal at best, two channel 11 one channel 6.

Using WPA Personal -> WPA2 and AES

Tried with just the wireless computer and no other devices.

No cordless phones.

WISH and WPS are off and never been used.

Gamefuel is off.

Used all combinations of the advanced wireless settings.

Test computer has no anti virus/anti spyware/firewall software.  Windows firewall disabled.

Advanced DNS off.  Tried DNS relay off and on didn't see any changes.

Both computers have reserved addresses.

Firewall settings are Endpoint Independent

UPnP has always been on.  Didn't notice any changes with multicast streaming on, currently off.

WAN port speed is set to AUTO.  Have not tried changing yet.

I changed the date/time.


I've done some searching on the forum so I tried most of the basics, still stumped :(
« Last Edit: January 01, 2013, 07:36:53 PM by squared »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49298
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: WMM Lag Spikes
« Reply #3 on: January 01, 2013, 08:53:20 PM »

Well there was and issue with router hang on the A1s with v1.21. Doesn't seem like this is the case. You could update to v1.23 however lets check to see if changing the channels will help here first.

Ensure the wireless adapter drivers are up to date as well on the devices that use drivers.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

squared

  • Level 1 Member
  • *
  • Posts: 10
Re: WMM Lag Spikes
« Reply #4 on: January 02, 2013, 05:00:20 AM »

I already tried changing the channels and didn't see any different results besides slightly less signal strength.  The speeds still never pass 30Mbps down.  

Everything functions perfectly, no drops or connectivity issues with WMM off.  With WMM on there is also no drops or big issues, only the slight latency delays I spoke of earlier during games.  Browsing/Streaming/Torrenting function fine at full speeds (50Mbps+).

I have tried the built in auto-detect Win7 drivers for the adapter, as well as using the ones from the manufacturer, noticed no difference.

I don't understand why with WMM off the download speeds caps under 30 Mbps, yet the upload goes to 33 Mbps+ just fine.  I understand how WMM/QoS functions and why this could be causing my delays in games, however it seems like the only way to achieve better speeds wirelessly.


Edit:

This is with WMM OFF:

Will add WMM ON somewhat soon currently running out the door.
« Last Edit: January 02, 2013, 05:22:42 AM by squared »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49298
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: WMM Lag Spikes
« Reply #5 on: January 02, 2013, 12:14:28 PM »

Are there any other wifi devices online while your gaming over WiFi?
I would recommend either not allowing other devices online while your gaming on Wifi?
I would recommend gaming on wired LAN if possible.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

squared

  • Level 1 Member
  • *
  • Posts: 10
Re: WMM Lag Spikes
« Reply #6 on: January 02, 2013, 03:31:32 PM »

Are there any other wifi devices online while your gaming over WiFi?
I would recommend either not allowing other devices online while your gaming on Wifi?
I would recommend gaming on wired LAN if possible.

Tested with no devices connected at all for hours, no improvement.

Of course I'd use wired, if I could, however it isn't possible due to the housing setup.  I guess I'm just out of luck with the router, time to move on, thanks anyway!
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49298
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: WMM Lag Spikes
« Reply #7 on: January 02, 2013, 03:37:31 PM »

One thing you can do is to update the routers FW.

Does this happen w other devices beside the one. You need to test a different device to see it it does the same.
I would recommend taking the router to a friend or families place that are in a different location to see if the problem follows or not.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

squared

  • Level 1 Member
  • *
  • Posts: 10
Re: WMM Lag Spikes
« Reply #8 on: January 02, 2013, 03:55:40 PM »

I have 1 desktop and 2 laptops.  I have been testing with the wireless desktop mainly, and secondly with one of the laptops, the result is the same with both.  I mainly use the desktop because it is a freshly built PC with a new clean Win7 install.

I'm going to try the firmware.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49298
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: WMM Lag Spikes
« Reply #9 on: January 02, 2013, 04:03:33 PM »

Please factory reset the router before sending the .bin file and do one more after. Then setup the router from scratch. I recommend testing the wifi before you confure the router after the last reset to see if the problem
is there.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49298
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: WMM Lag Spikes
« Reply #10 on: January 02, 2013, 04:08:36 PM »

And please use IE browser for sending the update. Chrome has been know to cause problems.
« Last Edit: January 02, 2013, 04:10:10 PM by FurryNutz »
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49298
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: WMM Lag Spikes
« Reply #11 on: January 02, 2013, 04:12:09 PM »

Another item i remembered, disable all IPv6 options on the PCs. This router does not support IPv6 and have seen some issues with some PCs w it enabled.
« Last Edit: January 02, 2013, 05:18:50 PM by FurryNutz »
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

squared

  • Level 1 Member
  • *
  • Posts: 10
Re: WMM Lag Spikes
« Reply #12 on: January 02, 2013, 07:23:00 PM »

Another item i remembered, disable all IPv6 options on the PCs. This router does not support IPv6 and have seen some issues with some PCs w it enabled.

Just tried disabling IPv6, no effect.  Will be updating firmware as you stated tomorrow.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49298
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: WMM Lag Spikes
« Reply #13 on: January 03, 2013, 12:33:20 PM »

Please follow: FW Update Process
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49298
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: WMM Lag Spikes
« Reply #14 on: January 05, 2013, 11:51:18 AM »

One other thing to try if you have a 5Ghz supporting client, does this happen on 5Ghz single mode N only?
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!
Pages: [1] 2