• September 19, 2019, 12:25:23 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: 1 ... 3 4 [5]

Author Topic: fan starts after spindown and doesn't stop  (Read 49646 times)

goldeneye77

  • Level 1 Member
  • *
  • Posts: 6
Re: fan starts after spindown and doesn't stop
« Reply #60 on: April 12, 2010, 06:02:59 PM »

Ok, seems like I could narrow down the problem to Power LED control. As soon as I switch off (such that the blue Power LED won't light anymore) and reboot the DNS, the fan woun't be able to stop anymore. I was able to get it running again by enabling the Power LED control again (including reboot) without reset to factory default settings!
You would propose everyone of you to give it a try and post if it works. Would probably also help the developers to fix this issue.

So what exactly are the steps to have the drives hibernate and the fans turn off (too)?  Disable LED > Reboot > Enable LED > Reboot ??
Logged

slyght

  • Level 1 Member
  • *
  • Posts: 10
Re: fan starts after spindown and doesn't stop
« Reply #61 on: April 12, 2010, 11:40:18 PM »

Actually I don't know :(

Seems like there are actually two different problems regarding the fan.

1.) The fan woun't be able to stop, if Power LED control is switched off (onl yoccurs after a reboot).
You can see a log entry about it right after the reboot.

2.) The fan woun't be able to stop, as soon as HDDs hibernate. Yesterday, when I last rebooted the DNS, the DNS went on and the fan stopped immediately after the reboot, so I thought everything is fine. But in fact as soon as the HDDs went in hibernate mode the fan started! This is really weird :/ It looks like the fan woun't stop anymore even if the HDDs are activated again.
Just a guess: The temperature is at ~35C and probably the fan would stop again, as soon as the temperature goes above 46C and then below 43C again such that the thresholds will be triggered.

Btw: Deactivating HDD hibernation stopped the fan, too, but this woun't help very much.
Logged

gunrunnerjohn

  • Level 11 Member
  • *
  • Posts: 2717
Re: fan starts after spindown and doesn't stop
« Reply #62 on: April 13, 2010, 05:26:49 AM »

Having programmed embedded systems for over 20 years, it escapes me how they managed to connect the fan to other events!  This should be dirt simple, temperature too high, run the fan!  ???
Logged
Microsoft MVP - Windows Desktop Experience
Remember: Data you don't have two copies of is data you don't care about!
PS: RAID of any level is NOT a second copy.

goldeneye77

  • Level 1 Member
  • *
  • Posts: 6
Re: fan starts after spindown and doesn't stop
« Reply #63 on: April 13, 2010, 06:35:57 PM »

Having programmed embedded systems for over 20 years, it escapes me how they managed to connect the fan to other events!  This should be dirt simple, temperature too high, run the fan!  ???

it is odd isn't it??? I (and I assume others) have wondered the exact same thing . . .  :-\
Logged

En3rGy

  • Level 1 Member
  • *
  • Posts: 20
Re: fan starts after spindown and doesn't stop
« Reply #64 on: April 13, 2010, 10:39:55 PM »

I played with settings for fan control, hdd hibernation and the "fancontrol" command:

  • Kill the fancontrol process (e.g. via telnet), set (via web interface) hdd hibernation on and fan control to auto, safe - the fancontrol process restarts ("ps | grep fan" via telnet)
  • Kill fancontrol process, hdd hibernation off, fan control to manual, safe - no fancontrol process available
  • Kill fancontrol process, hdd hibernation off, fan control to auto, safe - fancontrol process restarted
  • Kill fancontrol process, hdd hibernation on, fan control to manual, safe - fancontrol process restarted

Look's like hdd hibernation and fan control is managed by a buggy (at least for C1 hardware) "fancontrol".
 
Logged

Ianaber

  • Level 1 Member
  • *
  • Posts: 13
Re: fan starts after spindown and doesn't stop
« Reply #65 on: April 20, 2010, 12:55:36 AM »

It would be nice to hear that D-Link is working on this and we expect a new firmware soon..

Yes, I agree.  I have the same problem with C1 hardware.  Would be nice to see at least a beta fix. :(
Logged

mihies

  • Level 2 Member
  • **
  • Posts: 29
Re: fan starts after spindown and doesn't stop
« Reply #66 on: April 29, 2010, 02:46:29 PM »

Another one with the same problem on C1/1.07.
It was odd to me that fan was running until I read this forum thread. Now I just turned off hibernation. Starting and stopping disks hurt them anyway.
Logged

En3rGy

  • Level 1 Member
  • *
  • Posts: 20
Re: fan starts after spindown and doesn't stop
« Reply #67 on: April 29, 2010, 11:35:58 PM »

I'm thinking about to claim my C1 hw to get a B1 version.
What - beside the fan bug - are the differences between a1, b1, and c1?
Logged

gunrunnerjohn

  • Level 11 Member
  • *
  • Posts: 2717
Re: fan starts after spindown and doesn't stop
« Reply #68 on: April 30, 2010, 05:07:33 AM »

Well, C1 has the capability of auto-recovery after power failure.
Logged
Microsoft MVP - Windows Desktop Experience
Remember: Data you don't have two copies of is data you don't care about!
PS: RAID of any level is NOT a second copy.

mardelzur

  • Level 1 Member
  • *
  • Posts: 1
Re: fan starts after spindown and doesn't stop
« Reply #69 on: May 03, 2010, 07:28:36 PM »

Hi All

Have the same issue here too - C1 hardware on 1.08 firmware.

A factory reset (via the pin hole at the back of the unit) seemed to fix this for a while but the problem reappears after a few days.

I have a temporary work around for this (temporary because once the drive come out of hibernation and then go back to sleep again, the fan issue reappears).

With the drives in hibernation, go into the web interface and set the drives to never sleep and apply. The fan will then spin up to max and then drop down again to low spin. Then, set the drives to sleep again (I use 5min) and then voila, the fan spins down.

Can anyone else confirm this?

D-Link - please fix this as it is VERY annoying.  >:(

I have another B1 unit and it works perfectly. Starting to wish I had bought two B1's at the time.....
Logged

D-Link Multimedia

  • Poweruser
  • Level 7 Member
  • **
  • Posts: 1066
    • D-link Systems, Inc.
Re: fan starts after spindown and doesn't stop
« Reply #70 on: May 04, 2010, 12:08:19 PM »

We are aware of the issue on the C1 hardware and it will be corrected in 1.10 firmware (which should quickly follow up the 1.09 firmware which is only for Ctera Cloud Backup Support).

Thank you all for your posts and we will update you as 1.10 release nears.
« Last Edit: May 05, 2010, 09:12:21 AM by ECF »
Logged
Pages: 1 ... 3 4 [5]