• December 07, 2019, 09:09:30 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: 1 [2] 3 4 5

Author Topic: fan starts after spindown and doesn't stop  (Read 50038 times)

En3rGy

  • Level 1 Member
  • *
  • Posts: 20
Re: fan starts after spindown and doesn't stop
« Reply #15 on: March 14, 2010, 07:22:28 AM »

Entering the settings manually after upgrade, reboot and reset didn't help.

By the way, setting the fan controller parameter on the power management page (auto1, auto2, manual) results in NAS reaction.
But there seems no difference between
  • "auto (off/low/high)" and
  • "auto (low/high)"
Logged

gunrunnerjohn

  • Level 11 Member
  • *
  • Posts: 2717
Re: fan starts after spindown and doesn't stop
« Reply #16 on: March 14, 2010, 08:06:00 AM »

The settings are a bit "flaky".  I finally had to do a factory reset, a manual reconfiguration, and then the fan controls seem to work properly.
Logged
Microsoft MVP - Windows Desktop Experience
Remember: Data you don't have two copies of is data you don't care about!
PS: RAID of any level is NOT a second copy.

En3rGy

  • Level 1 Member
  • *
  • Posts: 20
Re: fan starts after spindown and doesn't stop
« Reply #17 on: March 14, 2010, 09:35:27 AM »

The settings are a bit "flaky".

What's flaky in detail?

What hardware revision do you own?
Logged

gunrunnerjohn

  • Level 11 Member
  • *
  • Posts: 2717
Re: fan starts after spindown and doesn't stop
« Reply #18 on: March 14, 2010, 01:42:36 PM »

"Flaky" means that without resetting to factory defaults, you can't get the fan control working properly.  Add to the fact that there is no way to easily save your configuration and restore it for new firmware or other things like this problem, makes it a PITA to fix things like this.  Although I don't think it's all that significant, I have B1 hardware.
Logged
Microsoft MVP - Windows Desktop Experience
Remember: Data you don't have two copies of is data you don't care about!
PS: RAID of any level is NOT a second copy.

En3rGy

  • Level 1 Member
  • *
  • Posts: 20
Re: fan starts after spindown and doesn't stop
« Reply #19 on: March 14, 2010, 02:43:27 PM »

Regarding the "Flaky" I was just wondering if I missed / forgot something...

Look's like the default fan controller never stops, independent of hardware revision (at least b1 and c1).

@gunrunnerjohn: You got a script doing the job? Does the HDDs hibernate if you run your script? Could you publish it?
Logged

gunrunnerjohn

  • Level 11 Member
  • *
  • Posts: 2717
Re: fan starts after spindown and doesn't stop
« Reply #20 on: March 14, 2010, 02:52:00 PM »

No script, no patches, just 1.08 with a factory reset and manual reconfiguration.  I just looked, and my DNS-323 fan is stopped, and the drives are hibernating.
Logged
Microsoft MVP - Windows Desktop Experience
Remember: Data you don't have two copies of is data you don't care about!
PS: RAID of any level is NOT a second copy.

En3rGy

  • Level 1 Member
  • *
  • Posts: 20
Re: fan starts after spindown and doesn't stop
« Reply #21 on: March 15, 2010, 01:00:31 PM »

I did the whole stuff again (1.08 firmware download, dated 12/18/2009, update, factory reset) but still without success. The fan spins up, stops and restarts with low speed at ~42° C. Later the plates hibernate and the NAS cools down but never stops anymore...

The only difference I can find is the hardware release. For better comparison, I post my NAS parameter:

H/W revisionC1
Firmware1.08, dated 12/19/2009
HDDs2 x Western Digital WD 5000AADS 500 GB Caviar Green, RAID1
Logged

gunrunnerjohn

  • Level 11 Member
  • *
  • Posts: 2717
Re: fan starts after spindown and doesn't stop
« Reply #22 on: March 15, 2010, 01:26:14 PM »

Perhaps the C1 hardware has a problem?  Just checked again, drives are sleeping and the fan is stopped.  Temperature 96F/36C.
Logged
Microsoft MVP - Windows Desktop Experience
Remember: Data you don't have two copies of is data you don't care about!
PS: RAID of any level is NOT a second copy.

Buhric

  • Level 3 Member
  • ***
  • Posts: 191
Re: fan starts after spindown and doesn't stop
« Reply #23 on: March 15, 2010, 10:04:19 PM »

I did the whole stuff again (1.08 firmware download, dated 12/18/2009, update, factory reset) but still without success. The fan spins up, stops and restarts with low speed at ~42° C. Later the plates hibernate and the NAS cools down but never stops anymore...

did you select "off/Low/High" or just "Low/High"
for the fan settings ?
Logged

En3rGy

  • Level 1 Member
  • *
  • Posts: 20
Re: fan starts after spindown and doesn't stop
« Reply #24 on: March 15, 2010, 11:31:55 PM »

After a factory reset "auto (off/low/high)" is set by default.
As described, the fan spins up at start up, stops, spins up somewhere at 43° C and keeps spinning, not regarding lower temperature (32°C).

For an "active" setting of this option I set the fan to "auto (low/high)". After saving, the fan starts immediately spinning. By the way if you kill the "fancontrol" process before saving the fan control setting, the process is restarted afterwards. This holds also for the hibernating setting (--> "fancontrol" is also responsible for hibernating the plates).
Finally I set the fan back to "auto (off/low/high)" followed by the same behavior as for "auto (low/high)".

By the way, it's quite annoying, waiting for the NAS to heat and cool down...  :)

In "/sbin" is a file called "fan.script". The script explains the start up behavior:
Code: [Select]
#temperature w 1 43
#sleep 1
#temperature w 2 47
#sleep 1
fanspeed s
sleep 1
fanspeed l
sleep 5
fanspeed g > /tmp/fan_status

Calling "temperature g 1" returns 167° F (75° C). Look's like the configured temperatures are independent of the "temperature" settings.
Logged

goldeneye77

  • Level 1 Member
  • *
  • Posts: 6
Re: fan starts after spindown and doesn't stop
« Reply #25 on: March 17, 2010, 08:16:58 PM »

Same results here -- have tried resetting to defaults via the web interface and by using the reset button on the back.  Fans continue to come on once the drives enter hibernation mode. (even when the temps are quite low -- i.e. 35 Celcius).  Quite a shame -- it's the one annoying thing about this device.  :-\
Logged

teamworker

  • Level 1 Member
  • *
  • Posts: 1
Re: fan starts after spindown and doesn't stop
« Reply #26 on: March 18, 2010, 04:22:10 AM »

The next User ...Same results
C1 Hardware Revision, 2 x 1GB WD green Harddrives as RAID1
 
resetting to defaults before upgrade from 1.07 to 1.08 , reset after successfully upgrade.
change off/low.. vs low/high take reboot´....
Fans continue to come on once the drives enter hibernation mode.

Where is the problem?  C1 Hardware?

Logged

gunrunnerjohn

  • Level 11 Member
  • *
  • Posts: 2717
Re: fan starts after spindown and doesn't stop
« Reply #27 on: March 18, 2010, 05:35:22 AM »

Where is the problem? 

 Hardware?
Starting to sound like it.  I guess you need to take a poll and see if it's only the guys with C1 hardware and 1.08 that are having the issue. :)
Logged
Microsoft MVP - Windows Desktop Experience
Remember: Data you don't have two copies of is data you don't care about!
PS: RAID of any level is NOT a second copy.

goldeneye77

  • Level 1 Member
  • *
  • Posts: 6
Re: fan starts after spindown and doesn't stop
« Reply #28 on: March 18, 2010, 05:38:38 AM »

I'll check on the hardware and get back to you guys later tonite hopefully.  I also played around with toggling hibernation on / off and toggling the fan speed settings.  Now the drives don't hibernate at all!  ???  :D

Now I understand the meaning of 'flaky'.
« Last Edit: March 18, 2010, 05:47:18 AM by goldeneye77 »
Logged

DavidB

  • Level 1 Member
  • *
  • Posts: 2
Re: fan starts after spindown and doesn't stop
« Reply #29 on: March 18, 2010, 06:04:27 AM »

I have the B1 hardware and have the same problem.
Logged
Pages: 1 [2] 3 4 5