Pages: [1]
  Print  
Author Topic: DIR-655 Shareport Problem Finally Fixed  (Read 13459 times)
jcarlile
Level 1 Member
*
Posts: 1


« on: November 06, 2009, 07:24:31 PM »

For the past month I haven't been able to connect to my backup drive using Shareport.  The Shareport system tray icon kept cycling between green and red.  It would keep locating my network backup drive and then losing it again and I could never connect to it.

At first I thought it was a firewall problem but nothing I did to my Norton 360 firewall settings seemed to have any effect.  I finally fixed the problem and it was pretty simple.  Although, I still don't know what originally caused the problem.

I entered the DIR-655 router setup utility and under Setup-> USB Settings I changed the USB setting from "Network USB" to "WCN Configuration" (I have firmware 1.21, if you are using firmware 1.31NA or 1.32NA is believe the "Network USB" setting is called "Shareport" or something similar).  I then had to reboot the router.  After the router rebooted, I entered the router setup utility again and chose Setup-> USB Settings once again.  I then changed the USB setting back to "Network USB" (Shareport).  I had to reboot the router once again, but when it came back up my Shareport problem was fixed and I was able to see and connect to my backup drive with no problem.

I decided to post this in case it might help someone else.  This problem was driving me crazy for weeks.
Logged
junkun13
Level 1 Member
*
Posts: 6


« Reply #1 on: November 09, 2009, 05:38:19 AM »

you need to reboot the router every time you connect to a device, very lame dlink
Logged
EddieZ
Level 11 Member
*
Posts: 2500



« Reply #2 on: November 09, 2009, 11:12:42 AM »

you need to reboot the router every time you connect to a device, very lame dlink

Reset to factory defaults, reflash, remove powerplug for 30 secs or so, turn on and manually reconfigure and it should work OK.
Logged

DIR-655 H/W: A2 FW: 1.33
100_Meridian
Level 1 Member
*
Posts: 2


« Reply #3 on: December 21, 2009, 06:15:57 AM »

Reset to factory defaults, reflash, remove powerplug for 30 secs or so, turn on and manually reconfigure and it should work OK.

I find this solution hard to understand. Manually reconfig a router with 10 devices is a huge time investment. Can you explain what this is solving, and specifics about the "reflash"?
Logged
EddieZ
Level 11 Member
*
Posts: 2500



« Reply #4 on: December 21, 2009, 11:32:41 AM »

I find this solution hard to understand. Manually reconfig a router with 10 devices is a huge time investment. Can you explain what this is solving, and specifics about the "reflash"?

Yep, that's a pain.

What does it solve? Erratic behaviour that can occur after flashing and/or restoring a saved config after flashing.
Logged

DIR-655 H/W: A2 FW: 1.33
satcomranger
Level 1 Member
*
Posts: 7


« Reply #5 on: December 21, 2009, 12:49:58 PM »

eddiez ..

Does this solve 100% of the peoples problems ...100% of the time ?   I have tried this method of reset ..reflash ..reboot .. reconfig .. no lessthan 3 times.... and yeah it works for a while ..but eventually ...the router winds up locking up ...slowing down .. only half of the features enabled..and as far as shareport is concerned .. forget it ..even with the latest beta that is proclaimed to fix both the router and shareport .  If dlink can come up with fixing even 90% of peoples problems 90% of the time .. then i will reinstall mine .. right now it is holding my door open ..  right now i have a competitors router in there and it is flying without the hint of a lockup or slowdown
Logged
EddieZ
Level 11 Member
*
Posts: 2500



« Reply #6 on: December 21, 2009, 01:17:31 PM »

eddiez ..

Does this solve 100% of the peoples problems ...100% of the time ?   I have tried this method of reset ..reflash ..reboot .. reconfig .. no lessthan 3 times.... and yeah it works for a while ..but eventually ...the router winds up locking up ...slowing down .. only half of the features enabled..and as far as shareport is concerned .. forget it ..even with the latest beta that is proclaimed to fix both the router and shareport .  If dlink can come up with fixing even 90% of peoples problems 90% of the time .. then i will reinstall mine .. right now it is holding my door open ..  right now i have a competitors router in there and it is flying without the hint of a lockup or slowdown

I experienced an apperent bad flash once, resulting in massive reboots when having reloaded the config. Reflash and manual setup fixed it. It worked for me and several others. But that does not say that it will work 100%. There might be other causes for the errors you experience.
Logged

DIR-655 H/W: A2 FW: 1.33
alphanumeric
Level 3 Member
***
Posts: 156


« Reply #7 on: December 22, 2009, 03:56:56 PM »

There is no 100% guaranty on anything in life except death.  Grin
I was having problems with Shareport after flashing to 1.32na. I reset to factory defaults and re-flashed my DIR-655 over a wired connection. I then redid all my settings from scratch and haven't had a problem since. I do know of at least one other forum member who tried this and it didn't work for him. As the saying goes, Your mileage may vary.  Wink
Logged
EddieZ
Level 11 Member
*
Posts: 2500



« Reply #8 on: December 23, 2009, 12:09:06 PM »

There is no 100% guaranty on anything in life except death.  Grin


And paying taxes  Grin
Logged

DIR-655 H/W: A2 FW: 1.33
DirtyDawg
Level 2 Member
**
Posts: 52



« Reply #9 on: December 24, 2009, 02:45:42 AM »

Wow, just tried my "Shareport" function for the first time since buying this product, Hardware Version: A4
Firmware Version 1.21, and didn't have any problems with it at all.  I suppose I should "knock on wood" or something Smiley.


My God, I'm soooo glad I heeded the warning in the beginning about not being able to flash back to previous version IF there was a problem AFTER flashing to the newer firmware version.  I came so close to updating the firmware.  I'm surprised you had trouble with 1.21.  Glad you got it operating to your liking.  There is nothing more frustrating than to purchase something only to spend hours and hours of troubleshooting time getting it to function properly.



The only thing I can suggest as to maybe improving this function is to make it so multiple systems can use it simultaneously.  Surely that should be possible?Huh  Well, one can only hope Smiley.
« Last Edit: December 24, 2009, 02:50:18 AM by DirtyDawg » Logged

DIR-655-Hardware A4-Firmware 1.21
Pages: [1]
  Print  
 
Jump to:  

Theme by webtechnica.com.