+  D-Link Forums
|-+  D-Link Xtreme N (Platinum Products)» DIR-655 » Web-site filtering does not work
Username:
Password:
Pages: [1]
  Print  
Author Topic: Web-site filtering does not work  (Read 1941 times)
aln688
Level 1 Member
*
Posts: 18


« on: October 19, 2009, 08:33:47 AM »

On my DIR-655 router, with 1.32NA firmware, I have found web-site filtering hasn't worked for at least two weeks now. It seems that it doesn't block web-sites nor log them under the STATUS->LOGS section. Under ADVANCED->ACCESS CONTROL, I have a single policy with the following attributes:

Enable: Yes
Policy: Internet Filter
Machine: Other Machines
Filtering: Block Some Access
Logged: Yes
Schedule: Always

I've added three web-sites under the ADVANCED->WEBSITE FILTER section, one of them "doubleclick.com", if I visit doubleclick.com, it's not filtered or blocked. I don't know what else to do. I've got this router problem, along with it disconnecting from my DSL modem and rebooting at random.

I really don't know why D-Link releases firmware of such poor quality, I mean why even release it at all? The entire ADVANCED->ACCESS POLICY and ADVANCED->WEBSITE FILTER sections simply do not work, no matter what I do to try and get them to work. If anyone has any ideas, I'd appreciate hearing them.

Thanks.
« Last Edit: October 19, 2009, 08:56:09 AM by aln688 » Logged
dcuthbertson
Level 1 Member
*
Posts: 1


« Reply #1 on: October 19, 2009, 02:21:27 PM »

I spent many hours searching for a solution to this problem. If you go to SETUP->NETWORK SETTINGS and check "Enable DNS Relay", the website filters will work. Though the post I read (at http://www.broadbandreports.com/forum/r22698188-Help-Me-DIR655-DNS-relay-long-post) implies that the router locks up with that checked.

I just enabled dns relay and my router appears to be working okay (the firmware is 1.32NA), so I don't know if there really is a lockup problem.

Logged
aln688
Level 1 Member
*
Posts: 18


« Reply #2 on: October 19, 2009, 02:37:20 PM »

Thanks for letting me know. I was aware of the DNS Relay needing to be checked in order for web-site filtering to work, but I already have it checked. I also saw that if you check it the router will freeze from time to time. Right now that option is checked and I experience broken web-site filtering and then freezing of the router every three or four days. When it freezes I usually have to pull the power, wait a minute, then power it back up again, then reconfigure it again.

This makes D-Link look incompetant at producing updates for their hardware, and I'm sure they aren't, I just don't understand why, who tests firmware before it's released? I spent hard-earned money on this device and at present the key features I rely on, web-site filtering and reliablility, do not work. I upgraded the firmware in the first place because web-site filtering and port-forwarding in 1.21 didn't work. I really can't afford to buy anything else at the moment.
« Last Edit: October 19, 2009, 02:39:18 PM by aln688 » Logged
Pages: [1]
  Print  
 
Jump to:  

Theme by webtechnica.com.