• July 09, 2020, 02:52:21 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: [SOLVED but not fixed] 802.3ad Load Balancing FAILS  (Read 7149 times)

~~Adam

  • Level 1 Member
  • *
  • Posts: 3
[SOLVED but not fixed] 802.3ad Load Balancing FAILS
« on: October 07, 2009, 01:40:51 PM »

Hello All,

Now that I'm calm, I thought I'd ask a question of QNAP in here.

Before I launch into the finer details, basically Link Aggregation or Trunking between a QNAP and a DLINK DES-1228P does NOT work, as far as I can tell.

Ok the finer details.
I have a QNAP TS-509 Pro 3.1.1 Build 0815T (5 x 1TB in RAID5 config) Connected to a DLink DES-1228P 24 port PoE managed layer 2 switch.
http://www.qnap.com/pro_detail_feature.asp?p_id=104
Ports 27 & 28 are untagged in VLAN 29 and are set as a Trunk (see page 42 of the Dlink man).
Cameras & laptop are connected to ports 1,2,3,4

I have 3 of Mobotix M12 Cameras recording back to the NAS (could be anything but in this case it's cameras), they are using NFS (also tested with CIFS).

Two cameras can save Files to the QNAP and one camera does not. Easy to fix, or so I thought.

1) Check IP address details/conflicts etc... all IP's are Static no conflicts.

QNAP:192.168.29.1/24
Laptop:192.168.29.2/24
Cam1:192.168.29.11/24
Cam2:192.168.29.12/24
Cam3:192.168.29.13/24

Can I ping the QNAP from my laptop, (YES).
Can my laptop ping the Camera (YES)
Can the camera ping the QNAP, (NO) huh that's weird, double check IP settings VLANS etc... Nothing is wrong.
Ok assume the camera is to blame so I factory default it. Still can't ping QNAP.
I reflash firmware into camera, Still can't ping QNAP.
I take the Config from a working Camera and dump it into Camera 1, Camera 1 still can't record (WTF)
Ok things are getting weirder.
Ok Check permissions on QNAP. (ignore ping failing) all permissions are set correctly, CIFS fails for Cam1 works for others.
Ok mayby the QNAP hates that IP so I change the camera from .11 to .50, it's now at 192.168.29.50/24 does CIFS work (NO)
Ok give up on CIFS convert system over to NFS. Still 2 cameras work and Camera 1 fails.
As a last resort I check MAC addresses of Cameras (all are different and normal).
All the time the other 2 cameras are happily recording.

Ok perhaps It's a hardware problem.

I get a Fluke network tester and test the Copper links for the Cameras using Class D specifications all pass no marginal passes or fails.
I test the Amp patch leads between the QNAP & the switch.

I look at the CRC error counters in the switch (There are no CRC or packet errors). Hardware is looking OK.

Then finally I think back to FreeBSD and how CARP works (Common address redundancy). FreeBSD uses a Hashing algorythm based on MAC addresses for Load Balancing to determine which port a Packet gets sent over, perhaps the DLINK is doing something similar with load balancing to the QNAP.

I log into the Dlink and remove the Trunk and unplug the second Ethernet port.
I change the QNAP from 802.1ad load balancing to just a normal config.

BANG

all three cameras are now saving files using NFS to the QNAP.

Is this a known bug with the DLINK or should I be chasing QNAP?

http://forum.qnap.com/viewtopic.php?f=11&t=19854#p86948  :o
« Last Edit: October 07, 2009, 11:42:07 PM by ~~Adam »
Logged

~~Adam

  • Level 1 Member
  • *
  • Posts: 3
[SOLVED but not fixed]Re: 802.3ad Load Balancing FAILS
« Reply #1 on: October 07, 2009, 11:40:54 PM »

I should have rung tech support

Quote
Dear Adam,

The link aggregation on the DES-12XX and DGS-12XX are a proprietary protocol.

They do not confirm to 802.1ad

Kind regards,
Paul B.
Technical Support Team
D-Link Australia & New Zealand
Logged