• December 06, 2019, 12:43:51 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: D-Link device not present  (Read 5391 times)

bradski

  • Level 1 Member
  • *
  • Posts: 2
D-Link device not present
« on: September 16, 2009, 10:53:51 AM »

Using: Windows Vista SP2 32bit, Skype 4.1.0.166, D-link dph50U_Driver_11.zip latest driver install download.

Was working with all the above fine. I did a complete uninstall of both skype and and the DPH-50U software/driver to try and fix an issue with skype not remembering the audio settings after a windows reboot.

After several uninstall and re-install attempts, I can never get past the red icon and "D-link device not present" issue. The install appears to go by the book and the skype program shows the DPH-50U utility.exe program as "allowed to use skype" in the access control part. Device manager shows the device as "VoIP Device" with a sub branch "D-Link USB VoIP Adaptor" and shows "This device is working properly" under properties.

This really is annoying. Please help.

Bradski
Logged

gotti

  • Level 1 Member
  • *
  • Posts: 13
Re: D-Link device not present
« Reply #1 on: September 16, 2009, 12:20:41 PM »

try the V1.1 driver. I use it and the phone rings http://www.dlink.com/products/?pid=DPH-50U&tab=3.driver
Logged

bradski

  • Level 1 Member
  • *
  • Posts: 2
Re: D-Link device not present
« Reply #2 on: September 16, 2009, 12:37:45 PM »

solved:

To do a clean uninstall, I had to first go into device manager and right click on both items that follow:
D-Link USB VoIP Adaptor (then select uninstall)
D-Link Virtual Audio Device (then select uninstall)

And THEN uninstall the D-link software using its own uninstaller.

After that, a re-install worked and requested a reboot at the end.

ALL works well again! =)
Logged