• October 02, 2023, 07:54:48 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  


This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Bricked DCS-5222L-A1  (Read 2233 times)


  • Level 1 Member
  • *
  • Posts: 3
Bricked DCS-5222L-A1
« on: March 07, 2022, 02:39:37 PM »

EDIT: for some reason, I eventually tried flashing REV-B on my REV-A and it revived the unit..... go figure.
case closed.

I have a Bricked DCS-5222L-A1 - upon startup I get a solid red power light.

Tried the emergency Firmware restore via the SDCard slot, result:

Camera unplugged
Fat32 formatted SD card with "upgrade" folder containing "update.bin" (most recent firmware for correct model)
hold the reset button
plug the power supply
Red power led start flashing
release reset button
Red power led becomes solid.

5 seconds later I get the green/solid icon / no red power light ;
stays like this forever. nothing else.

If I remove the sdcard and restart I'm back to the solid red light. Standard reset (holding reset up to 30 seconds) doesn't work. WPS doesn't respond either.

Before I throw it to garbage, any clue what the issue is? anything else I can do to fix it or troubleshoot ?

« Last Edit: March 08, 2022, 06:28:15 AM by 123qweasd »