• December 02, 2020, 05:23:23 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: WiFi Issues since FW1.11  (Read 1428 times)

Valthanis

  • Level 1 Member
  • *
  • Posts: 5
WiFi Issues since FW1.11
« on: June 17, 2020, 07:03:46 AM »

Anyone else having many devices look connected, have a proper IP address and not get communication from the router since FW1.11? Is there a roll back process since the FW upgrade happened automatically (something I normally like for security reasons, but there aren't even any release notes associated with this FW version).
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49375
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: WiFi Issues since FW1.11
« Reply #1 on: June 17, 2020, 09:43:20 AM »

Link>Welcome!

  • What region are you located?

Have you tried a factory reset and setup from scratch to see if this clears anything?
Logged
Cable: 1Gb/50Mb>NetGear CAX80>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

Valthanis

  • Level 1 Member
  • *
  • Posts: 5
Re: WiFi Issues since FW1.11
« Reply #2 on: June 17, 2020, 11:52:03 AM »

No I havent tried that yet. If I reboot it works like normal for about an hour or 2, then starts not communicating (or showing them connected from the admin screen) on some devices.

When you say setup from scratch, can I load a backup so I don't have to recreate all my rules and reservations?
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49375
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: WiFi Issues since FW1.11
« Reply #3 on: June 17, 2020, 11:54:22 AM »

Lets try a reset then set from scratch. I would not load the backup file immediately. Please try the router after the setup from scratch with the basic setup configuration first. Lets see if the problem continues or not, if not, then load the backup config from file.
Logged
Cable: 1Gb/50Mb>NetGear CAX80>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

hilaireg

  • Level 3 Member
  • ***
  • Posts: 348
Re: WiFi Issues since FW1.11
« Reply #4 on: June 20, 2020, 06:50:07 AM »

RE: Rollback

Assuming the vendor hasn't blocked rollback, I typically follow this process when rolling back to the previous F/W:

1. Export current configuration/profile
2. Upgrade to latest firmware
3. Verify functionality

... rollback

4. Factory reset device, disconnect from LAN/WAN
5. Connect directly to FIRST/LAST port on device
6. Upload previous firmware
7. Factory reset device
8. Upload backed-up configuration
9. Connect to WAN, verify functionality
10. Connect to LAN, restart LAN devices

Cheers,


NOTE:

Although not explicitly stated as required by the vendor, I typically power-off/on a device once I have logged into the device post-firmware update.  As part of the firmware update activity, I also note the WAN connection information and review it post firmware update and post power up.

For example, I just updated to F/W 1.11.  I had noted my ISP connection information (IP, DNS, Gateway, etc) pre-firmware and noticed and *significant* change post-firmware.  After powering off/on the device, the ISP connection information returned to what it was pre-firmware.  The point I'm making here is that sometimes, the equipment actually *does* need to be powered off/on ... not just power cycled.
« Last Edit: June 20, 2020, 07:09:07 AM by hilaireg »
Logged

Valthanis

  • Level 1 Member
  • *
  • Posts: 5
Re: WiFi Issues since FW1.11
« Reply #5 on: June 29, 2020, 11:37:24 AM »

So I haven't tried downgrading the Firmware yet, but I did reload both from my backup, and from scratch and the same problem is still happening.

I am testing currently with the "Smart Connect" feature off and I will post back tomorrow if that has resolved the connection dropping issues I have seen on wifi.

I know its not my internet as the devices that I have hardwired have not had a problem at all since this started with FW1.11
Logged

Valthanis

  • Level 1 Member
  • *
  • Posts: 5
Re: WiFi Issues since FW1.11
« Reply #6 on: July 02, 2020, 09:49:07 AM »

So it's still happening after about 18 hours, reboot fixes it again though. I really believe there is a bug in this firmware.

Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49375
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: WiFi Issues since FW1.11
« Reply #7 on: July 02, 2020, 10:10:04 AM »

Let us know what happens if you downgrade FW...
Logged
Cable: 1Gb/50Mb>NetGear CAX80>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

aitkened

  • Level 1 Member
  • *
  • Posts: 3
Re: WiFi Issues since FW1.11
« Reply #8 on: August 28, 2020, 07:34:00 AM »

I've also had nothing but issues with WIFI since the 1.11 update. Devices tend to just take longer to connect to it (mainly phones when waking the device) but it's very noticeable. my laptop (surface pro) even drops wifi connectivity randomly. Even my Google home doesn't work right and 50% of the time you ask it a question it says "something went wrong try again in a few seconds" after which it will work fine.  I tried a factory reset and setup everything from scratch. i have QOS disabled and use separate 2.4 and 5g networks. Everything was great with the 1.02 firmware but i updated because of the mesh enhancements (I have a hardwired dap-1820 at the back of my house). It'd be great if i could ROLL BACK to that firmware with an official download  ::)
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49375
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: WiFi Issues since FW1.11
« Reply #9 on: August 28, 2020, 11:22:53 AM »

Have you made contact with D-Link support about this yet?


I've also had nothing but issues with WIFI since the 1.11 update. Devices tend to just take longer to connect to it (mainly phones when waking the device) but it's very noticeable. my laptop (surface pro) even drops wifi connectivity randomly. Even my Google home doesn't work right and 50% of the time you ask it a question it says "something went wrong try again in a few seconds" after which it will work fine.  I tried a factory reset and setup everything from scratch. i have QOS disabled and use separate 2.4 and 5g networks. Everything was great with the 1.02 firmware but i updated because of the mesh enhancements (I have a hardwired dap-1820 at the back of my house). It'd be great if i could ROLL BACK to that firmware with an official download  ::)
Logged
Cable: 1Gb/50Mb>NetGear CAX80>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

aitkened

  • Level 1 Member
  • *
  • Posts: 3
Re: WiFi Issues since FW1.11
« Reply #10 on: September 02, 2020, 07:55:47 AM »

Not yet - i need to carve out the time to setup a chat with them online. Has anyone tried the 1.13b firmware that just released?

Have you made contact with D-Link support about this yet?
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49375
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: WiFi Issues since FW1.11
« Reply #11 on: September 02, 2020, 08:34:51 AM »

I see it only fixes a security problem:
"Firmware encryption key change
3rd Party Report:
On July 22, 2020, security researchers working with Bleeping Computer disclosed the DIR-3040-US firmware archive had disclosed the firmware encryption keys for the device."
Logged
Cable: 1Gb/50Mb>NetGear CAX80>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

GreenBay42

  • Administrator
  • Level 11 Member
  • *
  • Posts: 2590
Re: WiFi Issues since FW1.11
« Reply #12 on: September 02, 2020, 08:43:46 AM »

I haven't heard of any issues with 1.13. It is HIGHLY recommended to update from 1.11. The beta firmware is based off the 1.11 firmware other than the new encryption key so performance should not change too much if any. They are working on an "official" release but it has to go through all the hoops before released.
Logged

aitkened

  • Level 1 Member
  • *
  • Posts: 3
Re: WiFi Issues since FW1.11
« Reply #13 on: September 19, 2020, 06:30:17 PM »

Follow up. D-Link support sent me a two step firmware update to 1.13 which helped. Turns out the majority of my issue was a bat network cable but the 1.13 firmware did resolve the wifi connectivity issues

Not yet - i need to carve out the time to setup a chat with them online. Has anyone tried the 1.13b firmware that just released?

Have you made contact with D-Link support about this yet?
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49375
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: WiFi Issues since FW1.11
« Reply #14 on: September 20, 2020, 09:12:39 AM »

Great to hear new FW and finding the bad cable helped.

Enjoy.  ;)

Follow up. D-Link support sent me a two step firmware update to 1.13 which helped. Turns out the majority of my issue was a bat network cable but the 1.13 firmware did resolve the wifi connectivity issues.
Logged
Cable: 1Gb/50Mb>NetGear CAX80>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.