• December 03, 2020, 11:39:02 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Port forwarding / DMZ / and UPNP not working. (DIR-890L)  (Read 1780 times)

necrovamp

  • Level 1 Member
  • *
  • Posts: 4
Port forwarding / DMZ / and UPNP not working. (DIR-890L)
« on: January 24, 2020, 01:56:01 PM »

Hey there, I just got a DIR-890L and I was setting it up yesterday, everything went smoothly except port forwarding.

Currently, I'm trying to forward 9987 UDP, and have been unsuccessful.  I'm at a loss.
The main reason I'm asking here, is my friend has the same router, and he let me try to forward the ports on his, and his didn't work either.
So Either I'm doing it wrong, or there's a setting, or quirk about the routers I need to handle, I hope you all can help

Below are all the steps I've tried.

I've tried setting it up normally using udp in the port forward section.
I've tried selecting "both" and only "tcp", which I know most port checkers online can check for TCP. And the router refused to open the ports. 
Next I tried the "Virtual server" portion of the page, figuring that might change something, with no luck.
Next I tried using DMZ, to at least get a connection moving, but everything is still blocked.
I did a factory reset and changed no settings, and tried the above 3 things, still blocked.
I upgraded from firmware 1.10 to transitional fw 1.11, then the above steps, still blocked
I tried firmware 1.20 and 1.21 with the above steps, still blocked.
I tried using UPNP, but there's no place to verify upnp requsted ports, and a UPNP application on my computer, doesnt detect the router accepting UPNP requests.


Current settings: (Hardware Version: A1    Firmware Version: 1.21)
I am wired into the router, I tried multiple factory resets throughout my troubleshooting, and after each firmware upgrade
I used firefox throughout most of the changes, but I did try chrome, and edge
My ISP is fiber through my utilities company, no port issues with previous router (Netgear R6300v2) Ethernet direct from Wall

**Update**
I have been able to use port forwarding and DMZ with http and https services. 
I still have not been able to get port 9987 UDP to work yet, as well as UPNP (though I only tried UPNP as a last resort, I dont play on using it)


« Last Edit: January 24, 2020, 05:37:05 PM by necrovamp »
Logged

GreenBay42

  • Administrator
  • Level 11 Member
  • *
  • Posts: 2590
Re: Port forwarding / DMZ / and UPNP not working. (DIR-890L)
« Reply #1 on: January 24, 2020, 02:16:21 PM »

What are you trying to do?

What application? Hosting a server? Gaming?
Logged

necrovamp

  • Level 1 Member
  • *
  • Posts: 4
Re: Port forwarding / DMZ / and UPNP not working. (DIR-890L)
« Reply #2 on: January 24, 2020, 03:23:09 PM »

All of the above

My immediate concern is a teamspeak server I run for my friends, on port 9987 UDP.

My future concerns are port forwarding for applications and games I use regularly, that I've had to forward in the past, including but not limited to.
Moonlight game streaming,
Plex.
Obi200 VOIP adapter
Steam Source:Server hosting,
Borderlands 3 Server hosting.

I havent tried most of the others, but since you mentioned them, I went ahead and tried to forward my plex port, which is also not working.

Also this is the first router I've had with 2 sections in the port forwarding page.
I'm assuming port forward , is for outgoing connections from my network (such as games) (similar to port triggering?),
 and virtual server is to allow incoming connections (for hosting) (similar to normal port forwarding)?
Needless to say I've tried both and neither has worked so far.

I'm open to downgrading the firmware, if you think that might help, or even WRT, (though I chose to stay with official firmware,  since people report not getting full gigabit WAN speeds )



What are you trying to do?

What application? Hosting a server? Gaming?
« Last Edit: January 24, 2020, 04:52:03 PM by necrovamp »
Logged

necrovamp

  • Level 1 Member
  • *
  • Posts: 4
Re: Port forwarding / DMZ / and UPNP not working. (DIR-890L)
« Reply #3 on: January 24, 2020, 05:10:53 PM »

My first bit of testing continued. I decided to hold off on the 9987 temporarily, and focus on plex, since it's easier to verify (tcp).

After some muddling through https for plex, I was able to open the webpage!  First step in the right direction.
My next step, I tried normally port forwarding a webserver, this time standard http, connected normally.   Next step!

So far that tells me that port forwarding is working, at least for https / http servers correct?

Which also means I'm at a loss for this teamspeak UDP port 9987.


Any help will be much appreciated.  In the meantime I'll keep adding ports and services, to continue to verify functionality.
It's also worth noting that DMZ also works at least with with http and https websites.

My current questions are:
Is it UDP traffic thats blocked?
Is it port 9987 thats blocked?
Is it teamspeak itself that I should just give up on?

My currently working on: next steps are:
Verify any type of UDP traffic
Add more services that dont using webservers, but do require open ports to my forward list and verify connectifity. (such as moonlight and obi200)
Research teamspeak port forwarding issues itself
« Last Edit: January 24, 2020, 05:47:34 PM by necrovamp »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49375
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Port forwarding / DMZ / and UPNP not working. (DIR-890L)
« Reply #4 on: January 25, 2020, 12:34:35 PM »

Internet Service Provider and Modem Configurations
  • What ISP Service do you have? Cable or DSL?
  • What ISP Modem Mfr. and model # do you have?

Also did you disable uPnP before configuring any Port Forwarding rules?
Logged
Cable: 1Gb/50Mb>NetGear CAX80>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.

necrovamp

  • Level 1 Member
  • *
  • Posts: 4
Re: Port forwarding / DMZ / and UPNP not working. (DIR-890L)
« Reply #5 on: January 25, 2020, 02:41:36 PM »

My ISP is fiber through my utilities company (Lightube) , no modem, Ethernet direct from Wall in an apt building
no port issues with previous router (Netgear R6300v2)

I did disable UPNP first before attempting any port forwarding.
After troubleshooting I tried enabling it as one of my last options.

_______
**Update**
Since yesterday, I have fully setup my obi200, which seems to be working
The ports it requires are,
Allow Outgoing:
TCP Ports: 6800, 5222, 5223
UDP Ports: 5060, 5061, 10000 to 11000, 16600 to 16998, 19305
Allow Incoming on UDP Port: 10000

After I set it up, it seems to be working.
If that's working that also includes plex and my webserver., which means port forwarding is working,
and the problem is with teamspeak or a service/port/protocol it uses?

So far, out of the 4 applications I have tried, only teamspeak is having trouble.

I enabled all ports on their help page, and I'm not sure where to go from here.
https://support.teamspeakusa.com/index.php?/Knowledgebase/Article/View/44/16/which-ports-does-the-teamspeak-3-server-use

I can change which port teamspeak uses as default (change it from 9987), I've tried changing it, and forwarding the new port, which did not work.
I have verified port 10011 is working for serverquery.
It's starting to seem that maybe its teamspeak that has an issue with the DIr-890L, so I maye have to start a forum post over there.
Using the teamspeak server logs, I have been able to verify that even when the client does not connect, it still reports the connection to the server.
(i blanked out my wan ip)

Since it does show up in the connection log, the client or server is blocking the connection, or somehow not fully connecting.
I attemped connection with the mosted update version or server and slient, as well as beta client, still not connecting

I also plugged in my old router and confirmed everything is working as expected.
The only ports I set the old one up to forward are 9987, and 30033


This means that whatever is happening is only with my DIR-890L


Internet Service Provider and Modem Configurations
  • What ISP Service do you have? Cable or DSL?
  • What ISP Modem Mfr. and model # do you have?

Also did you disable uPnP before configuring any Port Forwarding rules?
« Last Edit: January 25, 2020, 03:23:50 PM by necrovamp »
Logged