• September 19, 2020, 06:24:28 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: [1] 2

Author Topic: Problem with my internet speed thru lan ports on this router  (Read 2264 times)

jdw20

  • Level 1 Member
  • *
  • Posts: 16
Problem with my internet speed thru lan ports on this router
« on: January 08, 2020, 09:34:28 AM »

Hi everyone, new to site and new to D-Link routers. Purchased my Covr 3902 last August, easy setup and super wireless coverage, my setup then was cable modem technicolor tc 4300 to this router, hardwired to windows 10 pc, hardwired to Cisco 122 ata(phone), hardwired to Lg smart tv, ipad/iPhone etc using wireless. My ips plan was 40 down 10up. With this setup I was getting my isp speeds for the most part mostly in the mid 30ís
Now to Jan 2020, upgraded my isp plan to 120 down 10up, provider stated I needed new modem due to speed and sent technicolor tc4350, installed modem , and plugged into Covr  router with everything as previously hooked up, my speed results, all hardwired devices, speed is now mid 20 to low 30, but all wireless is 90 to 110 down!, something is capping the data thru router?
Things I tried
1) Factory reset and reinstalled Covr router - no change in hardwired speed
2) hardwired modem directly to pc (no router) - I get full speed from ips
3) on Lg tv changed from hardwired to wireless - speed increases from 25 to 100 !
4) reinstalled old Linksys ea6400 router with same wiring as Covr router - everything works speed on both wired and wireless are up around 90 to 110
I donít understand why the Covr router is sooo slow on wired devices? I have removed all QoS devices, anyone experience something similar. Appreciate everyoneís input, I really like this router and the quality of the wireless through out my home, but this wired slow speed is no good
Thanks
Logged

FurryNutz

  • Poweruser
  • ††▲
    ▲†▲
  • *****
  • Posts: 49182
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Problem with my internet speed thru lan ports on this router
« Reply #1 on: January 08, 2020, 12:58:58 PM »

Link>Welcome!


  • Link>What Firmware version is currently loaded? Found on the routers web page under status.
  • What region are you located?
  • Check cable between Modem and Router, swap out to be sure. Link> Cat6 is recommended.
  • Check ISP MTU requirements, Cable is usually 1500, DSL is around 1492 down to 1472. Call the ISP and ask. Link>Checking MTU Values
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

jdw20

  • Level 1 Member
  • *
  • Posts: 16
Re: Problem with my internet speed thru lan ports on this router
« Reply #2 on: January 08, 2020, 04:23:43 PM »

Thanks for the links following answers
1) firmware is at 1.01, router confirms this is latest
2) hardware  at A1
3j change the cable from mod3m to router, was using cat 7 now using cat 6 no change in speed
4j mtu router setting at auto
Logged

FurryNutz

  • Poweruser
  • ††▲
    ▲†▲
  • *****
  • Posts: 49182
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Problem with my internet speed thru lan ports on this router
« Reply #3 on: January 11, 2020, 03:12:20 PM »

What happens if you load this version of FW?
http://forums.dlink.com/index.php?topic=73003.15

Factory reset after the file loads and setup from scratch.


If this fails to correct this issue, I recommend that you phone contact your regional D-Link support office and ask for help and information regarding this.
Link> Tech Support Contact Information
We find that phone contact has better immediate results over using email.
Let us know how it goes please.
« Last Edit: January 12, 2020, 04:20:18 PM by FurryNutz »
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

jdw20

  • Level 1 Member
  • *
  • Posts: 16
Re: Problem with my internet speed thru lan ports on this router
« Reply #4 on: January 12, 2020, 07:41:45 AM »

Thanks but unable to find the post 73003.15, for the firmware , can you forward the link to this post
Logged

FurryNutz

  • Poweruser
  • ††▲
    ▲†▲
  • *****
  • Posts: 49182
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Problem with my internet speed thru lan ports on this router
« Reply #5 on: January 12, 2020, 04:20:49 PM »

There is a FTP download link that should get you a beta version...File link is working.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

davevt31

  • Level 8 Member
  • ***
  • Posts: 1486
Re: Problem with my internet speed thru lan ports on this router
« Reply #6 on: January 12, 2020, 09:57:31 PM »

Here is a link to page with information and download link :

https://supportannouncement.us.dlink.com/announcement/publication.aspx?name=SAP10109
Logged

jdw20

  • Level 1 Member
  • *
  • Posts: 16
Re: Problem with my internet speed thru lan ports on this router
« Reply #7 on: January 13, 2020, 06:13:24 AM »

Thanks will give this a try and post the results

UPDATE Results:                 http://forums.dlink.com/index.php?topic=73003.15

I updated firmware from file       link above, reset router, but no change to wired download speeds! several tests with speedtest dn is 28 - 39, wireless is 95 to 115
I changed the wan port speed to 100 vs auto and my dn speed improved a little to the high 50 range, changed port setting to 1000, download returns to the 28-39 range
Something is capping the wired download thruput. Guess onto support
« Last Edit: January 13, 2020, 08:31:14 AM by jdw20 »
Logged

jdw20

  • Level 1 Member
  • *
  • Posts: 16
Re: Problem with my internet speed thru lan ports on this router
« Reply #8 on: January 13, 2020, 04:54:29 PM »

Update 2 - on phone with support, had a super tech person (John) assist me with this problem, nothing seemed to work, to get wired router up to my ISP speeds,
We did discover that when I hardwired my PC to the covr extender dir3ctly, my lan speed got up to high 90ís.
Conclusion with tech that router is defective and am in process of getting a replacement under warranty.
Will posted update of speed results once I get the replacement router, thanks for your assistance on this forum
Logged

FurryNutz

  • Poweruser
  • ††▲
    ▲†▲
  • *****
  • Posts: 49182
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Problem with my internet speed thru lan ports on this router
« Reply #9 on: January 14, 2020, 06:15:03 AM »

Glad they are sending a RMA.  ;)
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

jdw20

  • Level 1 Member
  • *
  • Posts: 16
Re: Problem with my internet speed thru lan ports on this router
« Reply #10 on: January 15, 2020, 02:43:44 PM »

Well I got my replacement covr 3902! Great service from D-Link, but unfortunately the new system is working just like the old one, my LAN speeds donít exceed 35 down on a 120 down plan, however my wifi speeds are in excess of 110 on all my wireless devices, also if I hardwire thru the covr extender, my lan speeds increase to the 110 range, this has me baffled and frustrated to say the least; as stated before my old Linksys EA6400 router outputs the correct lan and wireless speeds as per provider, I donít believe I am the only one who has experienced this router operation, donít know where to go next?  Thanks 🙏

Added comment: just thinking that if  using the wired ports on the extender, arenít I just relaying the wireless speed of the extender thru itís ports, really not the same as the using lan ports of the router?
« Last Edit: January 15, 2020, 05:45:16 PM by jdw20 »
Logged

FurryNutz

  • Poweruser
  • ††▲
    ▲†▲
  • *****
  • Posts: 49182
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Problem with my internet speed thru lan ports on this router
« Reply #11 on: January 15, 2020, 04:40:54 PM »

What PC, OS and LAN adapter MFr and model# that is in this PC?

Happen to have a different PC by chance? Kind of thinking something is going on with your PC maybe.

I'll pull out my 3902 and test here. I have a 1Gb ISP connection.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

FurryNutz

  • Poweruser
  • ††▲
    ▲†▲
  • *****
  • Posts: 49182
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Problem with my internet speed thru lan ports on this router
« Reply #12 on: January 15, 2020, 05:02:27 PM »

Ok, got mine setup. Using v1.01B05_BETA01 Date : 27, Dec, 2017 which the latest version I believe...

Netgear CM1100 Cable modem>COVR2600 router>HP Gb switch>WIndows 10 PC


I'll leave this run for a day or two and check back on it.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

jdw20

  • Level 1 Member
  • *
  • Posts: 16
Re: Problem with my internet speed thru lan ports on this router
« Reply #13 on: January 15, 2020, 06:42:44 PM »

Thanks for the reply my isp is distributel 120down and 10up With Cisco ata voip phone adapter

My pc Ho Compaq with Windows 10, network card is Realtek 10/100 card built in to motherboard, my results with the pc is follows:
1) hardwired to my technicolor tc4350 modem , dn speed is around 95, being capped due 10/100 card?
2) place same cat7 cable into Covr router , Dn speed never gets above 40
3) all wireless connects 2 iPads, iphone, firestick 4k, dn speed between 90 and 120
4) no other computer but have lg sk9000 smart tv which can be wired or wireless , on wired thru D-Link router dn speed is under30, wireless 90 to 120
just now Hardwired tv directly from modem, dn is low to mid 90 using speedtest  thru the Nexflix app
Same cat cable inserted into D-Link router, dnspeed thru Netflix is 20!
5) tried removing ata phone adapter and only use the pc or tv always wired thru covr router always get low dn 20 - 35!
6)as stated before my Linksys EA 6400 , if I change D-Link covr with the Linksys I have no issues wired wired download speeds
I am lost?
Logged

FurryNutz

  • Poweruser
  • ††▲
    ▲†▲
  • *****
  • Posts: 49182
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Problem with my internet speed thru lan ports on this router
« Reply #14 on: January 16, 2020, 06:15:06 AM »

Possible there maybe a problem with your adapter and the router. I don't use 100Mbps adapters anymore. All 1Gb for years.
Thought the adapter and router should be able to see near 90Mpbs, not sure why it's getting lower. i would recommend getting a 1Gb adapter installed in your PC.

Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!
Pages: [1] 2