• September 19, 2019, 05:58:45 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Static Route to Block Google DNS  (Read 103 times)

square_eyes

  • Level 2 Member
  • **
  • Posts: 37
Static Route to Block Google DNS
« on: September 13, 2019, 07:48:38 PM »

I want to block Google 8.8.8.8 and 8.8.4.4 because I have a Pihole on my network doing DNS for me. The Pihole gives out DNS records as it's the DHCP server on my network (this is because the 880L refuces to allow setting a custom DNS server - but that's another issue - more info below).

Numerous devices have Google DNS hard coded. Tutorials online explan how to block Google DNS with a static route. However when I save my static route, for example... 8.8.8.8 gets saved/written as 8.8.8.0. I have no idea why, and 8.8.8.8 remains pingable on my network.

Example tutorial on using static routes: https://support.unlocator.com/article/177-how-to-block-google-dns-on-roku-using-d-link-router
My static route (with 0 digit manipulation on saving): https://imgur.com/a/2OVWdkn

DIR-880L    HW:A1    FW:1.08WW

More info
Explanation on lack of DNS LAN configuration: https://discourse.pi-hole.net/t/instal-of-pihole-on-dlink-router-not-working/5631/2
« Last Edit: September 13, 2019, 08:07:31 PM by square_eyes »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47759
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Static Route to Block Google DNS
« Reply #1 on: September 14, 2019, 08:44:24 AM »

Is DNS Relay disabled on the 880L?
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

square_eyes

  • Level 2 Member
  • **
  • Posts: 37
Re: Static Route to Block Google DNS
« Reply #2 on: September 14, 2019, 11:55:04 AM »

Yes it is disabled.

I was able to block requests with the firewall, but what I want to do is actually forward requests to port 53 to my local DNS server (Pihole) using static routes - or at least back to my router.

Pretty sure it's a bug. When subnet mask is 255.255.255.0, I can't save a destination IP that doesn't end with 0. Or rather, I can, just the zero overwrites the digit on save. It dousn't mangle the digit using a different subnet, 255.255.255.255. But I can't then go and change the router subnet to that in the LAN settings - so my devices remain on .0 and the rules have no effect. Saving 255.255.255.0 in LAN settings, results in the form validation saying my router IP 192.168.0.1 is invalid! So another bug perhaps too.
« Last Edit: September 15, 2019, 03:31:44 AM by square_eyes »
Logged