• December 05, 2019, 06:26:36 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Choppy video in Playback System.  (Read 819 times)

RiverWay

  • Level 1 Member
  • *
  • Posts: 23
Choppy video in Playback System.
« on: August 22, 2019, 11:50:26 AM »

Summary: normal streaming video quality is inherently present in source video, but the D-ViewCam Main Console and Playback application are not handling H.264 and JPEG encoding correctly on the output end, unless it is exported as  "AVI (original format)".

-----

I have had this "choppy video" problem in D-ViewCam for years. For convenience here, I'll call it freeze-go-freeze-go, or F-G. Here is what I have found. Though I understand it -may- be peculiar to my computers and network configurations, I think not. It has to do with D-Link H.264 and/or JPEG encoding and the handoff to a network, AND the playback in D-ViewCam and D-ViewCam's handling of the encoding, whether the network is hardwired ethernet or wifi. Further, when using cams from other manufacturers, and their viewing software, I have never seen F-G issues on their equipment connected on the same network and computers. Reducing resolution on the D-Link cams has absolutely no positive impact on the F-G problem.

For the record, I have the F-G issues with D-Link models DCS-942L, DCS-2330L, DCS-2132L and DCS-2132LB1. D-ViewCam is installed and tested on multiple computers running under Win 7 and Win 8.1. As explained below, it's not the cams, it's a D-ViewCam problem.

In my experience, the F-G problem is most severe with D-Link's implementation and processing of H.264 encoding, yielding a roughly 0.5s GO/0.5s FREEZE iteration. D-Link's JPEG encoding also has a F-G issue (when viewed in D-ViewCam) which is not as severe as H.264, but it is still unacceptable. Streaming is streaming and we expect smooth video motion.

If a D-Link cam has MPEG4 encoding, use it. I have no F-G problems with any D-Link cam that has an MPEG4 encoding option. I was disappointed with newer D-Link cameras that eliminated the MPEG4 encoding option, because then I got stuck with the H.264 Freeze-Go problem.

The freeze-go problem does not occur in video clips recorded on camera storage, for any encoding format, whatsoever. This is a BIG hint regarding the source of the problem - the cams and on-board encoding are not the source of the problem. The F-G problem does not occur when viewing video via the cameras' on-board software and viewing "Live Video" in a browser. This is another BIG hint about the source of the problem, eliminating the network and computers as the source of F-G issues.

The problem is in D-ViewCam when processing and presenting LAN locally-streamed, and also saved, H.264 and JPEG video.

First, the live streaming video views in the D-ViewCam Main Console for H.264 and JPEG exhibit the F-G problem.

When saving selected video clips in the D-VewCam Playback application using the default ASF format, the F-G problem is duplicated to the output files. The video is essentially useless, unprofessional and annoying.

** HOWEVER, save the video using the "AVI (original format)" option, and the F-G problem is non-existent for H.264 and JPEG encoding. **

Bingo. The normal video quality is there, but D-ViewCam is not handling H.264 and JPEG correctly on the output end, unless it is exported as  "AVI (original format)".

There are no F-G problems when saving selected MPEG4-encoded video clips in any format allowed by the D-ViewCam Playback app.

***** Workaround Summary *****

If a D-Link cam has an MPEG4 encoding option, I use it. No F-G problems, whatsoever. (But now, and new to D-ViewCam 5.0.0, it causes cams with MPEG4 encoding enabled to quickly and permanently disconnect, and I have no choice - I must use H.264 encoding, which -does not- cause a D-ViewCam 5.0.0 disconnect issue.)

If a D-Link cam must use H.264 or JPEG encoding because that is what D-Link has decided we will be limited to, I use the H.264 and accept that the live views AND Playback views exhibit the very annoying 0.5s Freeze-Go cycles.

When I save desired video clips via the D-ViewCam Playback app, I use the "AVI (original format)" option, and my saved video is fine, normal and presentable - there is no freeze-go issue. I use other software to convert from AVI to mp4 for distribution.

Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47947
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Choppy video in Playback System.
« Reply #1 on: October 03, 2019, 09:00:21 AM »

New version of DVC is available:
http://forums.dlink.com/index.php?topic=75118.0
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting