• August 17, 2019, 08:22:22 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DGS-1100-xx RxError Count Bug with PPPoE Traffic?  (Read 89 times)

J1mbo

  • Level 1 Member
  • *
  • Posts: 10
DGS-1100-xx RxError Count Bug with PPPoE Traffic?
« on: August 14, 2019, 11:36:51 AM »

DGS-1100-05PD (1.00.B033) and DGS-1100-08P (1.00.B031).

BT HG612 PPPoE modem -> 05PD eth1, VLAN 15 untagged
05PD eth4 -> 08P eth1, multiple VLANs trunk ports
08P eth8 -> Unifi EdgeRouter X, multiple VLANs trunk ports

For these 4 ports only, I see steadily increasing RxError counts.

The only commonality if that PPPoE traffic is being carried by all ports. Therefore, I wondered if there could be a bug with the firmware recording RxErrors?

Note: I don't have flow control enabled on these switches.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47679
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DGS-1100-xx RxError Count Bug with PPPoE Traffic?
« Reply #1 on: August 15, 2019, 06:11:43 AM »

What happens if you remove the ER-X from the mix and try a different router?

I'll try and connect my ER-X and 1100 up and see if I see similar, however I don't have VLANs configured.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

J1mbo

  • Level 1 Member
  • *
  • Posts: 10
Re: DGS-1100-xx RxError Count Bug with PPPoE Traffic?
« Reply #2 on: August 15, 2019, 10:56:11 PM »

The RxErrors appear to be a bug relating to jumbo frames. The two switches have jumbo frames enabled and the PPPoE connection is configured with an MTU of 1500 bytes, meaning the MTU between the router and the FTTC modem is 1508.

Running this from a client within the network generates the error counts:
ping -i 0.1 -c 100 -s 1472 -D 8.8.8.8

Conversely, this does not:
ping -i 0.1 -c 100 -s 1460 -D 8.8.8.8

I will raise a ticket with support.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47679
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DGS-1100-xx RxError Count Bug with PPPoE Traffic?
« Reply #3 on: August 16, 2019, 06:07:08 AM »

Glad you narrowed it down more. Let us know how it turns out.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting