• December 14, 2019, 12:31:59 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: D-link router not working after firmware upgrade  (Read 454 times)

user7101

  • Level 1 Member
  • *
  • Posts: 1
D-link router not working after firmware upgrade
« on: July 21, 2019, 12:30:26 PM »

My DWR-921 rev c3 router has stopped working after I attempted upgrading the firmware. Resetting the device doesn't work. And browsing to 192.168.0.1 says "This site cannot be reached".

I have tried to do the emergency flashing described here: http://forums.dlink.com/index.php?topic=44909.msg163599#msg163599. When the router comes on, all the led lights on the front panel flash continuously with the exception of the power indicator. I have tried the same procedures on a different computer with the same result. I'm at my wits end. Any help will be appreciated.
« Last Edit: July 21, 2019, 01:25:39 PM by user7101 »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47985
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: D-link router not working after firmware upgrade
« Reply #1 on: July 21, 2019, 01:33:02 PM »

Try a different PC.

Be sure your PCs networking setting are for automatic IP addressing, and not static.

If a different PC fails to connect, possible the unit maybe faulty.
I recommend that you phone contact your regional D-Link support office and ask for help and information regarding this.
Link> Tech Support Contact Information
We find that phone contact has better immediate results over using email.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting