• October 17, 2019, 01:09:31 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: PPPOE Authentication settings ?  (Read 826 times)

infra

  • Level 1 Member
  • *
  • Posts: 1
PPPOE Authentication settings ?
« on: July 03, 2019, 03:48:31 PM »

I work at an ISP.   If there is a problem with the PPPOE Server then users with DLink 520B's have a LOT of problems reconnecting.

One of the causes seems to be that if the 520b gets an error back from the NAS or Radius is pops up a web page to the user  "ISP Authentication failed.  Please enter your password".  The user almost NEVER know which password they are supposed to use and the enter the wrong one then apply and they have no service. That's NOT a good feature.  How can this page be disabled ?

Another issue is that even if they do not see that error (becuase they are not using the service at that moment,  the "Internet" light on the modem will remain Red through successive reboots until we help them reprogram the modem!   What a waste of time!!

None of the other modems our users use have these issues, TPLink, ComTest, SageCom even Tenda.  All work.  Why is DLink so difficult ?
Logged

GreenBay42

  • Administrator
  • Level 10 Member
  • *
  • Posts: 2194
Re: PPPOE Authentication settings ?
« Reply #1 on: July 08, 2019, 08:23:22 AM »

Contact Canadian tech support to assist you with this. They can send a ticket to the engineers in Taiwan to see if there is a solution.
Logged

LarryNOTtheCableGuy

  • Level 2 Member
  • **
  • Posts: 46
Re: PPPOE Authentication settings ?
« Reply #2 on: August 06, 2019, 06:15:41 PM »

One of the causes seems to be that if the 520b gets an error back from the NAS or Radius is pops up a web page to the user  "ISP Authentication failed.  Please enter your password".  The user almost NEVER know which password they are supposed to use and the enter the wrong one then apply and they have no service. That's NOT a good feature.  How can this page be disabled ?

I'm using DSL-520B modems with two different ISPs in Ontario: Pathway in Toronto, and Vianet in Muskoka. Both sublet Bell Canada's DSL service. I've never had the problem you describe in either location. Is it possible the modems are simply not configured correctly?

Granted, I do occasionally get service disconnects, which require the modem to be power cycled to correct. But in all cases, this solves the problem. As this usually happens when I'm not at home, I now power cycle the modems daily, whether they need it or not. In one location I have a simple dumb timer setup to power cycle all of the network components at 4:00 am. At the other location, which is unoccupied for long periods at a time, I have a Raspberry Pi checking the internet connection hourly and power cycling the modem when required. I've tried dumb timers in this location, but for some unknown reason I've had two fail at critical times (the last time happened just a few days before my basement flooded, which went undetected for two weeks).

If you like, I can provide you with the PPPOE settings I use.

Larry ....
Logged
DSL-520B  HW:T1 FW:1.00NA
DIR-885L  HW:A1  FW:1.20
DGS-108  HW:B1
DCS-5020L  HW:A1  FW:1.15.12