• October 15, 2019, 06:44:35 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DCH-S161 keeps disconnecting  (Read 1244 times)

desi2000

  • Level 1 Member
  • *
  • Posts: 2
DCH-S161 keeps disconnecting
« on: April 24, 2019, 07:46:31 AM »

Hi there.

I purchased 4 DCH-S161 water sensors for our home over a month ago and recently I've been getting notifications sent to my iPhone stating that my sensors have disconnected. I go and press the side button and the green LED lights up again. I day or so later, this happens again randomly to all of my devices. I'm not sure if there was an update pushed out, but I never had this problem when I first purchased these DCH-S161 water sensors.

Any advice / suggestions would be appreciated.

Cheers!
Logged

GreenBay42

  • Administrator
  • Level 10 Member
  • *
  • Posts: 2192
Re: DCH-S161 keeps disconnecting
« Reply #1 on: April 24, 2019, 07:51:43 AM »

I believe the issue has been reported. It has something to do with the power save mode that is disconnecting from your wifi network. When water is detected, it will turn on and then notify you but it will prevent you from accessing the sensor via the app until you press the button to wake it up.
« Last Edit: April 30, 2019, 03:37:44 PM by GreenBay42 »
Logged

desi2000

  • Level 1 Member
  • *
  • Posts: 2
Re: DCH-S161 keeps disconnecting
« Reply #2 on: April 24, 2019, 08:05:03 AM »

Thanks for the quick response.

Looking forward to seeing this get fixed.

Cheers!
Logged

sumppump57

  • Level 1 Member
  • *
  • Posts: 1
Re: DCH-S161 keeps disconnecting
« Reply #3 on: April 27, 2019, 09:08:05 PM »

I'm observing the same behavior.  I can't find any documentation from D Link describing this either.  It would be useful if the next firmware version gives users the option of having the wifi disconnect or not when entering power save mode.

I suspect that the auto disconnect is also causing problems with getting IFTTT to work.  I get error core 101/0 when trying to use the IFTTT applets for automatic notifications and actions.
Logged

GreenBay42

  • Administrator
  • Level 10 Member
  • *
  • Posts: 2192
Re: DCH-S161 keeps disconnecting
« Reply #4 on: May 06, 2019, 08:41:00 AM »

As of now, there is no way to turn off "power save" mode so it will be enabled after about 45 seconds to 1 minute. The sensor will work - when it detects water, siren will turn on and the sensor will reconnect to the wifi network, send a signal to the mydlink servers saying "hey i detect water" which will then send a notification to your device (phone or tablet).

When the sensor is in power save mode, it currently sends a signal every 24 hours to the mydlink server saying "im here". If the mydlink server does not get that message, it will then send a notification that the sensor is disconnected. This is caused by the sensor not reconnecting with the wifi network.

We have asked to 1. change the beacon time to every say 12 hours, not 24, or have an option to specify, and 2. have an option to disable power save mode which will eat up batteries extremely fast.

The main issue is the sensor is not reconnecting to the wifi network. Make sure the sensor is within (strong) range of your wireless router or access point. The engineers have done several tests with multiple units and it seems to work without issues, but honestly not sure their testing environment (how close to a router they are). I will try mine in my garage at home where the signal is much weaker to see how well it reconnects.

Logged