D-Link IP Cameras for Home > DCS-8525LH

Not working - NIPCA commands resultcode=unauthorized or This File is Forbidden

(1/3) > >>

Hi all,

Hope you can help with this issue... about 5-6 months ago I bought a DCS8525LH-11A3 camera. I integrated it with MotionEye as soon as I got it up and running, basically all I had to do was:

-Reset camera
-Register the camera via myDlink app for Android (to connect it to my network)
-Go to my Router and give it a static IP (via DHCP reservation)

After this I was able to get the stream via NIPCA:

(HTTP) http://admin:<PIN>@CAMERAIP/video/mjpg.cgi
(VLC STREAM) http://admin:<PIN>@CAMERAIP/video/ACVS-H264.cgi?profileid=1

I was able to use all the NIPCA commands. I was even using the PTZ commands to move my camera based on scripts which are managed by sensors. (a script which makes an HTTP POST request with the NIPCA command)

Out of the blue now I cannot no longer connect (no updates, no nothing), it just stopped working altogether. Now I am unable to use HTTP for everything, I can partially use HTTPS to get at least a different message.

For example:
(HTTP) https://admin:<PIN>@CAMERAIP/video/mjpg.cgi -> CONNECTION REFUSED, mnothing loads
(HTTPS) https://admin:<PIN>@CAMERAIP/video/mjpg.cgi -> I get the following plain text response "resultcode=unauthorized" or "This file is forbidden... go back to home page"

Basically I cannot do anything at all. I can only access

And I get this over that command:

--- Code: ---model=DCS-8525LH
product=Wireless Internet Camera
--- End code ---

I  have tried to reset it plenty of times, tried over WiFi and Ethernet, I gave it a new IP address, I tried POSTMAN request with BASIC and DIGEST always using ADMIN as user and the PIN code in the label of my camera.

Any ideas on what could be causing this error or if there's any solution?
I can only use my camera with the Android/iOS applications which make it an utterly useless 90 USD camera. I could have gotten a Xiaomi Xiaofang 1080P camera with exactly the same features and capabilities for 20 USD if I didn't mind sticking to an Android app.

Just to add on, I have NOT make any changes in my router configuration (or network topology). I have only added a new DCS-930L camera about a week earlier, I did remove it when I started having the issues described above. Other than that there has not been any other changes.

I am shocked you got this to work. What firmware is currently on it?

This cameras is not supposed to support http/rtsp but the original release left a few holes in the firmware to allow some commands to work.

Same for me !! i don't understand why we need use MyDlink to use my cam !! the new firmware 1.03.06 updated this night, block any acces from my camera manager ! Mydlink it's an bad application very low, not optimized and absolutly not pratical, and i don't talk about alexa skill .... please someone have more information to unclock this situation ?

After searching i find this informations :

Source : https://tsd.dlink.com.tw/
Select DCS and 8525LH

1. Update mydlink agent to v 3.2.3-b01
2. Support mydlink APP rich notification feature
3. Support mydlink APP fw manual upgrade feature. -> (Where ?)
4. Support Micro SD cards up to 256GB.
5. PIN code as default password and setup by FW not factory. -> (what's FW ? Firmware ?)
6. Support D-Link NIPCA DCS Authentication and Password
Encryption_v1.2.pdf -> (More information about encryption please ??)
7. Support D-Link Anti-Brute-Force Attack Mechanism_v04
8. Support WEP encryption
9. Set the PIN code as password after binding.
10.Support rtsp live stream over UDP, with Digest authertication

1. Update mydlink agent to v3.0.0-b75
2. Support mydlink Requirements for IoT Agent Version 1.0.6

1. Update mydlink agent to v3.0.0-b64.1
2. Change Video spec , 1080P up to 1.5M bitrate

i can't downgrade, i can't do anything with this cam !! on site i have this message :

--- Quote ---
This device works with the mydlink app. On your mobile device, download and install the mydlink app from the App Store or Google Play.

--- End quote ---

Unbelievable ... but it's true ... we can't manage this cam because on dlink App we can't do nothing too ....

The dcs-8xxxLH series cameras were designed to be app-only cameras and will not have all the same features as most other D-Link cameras.

The new firmware got pushed out today in the US and should be out globally by tomorrow.

- #2 and 3 - mydlink app rich notification and manual upgrade features will be added to version 1.8 of the mydlink app (not out yet).

- Not really sure how to translate #5. The PIN number (located on the bottom of the camera) is uses as the default password for RTSP/3rd party.

- #6 not sure what that means. I will find out more.

- #10 - new to this camera (but FINALLY added). Will do some testing this week.

Before 1.03.06 i could connect with my 3rd partie sofware at the DCS8525LH camera from this link http://admin:<PIN>@CAMERAIP/video/flv.cgi (Video 60fps and sound). This feature was always available like gurbina93, but with this new firmware update, we can't any more ... I think it's the new encryption system... if you can just explain how we can use the new NIPCA when you'll has more information



[0] Message Index

[#] Next page

Go to full version