• December 09, 2019, 10:47:50 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Cannot port forward Foscam Camera / From Port 8081 to Port 80  (Read 1303 times)

johnjces

  • Level 1 Member
  • *
  • Posts: 3
Cannot port forward Foscam Camera / From Port 8081 to Port 80
« on: January 08, 2019, 10:05:50 AM »

Good day!

I have searched the forums here and elsewhere for answers to this most simple of router tasks and cannot seem to find out what works. I am not a newbe to these devices but this is kicking me! And please forgive me if this is too wordy or long. I sometimes have a hard time getting the issue verbalized on forums.

This router is a DSR250 (DSR-250) with the latest firmware installed on 1/7/2019 version 3.11_WW. The firmware date seems to be 10/15/2018. Using COX Cable Internet and they are not supposed to blocking port 8081 and up.

In this specific router I have easily port forwarded VOIP and SIP traffic for a FreePBX. I.E. WAN IP to port 5060 to LAN IP port 5060, and etc for the other needed and desired ports. These all go from the same port number to the same port number.

I have a Foscam camera which uses a proprietary Audio and Video Codec. I have used these exact same cameras on a Netgear router with no issue going from WAN ANY IP Port 808X to LAN IP Port 80 and they have worked great. I have also used the same model cameras on two Linux iptables gateways/routers.

Simply I have set up a custom service for port 8081 in to port 80 using the multiple ports (only two lines to enter whereby port range has four (4) lines to enter) called Foscam 1. Added a Firewall rule to allow this from the Insecure WAN to Secure LAN, ANY IP, Always Allow, Never Log and save. It never works and this is the exact same setup I have for the VOIP stuff which does work!

What I don't know anything about is the Translate Port and Enable Port Forwarding and Insecure WAN (only item that shows in the drop down box) at the bottom of the rule dialog box. When you click Enable Port Forwarding you have to enter a port to translate and this confuses me. The default is Port is shown as zero (0). The language "Enable Port Forwarding" is wrong as it is NOT needed to port forward any of my VOIP rules. Some older forum posts show not entering stuff in the custom rule which you have to enter in the latest firmware and things are just... weird.

SO... in summary, how do I go from any WAN IP from a specific port like 8081 or even 2525, to port 80 to a specific IP (camera) on the LAN? It should be so simple and it is for other stuff!
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47964
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Cannot port forward Foscam Camera / From Port 8081 to Port 80
« Reply #1 on: January 08, 2019, 02:27:44 PM »

I recommend that you phone contact your regional D-Link support office and ask for help and information regarding this.
Link> Tech Support Contact Information
We find that phone contact has better immediate results over using email.
Let us know how it goes please.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

johnjces

  • Level 1 Member
  • *
  • Posts: 3
Re: Cannot port forward Foscam Camera / From Port 8081 to Port 80
« Reply #2 on: January 10, 2019, 07:54:56 PM »

There is a similar post pinned at the top of this forum, but we were unsuccessful trying that approach. However, we did receive the following response from D-Link tech support which worked!!! Here it is.

Based from what I have read you would like to forward a specific port through your WAN IP,  for example 8081 or 2525 to a local IP with a local port of 80. Please create a custom service for the specific port (8081 or 2525) please don't indicate anything in the source port. For example create a custom service, set it as multiple port, (there are only two lines in this specific rule start, not 4 lines that is suggested in the pinned topic above), set it to either TCP, UDP or both, type in the desired port in the destination port (8081) if you would like multiple ports you can separate the ports using a comma (,) for example (8081,2525) and you can leave the source port as empty. After creating the said custom service, you can then create the firewall rule, as indicated in your E-mail your firewall rule is correct, you just need to enable port forwarding and type in 80 in the said space. This will act as a local port for the local IP but the remote port is 8081, so you would be able to access the IP using WAN IP:8081 and it will be forwarded to the local IP using the local port of 80.

Moderators: PLEASE change this in pinned topic above:
3. Leave Source Start Port and Source Finish Port BLANK. (Using this it would not allow us to save the new service)
4. Enter the port number(s) or port ranges into the Destination Start Port and Destination Finish Port fields
to
3. Select Multiple Ports. LEAVE SOURCE PORTS BLANK.
4. Enter the source WAN port numbers separated by a comma if using multiple ports into the DESTINATION PORTS.
Logged

GreenBay42

  • Administrator
  • Level 10 Member
  • *
  • Posts: 2251
Re: Cannot port forward Foscam Camera / From Port 8081 to Port 80
« Reply #3 on: January 11, 2019, 07:01:59 AM »

Thanks for the update. I updated the pinned post.
Logged