• September 23, 2018, 10:29:56 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Can not open port 443 for RaspBerry Pi  (Read 197 times)

dummyuser

  • Level 1 Member
  • *
  • Posts: 6
Can not open port 443 for RaspBerry Pi
« on: September 10, 2018, 12:12:41 PM »

Hello

I have a DIR-850L A1, 1.21WW (Europe). Behind the router I have a Raspberry Pi to which I want to connect through SSH on port 443.
However, the router makes this impossible. Any port I try to forward from my Raspberry Pi does not get through the router.



I have forwarded ports for my NAS and Pi. My NAS I can access from outside my network but the Pi I cannot.

However. The Pi gets an IP through DHCP reservation, and if I change the IP to a different one, the port is forwarded for a couple of hours.
After those hours the port is never able to be accessed again. When trying to use a completely static IP, the port forwarding does not work at all.

Is there any solution for this? I would prefer to keep using this router as it has served me quite well.

Thank you
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 45772
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Can not open port 443 for RaspBerry Pi
« Reply #1 on: September 10, 2018, 12:23:20 PM »

Link>Welcome!

Internet Service Provider and Modem Configurations
  • What ISP Service do you have? Cable or DSL?
  • What ISP Modem Mfr. and model # do you have?
  • Set Firewall settings to Endpoint Independent for TCP and UDP under Advanced/Firewall. Enable or Disable SPI to test if seen.
  • Enable uPnP and Multi-cast Streaming under Advanced/Networking. Disable uPnP for testing Port Forwarding rules.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

dummyuser

  • Level 1 Member
  • *
  • Posts: 6
Re: Can not open port 443 for RaspBerry Pi
« Reply #2 on: September 10, 2018, 01:40:26 PM »

Link>Welcome!

Internet Service Provider and Modem Configurations
  • What ISP Service do you have? Cable or DSL?
  • What ISP Modem Mfr. and model # do you have?
  • Set Firewall settings to Endpoint Independent for TCP and UDP under Advanced/Firewall. Enable or Disable SPI to test if seen.
  • Enable uPnP and Multi-cast Streaming under Advanced/Networking. Disable uPnP for testing Port Forwarding rules.

Hi

Thank you for the quick response! :)

- ISP Service: DSL
- ISP Model: BBOX 3 (Not a common model, just for Belgium): http://www.zoobab.com/bbox3-technicolor
- I'm not sure what you mean by Endpoint Independent? I don't see the option Advanced/Firewall anywhere.

- I disabled and enabled SPI, no difference
- I disabled and enabled uPnp, Multi-cast Streaming, no difference.
Logged

GreenBay42

  • Administrator
  • Level 8 Member
  • *
  • Posts: 1329
Re: Can not open port 443 for RaspBerry Pi
« Reply #3 on: September 10, 2018, 02:30:57 PM »

Make sure SSH is enabled on your Pi since it normally is disabled by default. Also, isn't port 22 used by default on the Raspberry Pi for SSH?  If this is the case use Virtual Server instead of Port Forwarding.

Public Port = 443 
Private Port = 22 (or whatever you assigned the Raspberry Pi)

Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 45772
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Can not open port 443 for RaspBerry Pi
« Reply #4 on: September 10, 2018, 02:36:35 PM »

Ok I wasn't sure if you had it or not. D-Link removed Endpoint Features a while back.
 :(
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

dummyuser

  • Level 1 Member
  • *
  • Posts: 6
Re: Can not open port 443 for RaspBerry Pi
« Reply #5 on: September 11, 2018, 02:45:04 AM »

Make sure SSH is enabled on your Pi since it normally is disabled by default. Also, isn't port 22 used by default on the Raspberry Pi for SSH?  If this is the case use Virtual Server instead of Port Forwarding.

Public Port = 443 
Private Port = 22 (or whatever you assigned the Raspberry Pi)

Thanks for the reply!

SSH is enabled and the port has been changed to 443.
I don't think the issue is the Pi, because when I remove the DLink I can access the Pi.

I also tried with other ports (like 80) but none get opened.
Logged

dummyuser

  • Level 1 Member
  • *
  • Posts: 6
Re: Can not open port 443 for RaspBerry Pi
« Reply #6 on: September 11, 2018, 02:47:01 AM »

Ok I wasn't sure if you had it or not. D-Link removed Endpoint Features a while back.
 :(

Welp. Thanks anyways. :)
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 45772
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Can not open port 443 for RaspBerry Pi
« Reply #7 on: September 11, 2018, 06:52:29 AM »

Does your ISP modem already have a built in router or is it just a modem only?
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

dummyuser

  • Level 1 Member
  • *
  • Posts: 6
Re: Can not open port 443 for RaspBerry Pi
« Reply #8 on: September 11, 2018, 07:26:43 AM »

Does your ISP modem already have a built in router or is it just a modem only?

It has a build on router. But on that router I put the DLink as DMZ.
Logged

GreenBay42

  • Administrator
  • Level 8 Member
  • *
  • Posts: 1329
Re: Can not open port 443 for RaspBerry Pi
« Reply #9 on: September 11, 2018, 07:44:48 AM »

Ah double-NAT. You should place the modem-router in bridge mode then use the D-Link as your router. I would also suggest not using 443 at the port. Use something between 1028-65535. At least try to test.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 45772
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Can not open port 443 for RaspBerry Pi
« Reply #10 on: September 11, 2018, 09:26:53 AM »

  • If the ISP modem has a built in router, it's best to bridge the modem. Having 2 routers on the same line can cause connection problems: Link>Double NAT and How NAT Works. Call the ISP and ask to see if the ISP modem can be bridged. To tell if the modem is bridged or not, look at the routers web page, Status/Device Info/Wan Section, if there is a 192.168.0.# address in the WAN IP address field, then the modem is not bridged. If the modem can't be bridged then see if the modem has a DMZ option and input the IP address the router gets from the modem and put that into the modems DMZ. Also check the routers DHCP IP address maybe conflicting with the ISP modems IP address of 192.168.0.1. Check to see if this is the same on the ISP modem, and if modem can't be bridged, change the DIR router to 192.168.1.1 or .0.254.
    Example of a D-Link router configured for PPPoE with ISP Modem bridged: PPPoE Configuration on a Router
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

dummyuser

  • Level 1 Member
  • *
  • Posts: 6
Re: Can not open port 443 for RaspBerry Pi
« Reply #11 on: September 11, 2018, 10:40:52 AM »

Ah double-NAT. You should place the modem-router in bridge mode then use the D-Link as your router. I would also suggest not using 443 at the port. Use something between 1028-65535. At least try to test.

  • If the ISP modem has a built in router, it's best to bridge the modem. Having 2 routers on the same line can cause connection problems: Link>Double NAT and How NAT Works. Call the ISP and ask to see if the ISP modem can be bridged. To tell if the modem is bridged or not, look at the routers web page, Status/Device Info/Wan Section, if there is a 192.168.0.# address in the WAN IP address field, then the modem is not bridged. If the modem can't be bridged then see if the modem has a DMZ option and input the IP address the router gets from the modem and put that into the modems DMZ. Also check the routers DHCP IP address maybe conflicting with the ISP modems IP address of 192.168.0.1. Check to see if this is the same on the ISP modem, and if modem can't be bridged, change the DIR router to 192.168.1.1 or .0.254.
    Example of a D-Link router configured for PPPoE with ISP Modem bridged: PPPoE Configuration on a Router

Unfortunately my ISP does not allow this (they don't give us the username and password) so it's not possible.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 45772
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Can not open port 443 for RaspBerry Pi
« Reply #12 on: September 11, 2018, 10:53:52 AM »

I would contact the ISP and ask them if they can help you configure the DMZ for the use of the 850L. If they won't, then the only other option will be to use the ISP Modem as your main host router and configure the 850L as a LAN to LAN AP:
Turning a router into an AP.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!