• February 17, 2019, 10:25:06 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DSL 2730U IN_R_01.00.01 How do I turn off ssh, telnet, ftp, park-agent, etc  (Read 1131 times)

veek

  • Level 1 Member
  • *
  • Posts: 4

Hi, just bought a D-Link modem today. I can't find a way to turn off open ports that show up during a nmap scan of 192.168.1.1 (LAN Interface).
21/tcp   open  ftp
22/tcp   open  ssh
23/tcp   open  telnet
53/tcp   open  domain
80/tcp   open  http
5431/tcp open  park-agent
http://pix.toile-libre.org/?img=1525269241.png

I have turned off those services in the web interface to no avail:
http://pix.toile-libre.org/upload/original/1525269377.png
http://pix.toile-libre.org/upload/original/1525269405.png

Additionally the modem responds to ping on the LAN iface even if I disable ping (as above - on the LAN iface) - how do I turn that off?
Is there an updated firmware I can use? Can I return this modem - I need something secure and open ports are an invitation to  get owned (even if they are on the LAN/internal interface)
« Last Edit: May 02, 2018, 07:13:24 AM by veek »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 46795
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology

Link>Welcome!

  • What Hardware version is your modem? Look at the sticker under modem.
  • Link>What Firmware version is currently loaded? Found on the modems web page under status.
  • What region are you located?

First make sure that your PCc and other devices are not actively using those ports. Port 53 and 80 and internet ports which are needed and maybe already open at the time of your test. Disable or turn OFF ALL other devices, close browsers, and any background running applications on 1 test PC.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

veek

  • Level 1 Member
  • *
  • Posts: 4

h/w version is I1
firmware version IN_R_01.00.05 (the shop must have flashed it to .05 because someones overwritten .01 on the nameplate details [bottom] with .05)
Location India
OS Linux

The open ports are ON THE MODEM.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 46795
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology

First make sure that your PCc and other devices are not actively using those ports. Port 53 and 80 and internet ports which are needed and maybe already open at the time of your test by a connected device. Disable or turn OFF ALL other devices, close browsers, and any background running applications on 1 test PC.

I recommend that you phone contact your regional D-Link support office and ask for help and information regarding this. We find that phone contact has better immediate results over using email.

Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

GreenBay42

  • Administrator
  • Level 9 Member
  • *
  • Posts: 1833

Are you scanning to see vulnerabilities? If you do a port scan from your local network, there will always be open ports, especially scanning the LAN IP.

To test open ports on your modem/router that are exposed from the Internet, you need to scan the WAN IP address from the Internet, not your LAN.
Logged

veek

  • Level 1 Member
  • *
  • Posts: 4

I'd like to turn off all unused services on the modem - BOTH LAN and WAN side. (I'm scanning the MODEM IP - 192.168.1.1 is the MODEM - wanted to see if the web interface was working as it should.. but it isn't.. to the best of my knowledge :( darn ports on the LAN-side of the modem don't turn off)
Logged

GreenBay42

  • Administrator
  • Level 9 Member
  • *
  • Posts: 1833

I am not familiar with this product or interface since it is not sold in the US.

From the 3rd screen shot, I believe you have to set the rule and click Add. The ACL table at the bottom is empty so the rule is not active.
Logged

veek

  • Level 1 Member
  • *
  • Posts: 4

http://pix.toile-libre.org/upload/original/1525329534.png
So I added some ACL rules WAN - ping is allowed but for the LAN only telnet, web, and ping are allowed. Unfortunately I can ftp to the MODEM.. and ping it
http://pix.toile-libre.org/upload/original/1525329723.png
http://pix.toile-libre.org/upload/original/1525329784.png
(FTP from 192.168.1.100 --> 192.168.1.1)

« Last Edit: May 02, 2018, 11:46:06 PM by veek »
Logged