• November 18, 2018, 12:22:36 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: SSH root access  (Read 1304 times)

rickxyz

  • Level 1 Member
  • *
  • Posts: 5
SSH root access
« on: February 07, 2018, 02:23:36 PM »

Hello!

I have a DNS-320L.

I used the fun plug before. After upgrading a firmware, ffp stopped work.
Now, I installed the SSH Add-on 3.0, but I can't login with root user, appear a message: "Access denied". I can login with a normal user.
I also tried to use the Telnet add-on to clear the root password, but no success.

How can I fix it?


Thanks.
Logged

vtverdohleb

  • Level 5 Member
  • *****
  • Posts: 686
    • Add-Ons for D-Link NAS
Re: SSH root access
« Reply #1 on: February 13, 2018, 07:17:58 AM »

I used the fun plug before. After upgrading a firmware, ffp stopped work.
Now, I installed the SSH Add-on 3.0, but I can't login with root user, appear a message: "Access denied". I can login with a normal user.
I also tried to use the Telnet add-on to clear the root password, but no success.

Possible option:
1. SSH built-in to firmware is enabled. Disable the built-in service, restart the SSH addon, or overload the NAS
2. fun_plug damaged the system file "/etc/shells". Its contents should be as follows:
Code: [Select]
/bin/sh
/usr/bin/bash
Logged
Add-on Application questions and issues, please include the following minimal information in your post:
* ShareCenter Model
* Add-on Name
* Add-on Version
* Detailed Description of your Issue
Donate: http://dlink.vtverdohleb.org.ua/Add-On/donate.php

rickxyz

  • Level 1 Member
  • *
  • Posts: 5
Re: SSH root access
« Reply #2 on: February 13, 2018, 09:22:00 AM »

Possible option:
1. SSH built-in to firmware is enabled. Disable the built-in service, restart the SSH addon, or overload the NAS
2. fun_plug damaged the system file "/etc/shells". Its contents should be as follows:
Code: [Select]
/bin/sh
/usr/bin/bash

1. The SSH built-in was disabled.
2. I think this could be the cause. I checked the passwd and shadow files, but I didn't remember to check the /etc/shells.
But I can't found anymore, cause I made a factory reset and the NAS works well now.
Thanks anyway!
Logged

ova

  • Level 1 Member
  • *
  • Posts: 5
Re: SSH root access
« Reply #3 on: November 10, 2018, 01:05:55 PM »

Hi there,

I have exactly the same... but can't fix it.
I have manually installed the add-on DNS-320L sshd Package v3.00_01162016
In Network Management, the option " Allow SSH connection" is unchecked.
In System Status -> System Services, I have restarted sshd (I supppose it is the new sshs add-on)
I can't login with root user... I suppose blank means no password

Any help is welcome...

Thank you
Logged

ova

  • Level 1 Member
  • *
  • Posts: 5
Re: SSH root access
« Reply #4 on: November 10, 2018, 01:17:53 PM »

Hi again,

Looking at /etc/passwd it seems I have some leftover from ffp

root:x:0:0:Linux User,,,:/ffp/home/root:/ffp/bin/sh

Should I remove that line?

Rgds,
Logged

ova

  • Level 1 Member
  • *
  • Posts: 5
Re: SSH root access
« Reply #5 on: November 13, 2018, 10:55:40 AM »

Finally I also tried the factory reset and it works !
Logged