• October 24, 2020, 10:43:32 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DNS-345 and MYSQL  (Read 3297 times)

Legion

  • Level 1 Member
  • *
  • Posts: 6
DNS-345 and MYSQL
« on: November 16, 2017, 11:12:27 PM »

I am having a major issue with my DNS 345.  I was using a mysql database with OSMC/Kodi to serve TV shows and movies.  I had a problem where if my TV shops went over a certain amount, around 186,  choosing a show would do nothing, the screen would flicker then return to the main menu.  I tried a lot of things to repair this and got to the stage where I had deleted all databases in MYSQL through phpmyadmin and rebuilt them.  It seemed to work and the TV shows seemed OK.
Last week when changing from one show to another the database refused to load.  Going into the web interface and phpmyadmin I could not log into phymyadmin.  After trying a number of things, including deleting and reinstalling the addon numerous times I still couldn't log in.  I downgraded phpmyadmin to  1.1 and upgraded the DNS to 1.05, but it made no difference.  I am starting to think that the mysql database program just isn't loading and phpmy admin refuses to log because as far as it is concerned the mysql database doesn't exist.  I had hoped that upgrading the DNS would reinstall mysql, if that is the problem, but no luck.  I have tried to edit the php config file but that seems to create more problems.
So, questions - any help gratefully excepted. 
Is there a way to check that mysql is actually loaded?  If that is confirmed any idea why I cannot log into it with phpmyadmin?
Logged

Legion

  • Level 1 Member
  • *
  • Posts: 6
Re: DNS-345 and MYSQL
« Reply #1 on: November 17, 2017, 03:11:08 PM »

As a bit of an update, and possibly in keeping with my idea that MySQL has dropped out.  I was having a delve into the OS using Webmin and found two things which may mean something,  1st - PostgreSQL Database Server - not installed and 2nd - (under Disk and Network Filesystems)
/usr/local/modules    SQUASHFS    /usr/local/tmp/image.cfs    100 % (used)

These may mean nothing but as the only reference to MySQL is that above I sense that I am correct in my idea that for some reason the MySQL server has dropped out.

As I can run commands under Webmin and /or SSH is there a way to restart MySQL or see if it is actually installed.
Logged

vtverdohleb

  • Level 5 Member
  • *****
  • Posts: 712
    • Add-Ons for D-Link NAS
Re: DNS-345 and MYSQL
« Reply #2 on: November 23, 2017, 11:56:41 AM »

Webmin is a great program for managing the system. BUT it is designed for the standard location of the configuration files for the operating system in use.
On DNS-3xx, many configuration files are not located where Webmin searches for them. As a result - without proper configuration, Webmin on the DNS-3xx device is useless.
For example: MySQL configuration is done through the configuration file "my.cnf". On a device DNS-3xx, "my.cnf" does not exist. Using the settings built into MySQL during compilation.
Logged
Add-on Application questions and issues, please include the following minimal information in your post:
* ShareCenter Model
* Add-on Name
* Add-on Version
* Detailed Description of your Issue
Donate: http://dlink.vtverdohleb.org.ua/Add-On/donate.php