• October 25, 2020, 05:45:53 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  


This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: [SOLVED] Curl command in motion  (Read 2454 times)


  • Level 1 Member
  • *
  • Posts: 2
[SOLVED] Curl command in motion
« on: January 23, 2017, 10:14:14 AM »


Firmware 2.14
Trying to enable/ disable the motion detection feature by a curl command like:

Code: [Select]
curl -u userid:password http://IPaddress/setSystemMotion –referer http://IPaddress/motion.htm -d « ReplySuccessPage=motion.htm&ReplyErrorPage=motion.htm&MotionDetectionEnable=1&MotionDetectionScheduleDay=0&MotionDetectionScheduleMode=0&MotionDetectionSensitivity=30&ConfigSystemMotion=Save » > /dev/null 2>&1
but keeping getting error
Code: [Select]
<html><body><h1>The request is forbidden.</h1></body></html>
curl: (6) Could not resolve host: xn--referer-t16c
<html><body><h1>The request is forbidden.</h1></body></html>
curl: (6) Could not resolve host: ReplySuccessPage=motion.htm

The end use is to append this to a virtual switch in Domoticz that allows me to turn this function on/ off remotely via its own control panel. 
Any help would be appreciated.

« Last Edit: January 24, 2017, 10:15:32 AM by rebelo »


  • Level 1 Member
  • *
  • Posts: 2
Re: Curl command in motion
« Reply #1 on: January 24, 2017, 10:14:48 AM »

Well found it using the help form this post:

A simple http request assigned in the switch did the trick

Try with and without port number.

Tks all



  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49284
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: [SOLVED] Curl command in motion
« Reply #2 on: March 07, 2017, 06:56:58 AM »

Thanks for posting. Hope this help future users.
Enjoy.  ;)
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!