• October 23, 2020, 01:44:07 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DWR-921 Router not connecting  (Read 14678 times)

R45tah

  • Level 1 Member
  • *
  • Posts: 1
DWR-921 Router not connecting
« on: December 07, 2016, 05:44:32 AM »

Hello,

I recently purchased a DWR-921. However it has not been able to connect to the internet via 4G. I have tried updated the firmware forwards and backwards. I have tried another Sim, I have even tried my Sim in  another router. The Sim is perfectly functional.
However In this router it does not work, it seemed to get the time clock wrong, but by syncing with my laptop would fix this. however it continues to attempt to connect and then appears disconnected. with the following being logged.

Dec 5 12:23:21 kernel: klogd started: BusyBox v1.3.2 (2014-09-03 11:25:37 CST)
Dec 5 12:23:25 syslog: Failure parsing line 12 of /etc/udhcpd.conf
Dec 5 12:23:25 syslog: server_config.pool_check = 1
Dec 5 12:23:25 syslog: start = 192.168.0.50, end = 192.168.0.199, lan_ip = 192.168.0.1, interface=br0, ifindex=0
Dec 5 12:23:25 udhcpd[1111]: udhcpd (v0.9.9-pre) started
Dec 5 12:23:32 commander: Init NAT Server ...
Dec 5 12:23:37 nat: Using the packet filter which support IP range
Dec 5 12:23:38 syslog[2468]: sendto error: 8.8.8.8:
Dec 5 12:23:38 syslog[2468]: Deactivating DNS server 8.8.8.8
Dec 5 12:23:38 syslog[2468]: Setting server 4.2.2.2 for domain (default)
Dec 5 12:23:38 syslog[2468]: sendto error: 4.2.2.2:
Dec 5 12:23:38 syslog[2468]: Deactivating DNS server 4.2.2.2
Dec 5 12:23:38 syslog[2468]: No active servers for domain (default)
Dec 5 12:23:42 commander: STOP WANTYPE 3G
Dec 5 12:23:44 init: Starting pid 2676, console /dev/ttyS1: '/bin/ash'
Dec 5 12:23:48 commander: Synchronization Time Fail. System would re-sync later
Dec 5 12:23:48 syslog[2468]: sendto error: 8.8.8.8:
Dec 5 12:23:48 syslog[2468]: sendto error: 4.2.2.2:
Dec 5 12:23:49 commander: Stop NAT Server since Half-Bridge enable ...
Dec 5 12:23:53 O3G/hotplug: 3G modem VendorID=1435 ProductID=0918
Dec 5 12:23:58 syslog[2468]: sendto error: 8.8.8.8:
Dec 5 12:23:58 syslog[2468]: sendto error: 4.2.2.2:
Dec 5 12:24:00 commander: Synchronization Time Fail. System would re-sync later
Dec 5 12:24:03 O3G/hotplug: THIS IS EVDO MODEM CARD!!
Dec 5 12:24:09 syslog[2468]: sendto error: 8.8.8.8:
Dec 5 12:24:09 syslog[2468]: sendto error: 4.2.2.2:
Dec 5 12:24:11 234304142172306 30, *99#, general.t-mobile.uk, user, wap
Dec 5 12:24:12 O3G/3g_notifyd: 3G Notify Server started
Dec 5 12:24:13 commander: Synchronization Time Fail. System would re-sync later
Dec 5 12:24:14 O3G/3g_notifyd: All initial tasks are done
Dec 5 12:24:18 syslog[2468]: sendto error: 8.8.8.8:
Dec 5 12:24:18 syslog[2468]: sendto error: 4.2.2.2:
Dec 5 12:24:26 commander: Synchronization Time Fail. System would re-sync later
Dec 5 12:24:28 commander: START WANTYPE 3G
Dec 5 12:24:28 syslog[2468]: sendto error: 8.8.8.8:
Dec 5 12:24:28 syslog[2468]: sendto error: 4.2.2.2:
Dec 5 12:24:38 syslog[2468]: sendto error: 8.8.8.8:
Dec 5 12:24:38 syslog[2468]: sendto error: 4.2.2.2:
Dec 5 12:24:38 commander: Synchronization Time Fail. System would re-sync later
Dec 5 12:24:48 commander: STOP WANTYPE 3G
Dec 5 12:24:48 syslog[2468]: sendto error: 8.8.8.8:
Dec 5 12:24:48 syslog[2468]: sendto error: 4.2.2.2:
Dec 5 12:24:49 commander: START WANTYPE 3G
Dec 5 12:24:51 commander: Synchronization Time Fail. System would re-sync later
Dec 5 12:24:58 syslog[2468]: sendto error: 8.8.8.8:

Any ideas how I can solve this ?

Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49275
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DWR-921 Router not connecting
« Reply #1 on: December 07, 2016, 07:17:11 AM »

I recommend that you phone contact your regional D-Link support office and ask for help and information regarding this. We find that phone contact has better immediate results over using email.
Let us know how it goes please.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

am.john

  • Level 1 Member
  • *
  • Posts: 12
Re: DWR-921 Router not connecting
« Reply #2 on: December 17, 2016, 04:56:28 AM »

I have exactly the same problem, the router has been running for nearly 11 months trouble free, albeit recently dropping out more and more frequently, until finally I lost all connections on 3 or 4 g, SIM card is fine, log shows the same error as above. System clock seems to have lost settings, re setting  the clock does not help, I am thinking the unit is bricked ?.

As for the suggestion regarding phoning the local regional support. I don't know what its like elsewhere, but from the UK this is not helpful, THB a total waste of time, hence visiting the forums, it's really frustrating then to be told to phone regional support !.

The rest of the unit functions perfectly well (wi fi) but the 3/4g connection is now non existent, I wonder if the 3/4g transmitter part of the unit is toast ?.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49275
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DWR-921 Router not connecting
« Reply #3 on: December 17, 2016, 09:45:07 AM »

Unfortunately this model product is not marketed here in the USA. Thus the reason for having users with this product get a hold of there regional support office.

Has a factory reset been performed.
Maybe doing a factory reset, manually re-load current loaded FW, factory reset then set up from scratch.

I have exactly the same problem, the router has been running for nearly 11 months trouble free, albeit recently dropping out more and more frequently, until finally I lost all connections on 3 or 4 g, SIM card is fine, log shows the same error as above. System clock seems to have lost settings, re setting  the clock does not help, I am thinking the unit is bricked ?.

As for the suggestion regarding phoning the local regional support. I don't know what its like elsewhere, but from the UK this is not helpful, THB a total waste of time, hence visiting the forums, it's really frustrating then to be told to phone regional support !.

The rest of the unit functions perfectly well (wi fi) but the 3/4g connection is now non existent, I wonder if the 3/4g transmitter part of the unit is toast ?.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

am.john

  • Level 1 Member
  • *
  • Posts: 12
Re: DWR-921 Router not connecting
« Reply #4 on: December 17, 2016, 04:10:17 PM »

Thank you for the prompt reply, yes I have tried all of those, but unfortunately it is still not communicating with the 4g Network. Looks like I've got a failed unit just as the warranty runs out, grrrrrrrr..
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49275
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DWR-921 Router not connecting
« Reply #5 on: December 19, 2016, 06:42:31 AM »

Contact your regional D-Link support office and see if they can help any.

Good Luck.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

am.john

  • Level 1 Member
  • *
  • Posts: 12
Re: DWR-921 Router not connecting
« Reply #6 on: December 20, 2016, 01:04:07 AM »

Local support = Total Waste of Time unfortunately.
I gave up after resetting, rebooting, new Firmware etc. I bought another model which now works, just as a cross check I put sim back in old model with same settings but no it refuses to connect, router 4g bit definitely faulty. New model works absolutely fine, and seems to have better signal.

Thanks,

AMJ
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49275
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DWR-921 Router not connecting
« Reply #7 on: December 20, 2016, 06:56:41 AM »

Good Luck.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

rwanyingi

  • Level 1 Member
  • *
  • Posts: 1
Re: DWR-921 Router not connecting
« Reply #8 on: March 28, 2018, 07:19:15 AM »

Hi,

I got the same problem with my router. I fixed the problem ! :D :D
It was a loose contact on the sim card port. A Bit difficult to reach and lift the gold contacts on the port. I used a stencil blade to hat it. Now my router is up and running.
The speed is back , the smiles are back!
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49275
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DWR-921 Router not connecting
« Reply #9 on: March 28, 2018, 08:54:08 AM »

Glad you were able to fix it.

Enjoy.  ;)
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

BlackWind

  • Level 1 Member
  • *
  • Posts: 1
Re: DWR-921 Router not connecting
« Reply #10 on: August 07, 2020, 01:09:50 PM »

for the new user .. after inserting the sim-card and pressing the power button on the back side , i.e or powering the device up , allow 2 minutes and 20 seconds , the signal will be flashing Red during this period and it will turn Green and everything will be ok ,, REMEMBER ,,, 2 MINUTES AND 20 SECONDS
it needs ...
cheers... ;) ;) ;)
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49275
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: DWR-921 Router not connecting
« Reply #11 on: August 07, 2020, 07:35:09 PM »

Thanks for letting us know.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!