• December 09, 2018, 04:55:30 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DHCP no longer allows internet to connected devices.  (Read 1587 times)

crowtoo

  • Level 1 Member
  • *
  • Posts: 3
DHCP no longer allows internet to connected devices.
« on: December 04, 2016, 04:23:46 AM »

I've got a DIR-850L rev a1 which I've had for a couple of years. I use it with a speedstream dsl modem.

Suddenly connected devices can no longer access the internet when the DHCP server is enabled. Windows 10 for example will say it can't find DNS.
I hadn't changed anything to cause this, and the router status page looked the same as usual.

I tried resetting the router, upgrading from fw1.12 to fw1.14, no change.

It actually started exhibiting thus behavior a few weeks ago, except on those occasions, it would start working again before I could troubleshoot it this far.

Does it sound like the router is giving up the ghost?
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 46270
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: DHCP no longer allows internet to connected devices.
« Reply #1 on: December 04, 2016, 11:35:24 AM »

Link>Welcome!

  • What region are you located?
  • Has a Factory Reset been performed?
  • Was a Factory Reset performed before and after any firmware updates then set up from scratch?
  Link> >FW Update Process

Internet Service Provider and Modem Configurations
  • What ISP Service do you have? Cable or DSL?
  • What ISP Modem Mfr. and model # do you have?

Do you have this router connected to a different router?

Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

crowtoo

  • Level 1 Member
  • *
  • Posts: 3
Re: DHCP no longer allows internet to connected devices.
« Reply #2 on: December 04, 2016, 02:21:21 PM »

North america
yes, yes, yes

DSL, Speedstream 5360

This is the only router.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 46270
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: DHCP no longer allows internet to connected devices.
« Reply #3 on: December 04, 2016, 02:41:37 PM »

I would disconnect the 850 from the isp modem temporarily. Then disconnect ALL other devices including wireless devices. Turn all OFF accept for 1 wired LAN cable PC. Do a factory reset on the router and use IE11 or FF and set up the router from scratch. Don't change any DHCP or networking setting, use default settings. Check the PCs networking to see if it's getting a IP address from the router. Then graduate adding wired devices to the router. Checking at each point to see if it's getting an IP address. Once you connect all wired, try adding wireless devices just to see that each one gets an IP address.

What all devices do you have connected?
Using Dynamic DHCP IP addresses or any reservations?

If all goes well here, then reconnect the ISP modem to the router. You might set the WAN port speed from AUTO to 100Mb and test as well.

 

Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

crowtoo

  • Level 1 Member
  • *
  • Posts: 3
Re: DHCP no longer allows internet to connected devices.
« Reply #4 on: December 04, 2016, 03:11:21 PM »

I'll try a reset again; but I'll clarify the devices were getting IPs from the router's DHCP service, they just couldn't see the internet. Usually it's just one Windows PC, and one PS4. (two devices at a time via ethernet; haven't used wireless mode since I bought the router.) As I said, I didn't make any setting changes to cause this.



Speedof.me
Download Speed: 5.39 Mbps
Upload Speed: 460 kbps
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 46270
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: DHCP no longer allows internet to connected devices.
« Reply #5 on: December 04, 2016, 04:21:15 PM »

  • Check cable between Modem and Router, swap out to be sure. Link> Cat6 is recommended.
  • Check ISP MTU requirements, Cable is usually 1500, DSL is around 1492 down to 1472. Call the ISP and ask. Link>Checking MTU Values
  • For DSL/PPPoE connections on the router, ensure that "Always ON" option is enabled.


I recommend that you have your ISP check the cabling going to the ISP modem, check signal levels going to the ISP modem. For DSL or Fiber service lines, ensure that the ISP is using good working phone or cable lines to the DSL modem and that the phone lines are filtered correctly. For cable Internet, RG-6 coaxial cable is needed, not RG-59. Check for t.v. line splitters and remove them as they can introduce noise on the line and lower the signal going to the ISP modem. I recommend having the ISP service physically check the lines going from the out side to the ISP modem. Connecting to the ISP modem could result in a false positive as the signal to the modem could be just enough to that point then adding on a router, could see problems. The router operation is dependent upon getting good data flow from the ISP modem and the modem is dependent upon getting good signal from the ISP Service.


Router and Wired Configurations
Some things to try: - Log into the routers web page at 192.168.0.1. Use IE, Opera or FF to manage the router. Besure to log into the Admin account on the router.

  • Enable or Disable Use Unicasting (compatibility for some ISP DHCP Servers) and test under Setup/Internet/Manual. Disable may help with speed performance on higher speed ISP services.
  • Turn on or off DNS Relay under Setup/Networking. Link>Finding Faster DNS Addresses using Name Bench and input new DNS addresses under Setup/Internet/Manual.
  • Setup DHCP reserved IP addresses for all devices ON the router. Setup/Networking. This ensures each devices gets its own IP address when turned on and connected, eliminates IP address conflicts and helps in troubleshooting and maintain consistency for applications that need to connect as well as mapped drives.
  • Ensure devices are set to auto obtain an IP address.
  • If IPv6 is an option on the router, select Local Connection Only under Setup/IPv6.
  • Set Firewall settings to Endpoint Independent for TCP and UDP under Advanced/Firewall. Enable or Disable SPI to test.
  • Enable uPnP and Multi-cast Streaming under Advanced/Networking. Disable uPnP for testing Port Forwarding rules. Enable IPv6 Multi-cast Streaming for routers that have a Media Server option. Disable IPv6 Multi-cast Streaming if IPv6 or Media Server is not being used.
  • Turn off WISH, and WPS under Advanced.
  • WAN Port Speed set to Auto or specific speed? Some newer ISP modems support 1000Mb so manually setting to Gb speeds can be supported by the router. Advanced/Advanced Networking/WAN Port Speed
>WAN and LAN Connection Rates and ISP Speeds FAQ
  • Set current Time Zone, Date and Time. Use an NTP Server feature. The DST setting is only needed in the NA region. Tools/Time.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!