The Graveyard - Products No Longer Supported > DIR-820L

set date time

<< < (2/3) > >>

fwiw...  my local time is 11:18 AM, the device time is Wed Dec 31, 1969 21:47:44.   

The Device Info page shows the WAN IP address as  I've allocated as the fixed lan IP on the UVerse box, this is the address for the dlink admin web pages.   Even if I deselect NTP and use "use my computer datetime" the system date does not change or update.   But, I guess I'll try the upgrade and resets...   thank you -

I've updated to version 2.02.  (pain)  At least I remembered the backwards instructions this time - specify the network address & subnet before you click save after disabling dhcp.

I guess I've found that the "use from my computer" requires I adjust the values even though they are correct, select Copy, select Save.  The screen will flash and the device time will update.  But, according to the documentation, this is not a desired configuration as a power outage will lose the config, and the datetime will revert to 1969 again.   I am plugged into a UPS, and the power rarely goes out here long enough to lose the juice, but I would still prefer to use the NTP server config, but I don't have any luck with those changes affecting the device datetime.   I think I read that ATT blocks  port 123, and NTP is UDP not TCIP.  blah blah blah - so maybe my Uverse box is blocking NTP to dlink?

I'll note that according to the internet  DST starts in March and ends in November, but those are the opposite values needed for dlink.  I guess I'll see if the logging picks up the web sites now...  I like to dream.

FW update process is easy. Just follow this: Link> >FW Update Process

How is the 820 connected to the ISP modem? If the modem is bridged it should be connected to the WAN port on the 820L.

* If the ISP modem has a built in router, it's best to bridge the modem. Having 2 routers on the same line can cause connection problems: Link>Double NAT and How NAT Works. Call the ISP and ask to see if the ISP modem can be bridged. To tell if the modem is bridged or not, look at the routers web page, Status/Device Info/Wan Section, if there is a 192.168.0.# address in the WAN IP address field, then the modem is not bridged. If the modem can't be bridged then see if the modem has a DMZ option and input the IP address the router gets from the modem and put that into the modems DMZ. Also check the routers DHCP IP address maybe conflicting with the ISP modems IP address of Check to see if this is the same on the ISP modem, and if modem can't be bridged, change the DIR router to or .0.254.
Example of a D-Link router configured for PPPoE with ISP Modem bridged: PPPoE Configuration on a Router
IF your connecting the 820L to the ISP modem via it's LAN port only, then NTP will not work on the 820L in this configuration as it needs use of the WAN port.

You might use the DMZ on the ISP modem and put the IP address the 820L (WAN port) gets from the ISP modem and see if the 820L can get time services. I have the 826L and 836L routers and the time and NTP are all the same. They work unless something is blocking or the WAN port is not being used.

You are correct, I am not using the WAN port on the 820L - this is per the instructions pages 11-12.  I guess I will have to try the DMZ.   The "use computer time" is not persistent between device reboots, even through the admin page, the datetime reverts to 1969.

Ya if your not using the WAN then your running the AP mode with the 820L. That's ok too, just know that NTP and other features the depend on the WAN port being connected won't work in AP mode (LAN to LAN) configuration:
Turning a router into an AP.


[0] Message Index

[#] Next page

[*] Previous page

Go to full version