The Graveyard - Products No Longer Supported > DIR-820L

set date time

(1/3) > >>

DIR-820L HW B1   FW 2.01.  I recently purchased the router in hopes of web site logging and wifi access scheduling.  No luck with the logging.   I thought I had the access scheduling working, but now I see the system time is incorrect, and I can't seem to fix it.  It's not 1969 any longer, but the router is.  I see there is a firmware upgrade, but the release notes make no mention of a datetime fix.   I've tried "copy from my pc", but nothing happens.   I've enabled NTP server and selected each, and a tried a few IP addresses from CO, but no luck.

I'm bridged from/to a UVerse 3800-HGVb.  any help is appreciated.


* What region are you located?

Internet Service Provider and Modem Configurations

* If the ISP modem has a built in router, it's best to bridge the modem. Having 2 routers on the same line can cause connection problems: Link>Double NAT and How NAT Works. Call the ISP and ask to see if the ISP modem can be bridged. To tell if the modem is bridged or not, look at the routers web page, Status/Device Info/Wan Section, if there is a 192.168.0.# address in the WAN IP address field, then the modem is not bridged. If the modem can't be bridged then see if the modem has a DMZ option and input the IP address the router gets from the modem and put that into the modems DMZ. Also check the routers DHCP IP address maybe conflicting with the ISP modems IP address of Check to see if this is the same on the ISP modem, and if modem can't be bridged, change the DIR router to or .0.254.
Example of a D-Link router configured for PPPoE with ISP Modem bridged: PPPoE Configuration on a Router
PC Web Browser Configurations
What browser are you using?
Try Opera or FF? If IE 8, 9, 10 or 11, set compatibility mode and test again.

Please post a screen capture of the TIME menu on the routers web page:
Adding Screenshots In A Post

Hi Furry -

Eastern US timezone
Daylight savings is selected, March through November.
Enable NTP is checked, is the server elected.
Set manually is grayed out as NTP is selected above.

I *think* the bridging is fine - the router has internet access, so I would hope NTP would work.

oops...    FF 43.0.1 on Linux MX-15 or IE 11 on Win7, tried enterprise mode and added address to compatibility.   Screen looks fine and saves my settings, but it never changes the system time.

What is the IP address of the WAN side on the 820L ##.##.###.### or a 192.168.#.# maybe?

I would try a FW upgrade as well using IE11 on 7. Do a factory reset, manually load the FW file, factory reset again, clear all browser caches then set up from scratch. And try FF or IE to see if it will configure. Setting NTP should gain correct time, if it can get services thru the ISP modem...


[0] Message Index

[#] Next page

Go to full version