• July 18, 2019, 06:41:07 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Upnp changes not saved  (Read 1905 times)

Gamera7

  • Level 1 Member
  • *
  • Posts: 2
Upnp changes not saved
« on: March 29, 2016, 07:09:32 AM »

Hi

I have 2 issues that I'm struggling with and wonder if anyone has any ideas.

I have 2 DCS-942L cameras, I set up port forwarding on my router and that is working as intended, I can access my cameras remotely.  I tried to turn off UPNP on both camera as I was still getting a lot of people trying to access my camera from outside my network, one camera worked, the other did not.

Router log of someone trying to access my camera
ex.
[LAN ACCESS FROM REMOTE] from 104.148.44.116:1844 to 192.168.1.213:43571

I know turning off UPNP will not fix this....but UPNP seems to be opening other ports I don't want

In my router UPNP page, I see stuff like
Int. Port: 43571 Ext. Port 80
Int. Port: 43571 Ext. Port 8080
Int. Port: 443 Ext. Port 443 

When I try and turn off UPNP in the Network settings page of my camera, the page just says "Changes failed" and will not allow me to turn it off.  The other camera works fine, Ive turned off UPNP on it successfully.  No idea why i cannot turn off UPNP on the 2nd camera, they are both setup the same, both running the same firmware.

So my 2 issues are:
1) How do I turn off UPNP

and

2) How do I stop people from trying to access my camera

Thanks
Gamera
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47568
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Upnp changes not saved
« Reply #1 on: March 29, 2016, 07:36:40 AM »

Link>Welcome!

  • Link>What Firmware version is currently loaded? Found on the DCSs web page under status.
  • What region are you located?

What Mfr and model is the main host router?

Cameras need uPnP enabled to work well especially if there are multiples and you have services that depend on accessing them. DCS Cloud (L) Series Camera Configuration and Mydlink.com

You could try factory resetting the camera then set up the camera from scratch then access the UI and disable uPnP. You might do this one at a time while each camera is turned off. If you don't use uPnP at all, then disable it on the main host router as well, however this might have adverse effects.

You might have your ISP change your WAN side IP address and services if you think that external users are trying to access the camera. Be sure that you have set up PWs on each camera. Be sure firewalls are enabled on the main host router.

Are the cameras associated with the mydlink.com service?

PC Web Browser Configurations
What browser are you using?
Try Opera or FF? If IE 8, 9, 10 or 11, set compatibility mode and test again.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting

Gamera7

  • Level 1 Member
  • *
  • Posts: 2
Re: Upnp changes not saved
« Reply #2 on: March 29, 2016, 08:28:20 AM »

Hey

Thanks for the reply

Both cameras are:
Firmware Version1.26
Firmware Build Number5601

The router is a Netgear Nighthawk  AC1900

I cannot disable UPNP on the router (well id prefer not to really), I have some other services that rely on it.  I could forward all the ports i need i guess and turn it off.

I have both cameras running on different ports, and port forwarding set up so that i can access both cameras from an external computer. I do have passwords on both cameras, so I do not believe people are actually loging in to my cameras, i think they're just at the login page....and attempting to log in...i hope.

I have both cameras on the MyDlink service, and for some reason, my wife can view them on her iphone, but I cannot with my android phone.  Whenever I try, I get a Could not connect to the device error, but it works fine from the Iphone...not sure whats up with that.  I usually do not use the MyDlink app though, I connect directly to the camera from my work computer,  which is working fine for both cameras at the moment.

I have tried changing the UPNP settings with 3 different browsers, IE11, Firefox and Google Chrome.  All give me the same error, Changes Failed when trying to disable UPNP.  I will try and factory reset the one camera and see if that lets me disable it.

I get several different IP addresses trying to connect to the camera, yesterday alone i had 26 distinct IP addresses trying to connect to the cameras.  I have no idea why, do people just scan ports looking for anything open?  I will call my provider and see if they can change my IP address, hopefully this will deter people for a while at least.

Thanks again
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47568
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Upnp changes not saved
« Reply #3 on: March 29, 2016, 09:09:43 AM »

I recommend leaving uPnP enabled on the main host router and cameras and also enable uPnP Port Forwarding on the cameras. This will help with multiple cameras and connections.

Not sure about Android. If the iPhone works, there maybe a problem with the Android and it's configuration.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting