• August 25, 2019, 08:08:58 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: 890L 2.4ghz wifi connection slow on all devices  (Read 2232 times)

sgtgregg

  • Level 1 Member
  • *
  • Posts: 1
890L 2.4ghz wifi connection slow on all devices
« on: February 27, 2016, 11:14:27 AM »

Good day everyone.

Ok, so here's the deal... the 890L was stupid slow for me (stupid part was mostly me). After reviewing a few posts, I found how to correct the 5.0 connections, and they are no longer slow nor an issue. My DL speeds are around 150+ mbps on all devices for 5.0 connections. But my 2.4 connection is horribly slow, with speeds around 25mbps or less on all devices. If I run an ethernet cable directly, speeds are just fine, and again are around 150 mbps.

The location is upstairs, but it don't matter where I'm at with the device, the speeds always stay the same. When I'm on 5.0, again it don't matter where I'm at with the device the speeds are always 150+. But unfortunately not all my devices are capable of running 5.0.

Any ideas?

Thanks
Logged
If everything is a priority, nothing is a priority.

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47713
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: 890L 2.4ghz wifi connection slow on all devices
« Reply #1 on: February 27, 2016, 11:33:41 AM »

Link>Welcome!

  • What Hardware version is your router? Look at sticker under the router case.
  • Link>What Firmware version is currently loaded? Found on the routers web page under status.
  • What region are you located?

Internet Service Provider and Modem Configurations
  • What ISP Service do you have? Cable or DSL?
  • What ISP Modem Mfr. and model # do you have?

Wireless Configurations
Links>Wireless Installation Considerations and Managing Signal Congestion and Good Neighbour Policy
  • What wireless modes are you using?
  • 2.4Ghz and 5Ghz routers: Try single mode G or N or mixed G and N on 2.4Ghz and single mode N or AC on 5Ghz?
  • Channel Width set for Auto 20/40Mhz or try 20Mhz only.
  • Try setting a manual Channel to a open or unused channel. 1, 6 or 11. 11 for single mode N if the channel is clear. 13 for EU regions.
  • What wireless devices do you have connected?
  • Ensure any devices with WiFi adapter drivers are updated.
  • Any 2.4Ghz or 5Ghz cordless house phones or WiFi APs near by that maybe causing interferences?
  • Any other WiFi routers in the area that maybe causing interferences? Link> Use a WiFi Scanner to find out. How many?
  • If you have any of these options, Try turning OFF or ON Short GI, WLAN Partition, Extra Wireless Protection and HT 20/40 Co-existence if you have it. Also testing with HT20/40Mhz Co-existence enabled will impact results as well. I prefer to use this option OFF. Recommended settings are default. Under Advanced/Advanced Wireless.
  • For routers with Smart Connect Technology , try disabling this feature and test. Under Wireless.

Also wired LAN cable speed testing is preferred as wireless has many factors and variables that contribute to inaccurate results.
Logged
Cable:200mb/10Mb>NetGear C7800>DIR-882>DGS-1100>HP 24pt Gb Switch. COVR-3902/2202/1203,DIR-2680,890L,882,880L,868L,DNR-202L,DNS-345x2,DCS-933L,936L and 960L.
Go Here>Router Troubleshooting