• November 15, 2018, 05:14:48 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: Shareport didn't work with windows 8.1 x64 SOLVED  (Read 4415 times)

HalBert42

  • Level 1 Member
  • *
  • Posts: 2
Shareport didn't work with windows 8.1 x64 SOLVED
« on: October 08, 2015, 12:12:37 PM »

I bought my Dell Inspiron 3847 in Feb. 2015. It had Win 7 Pro 64 bit installed, with free upgrade to Win 8.1 Pro 64 bit. In June of 2015 I did the upgrade to Win 8.1 Pro 64 bit. And then in the first week of September, I upgraded to Win 10 Pro 64 bit.
In each of these versions, I tried to install and run Shareport Plus 4.30 64 bit to use my Cannon iP2700 printer via my DAP-1525 Access Port. I got the message "Failed to install SXUPTP" during install.
I also tried earlier versions of Shareport, and even Silex SX Virtual Link. When the ran, they would show the Cannon printer as available. But, the connect would never work.
I made several trips to various threads of Google searches, including this forum. Trying many things.
T have an HP desktop setting right next to the Dell. Shareport and SX Virtual Link runs perfectly abd either connects the the Cannon everytime.
Yesterday, I made a file comparison between the install folders of both computers. I noted the file "sxuptp.inf" was newer on the HP than on the Dell.
I deleted all the copies of "sxuptp.inf" in each of the folder *x64" designated and replaced each with a copy of the file from the HP. The files replaced were in the folders at SHAREPORTPLUS_UTILITY_4.30_WIN (1)\SharePort_V430_131226\Files\Bin\Sxcsapi\.
I am very happy to report that both Shareport and SX now function perfectly as well as connect each time on the Dell machine.
I hope this information may help some of you?
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 46150
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Shareport didn't work with windows 8.1 x64 SOLVED
« Reply #1 on: October 08, 2015, 12:50:40 PM »

Did you fully remove SP by uninstalling it then re-installing the software package during your intitial troubleshooting?
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

HalBert42

  • Level 1 Member
  • *
  • Posts: 2
Re: Shareport didn't work with windows 8.1 x64 SOLVED
« Reply #2 on: October 09, 2015, 01:00:25 PM »

Yes, several time, Both SX and Shareport. That included new downloads.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 46150
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Shareport didn't work with windows 8.1 x64 SOLVED
« Reply #3 on: October 15, 2015, 07:09:09 AM »

Sounds like you got it working then. Enjoy.  ;)
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

SirMaxwell

  • Level 1 Member
  • *
  • Posts: 1
Re: Shareport didn't work with windows 8.1 x64 SOLVED
« Reply #4 on: August 16, 2018, 12:26:23 PM »

I have a DIR-825 (three of them actually) and I had the ShareLink working fine with my Canon printer connected to the router's USB port.   I was running Win8.1.  Then, not sure what I did, but I lost the ability of SharePort to connect to my printer.  It saw it there, but couldn't connect with it and I got an error message.  Note, the SharePort software running on a Vista machine, worked fine and that computer was able to connect to the printer and print.

I came back here to see if anyone had any suggestions, and saw a lot of similar issues with the connection errors or the new version's installation error of not being able to find some file.

I did some Google searching and found the free SX-Virtual Link, which I had also tried to install on my computer with no luck.

But, this time, I tried downloading an older version of the SX_Virtual Link software (Ver. 3.16) and it installed without issue and connected to the printer with no issues and I am now able to printer again, via the USB port on the back of my DIR_815.

So I just wanted to post this so that if anyone else was still looking for a solution, this might be something to try.   Or, try downloading older versions of SharePort and install it and see if that works.

Hope this helps:

Hi.
I found a fix.
I downloaded the latest SX Virtual Link and installed it and it too didn't work.
So, I downloaded the SX Virtual Link 3.16 and installed that, and now my printer connects and works fine.   
I know the ShareLink worked on my 8.1 machine, but perhaps, I updated the ShareLink software and that was the problem with Win 8 or 8.1.
Anyway, this SX Virtual Link 3.16 definitely worked!
I'll try to share this with the community, but if you don't see it there, feel free to share.
http://www.silexeurope.com/en/home/support/productgroups/common-downloads/device-server-and-virtual-link.html
Thanks,
Max
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 46150
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: Shareport didn't work with windows 8.1 x64 SOLVED
« Reply #5 on: August 16, 2018, 01:27:34 PM »

Thanks for letting us know.
Enjoy.  ;)
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!