• June 05, 2020, 06:12:54 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: 1 [2]

Author Topic: New FW 1.04b08: SSH feature does not work?  (Read 9682 times)

ivan

  • Level 8 Member
  • ***
  • Posts: 1474
Re: New FW 1.04b08: SSH feature does not work?
« Reply #15 on: February 24, 2016, 03:31:36 PM »

Disclaimer: we don't have a DNS-327L box to do tests on therefore my comments are based on over 20 years experience of IT.

First, what are you using as an SSH server/client?  Is it an addon or built into the firmware?  If it is an addon where did you get it?

Once we have the answers to those questions we might be able to solve the problem.  We use OpenSSH here at work and generate our own security cert/keys.

If you are using PuTTY where did you get it from?  It might be a very good idea to ask the people that ported it about how to reset a password, after all they should know.
Logged

CALDERONE1

  • Level 1 Member
  • *
  • Posts: 4
Re: New FW 1.04b08: SSH feature does not work?
« Reply #16 on: February 25, 2016, 11:35:09 AM »

It almost sounds like that the PW maybe needs to be changed for root or admin? Can you get telnet into a non SSH command maybe? I'll ask around and see if I can get some eyes on this.  :o

The NAS refuses any attempt to telnet into a non SSH command.
The SSH accept the username 'admin', but as soon as the correct password is input the connection is closed with the above mentioned password issue.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 48822
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: New FW 1.04b08: SSH feature does not work?
« Reply #17 on: February 25, 2016, 02:04:04 PM »

Can you try using 'root' as the log in? ???
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

ivan

  • Level 8 Member
  • ***
  • Posts: 1474
Re: New FW 1.04b08: SSH feature does not work?
« Reply #18 on: February 26, 2016, 06:04:45 AM »

According to the firmware release notes version 1.04 has a SSH configuration feature.  Has anyone with this password problem actually setup SSH for their unit?  Such a setup would include setting users and passwords.
Logged

CALDERONE1

  • Level 1 Member
  • *
  • Posts: 4
Re: New FW 1.04b08: SSH feature does not work?
« Reply #19 on: February 26, 2016, 09:18:08 AM »

According to the firmware release notes version 1.04 has a SSH configuration feature.  Has anyone with this password problem actually setup SSH for their unit?  Such a setup would include setting users and passwords.

Has anyone to suggest eventual specific configuration for the SSH client to login into the DNS-327. I have tried with the default settings using PuTTY and Bitvise SSH clients without any success. The section for the 'admin' user closes as soon as the correct password is input, and it is not possible to do anything with the 'root' user I tried with different passwords including no password and the same password of 'admin' without any success. Apparently it should be supported (there is a specific enable in the web configuration page of the NAS), but actually it is not working. I opened a assistance ticket with D-Link, but they bring me around with un-usefull  at all suggestions like "please reinstall the NAS from scratch" or "this is the link with the PuTTY manual" ... ?!? :( 
Logged

CALDERONE1

  • Level 1 Member
  • *
  • Posts: 4
Re: New FW 1.04b08: SSH feature does not work?
« Reply #20 on: February 26, 2016, 09:20:14 AM »

Can you try using 'root' as the log in? ???

Yes I also tried that, but it does not accept any password ...
Logged

ivan

  • Level 8 Member
  • ***
  • Posts: 1474
Re: New FW 1.04b08: SSH feature does not work?
« Reply #21 on: February 26, 2016, 10:07:29 AM »

Could you please provide screen grabs of the SSH setup page or pages taken from the web UI.  There may be some indication there as to what is/isn't happening.
Logged

Manul

  • Level 2 Member
  • **
  • Posts: 48
Re: New FW 1.04b08: SSH feature does not work?
« Reply #22 on: February 26, 2016, 03:33:39 PM »

Since an expired password is mentioned: Have you tried setting a new password for the admin user after enabling ssh? It's a long shot but it might be worth a try...
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 48822
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: New FW 1.04b08: SSH feature does not work?
« Reply #23 on: March 14, 2016, 07:51:52 AM »

Any status on this?  ???
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

pianio

  • Level 1 Member
  • *
  • Posts: 1
Re: New FW 1.04b08: SSH feature does not work?
« Reply #24 on: March 30, 2020, 07:42:08 AM »

Tested now with 327L and 1.10B02 fw.

root login works without password.
admin asks password and change password during login doesn't work.
any other user works.

« Last Edit: March 30, 2020, 07:45:43 AM by pianio »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 48822
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: New FW 1.04b08: SSH feature does not work?
« Reply #25 on: March 30, 2020, 08:27:00 AM »

Thanks for letting us know.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!
Pages: 1 [2]