• October 19, 2020, 11:34:31 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: [SOLVED] Problems setting up WiFi AP  (Read 2339 times)

Stayen

  • Level 1 Member
  • *
  • Posts: 2
[SOLVED] Problems setting up WiFi AP
« on: July 16, 2015, 12:44:53 AM »

Hello,

Device: DSR-250N, hardware version: A1, firmware left original so far (1.01B46)

The router works within intranet (WAN disabled; DHCP set to Relay; IP LAN address defined as static). In WiFi radio settings "n and g" mode selected. Other settings by default. Date/time set to correct ones, NTP sync enabled.

I experience problems making its WiFi work. Details:

1. When setting WiFi throiugh Wizard, I end up with WPA/WPA2 (as declared), although there's no WPA/WPA2 security options in Profiles, only OPEN/WEP.

When client attempts to connect, it ends up asking for password again and again.

2. When setting through manual configuration (using WEP),
- WiFi SSID isn't actually broadcast - WiFi-enabled devices do not see the AP in the list
- after trying to connect by setting parameters manually, device ends up asking key/password again and again

What are my options beyond installing the last firmware and re-attempting all the above?

Thanks.

Update: The line like below are being written to Log facility when Iupdate Profile settings:

Thu Jul 16 13:47:35 2015(GMT+0600) [DSR-250N][Local0-wireless][UDOT11] sqlite3QueryResGet failed
« Last Edit: July 17, 2015, 12:57:53 AM by Stayen »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49273
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: Problems setting up WiFi AP
« Reply #1 on: July 16, 2015, 08:53:29 AM »

You might want to factory reset, upload the most current FW version, factory reset after the load and setup from scratch using IE or FF.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

Stayen

  • Level 1 Member
  • *
  • Posts: 2
Re: [SOLVED] Problems setting up WiFi AP
« Reply #2 on: July 17, 2015, 01:00:04 AM »

Upgrading firmware (to 1.09B32) appears to be the only solution.

The original firmware has WiFi settings, especially Wizard part, all garbled.

Steps:
- reset to factory defaults
- load the latest firmware
- reset to factory defaults
- disable IPv6
- set up WAN/LAN/Wifi as required

In my case, in network not supporting IPv6, I couldn't proceed with any network configuration until I disabled IPv6
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49273
  • D-Link Global Forum Moderator
    • Router Troubleshooting
Re: [SOLVED] Problems setting up WiFi AP
« Reply #3 on: July 17, 2015, 07:41:26 AM »

Glad you got it working. Enjoy.  ;)
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!