• September 23, 2019, 01:52:55 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: [1] 2

Author Topic: Add-on "PlexMedia Server v.0.9.12.3" for D-Link NAS  (Read 21936 times)

vtverdohleb

  • Level 5 Member
  • *****
  • Posts: 712
    • Add-Ons for D-Link NAS
Add-on "PlexMedia Server v.0.9.12.3" for D-Link NAS
« on: June 16, 2015, 03:20:10 AM »

[Add-on] PlexMediaServer v0.9.12.3

[Description]
Plex bridges the gap between your D-Link NAS and your home theater, doing so with a visually appealing user interface that provides instant access to your media. Plex can play a wide range of video, audio and photo formats as well as online streaming audio and video.

[New & Fixes]
https://plex.tv/downloads/1/archive

[Version]
Add-on Package v1.07

[Maintainer]
vtverdohleb

[Download link]
DNS-320L Plex Package v1.07_06162015_UA
DNS-325 Plex Package v1.07_06162015_UA
DNS-327L Plex Package v1.07_06162015
DNS-340L Plex Package v1.07_06162015
DNS-345 Plex Package v1.07_06162015_UA

[Resource]
Website https://plex.tv/
Plex Forum https://forums.plex.tv/
Other Add-ons http://dlink.vtverdohleb.org.ua/Add-On/

[Remarks]
Download and install the Plex Add-On.
Click the link for the Plex web interface and configure it.
« Last Edit: September 21, 2015, 09:10:27 AM by vtverdohleb »
Logged
Add-on Application questions and issues, please include the following minimal information in your post:
* ShareCenter Model
* Add-on Name
* Add-on Version
* Detailed Description of your Issue
Donate: http://dlink.vtverdohleb.org.ua/Add-On/donate.php

Miaou63

  • Level 1 Member
  • *
  • Posts: 9
Re: Add-on "PlexMedia Server v.0.9.12.3" for D-Link NAS
« Reply #1 on: June 16, 2015, 10:40:57 AM »

Thank you very much for building that one !
Is there a way to update from 9.12.1 to 9.12.3 without uninstalling the application ? Or do we have to perform a clean install ?
Logged
DNS-320L - 1.04.B12

vtverdohleb

  • Level 5 Member
  • *****
  • Posts: 712
    • Add-Ons for D-Link NAS
Re: Add-on "PlexMedia Server v.0.9.12.3" for D-Link NAS
« Reply #2 on: June 17, 2015, 12:37:33 AM »

Thank you very much for building that one !
Is there a way to update from 9.12.1 to 9.12.3 without uninstalling the application ? Or do we have to perform a clean install ?

You want to save the contents of the directory /mnt/HD/HD_a2/Nas_Prog/Plex/Library
Logged
Add-on Application questions and issues, please include the following minimal information in your post:
* ShareCenter Model
* Add-on Name
* Add-on Version
* Detailed Description of your Issue
Donate: http://dlink.vtverdohleb.org.ua/Add-On/donate.php

enigmatic28

  • Level 1 Member
  • *
  • Posts: 19
Re: Add-on "PlexMedia Server v.0.9.12.3" for D-Link NAS
« Reply #3 on: June 17, 2015, 06:10:52 AM »

    Hi vtverdohleb,

    First of all, thanks for sharing your work..
    I'm new on this plugin for Plex. Just wanted to ask a few questions, oh and i'm using the DNS-320L plugin that you have created and my connection is hardwired and not via wifi:

    • Why is it when i add a library, the language selection is always blank, sometimes at takes lots of retry before the list is shown.
    • When i go to the settings and and click Server there are times that it shows the server settings and there are times that it says "Server settings are unavailable."
    • When i did able to set-up a folder containing videos and when i tried accessing it on my TV player, the video (which can be played by the TV when accessed using the normal sharing of the device) will not play and will say that the server is not accessible, though there are times that the video is played by the TV without any problem.
    • While on the configuration page, there are times that the server will suddenly disconnect saying  "We're sorry, but we can't reach this server." even though i can still navigate within the Plex Server interface.

    Hoping you will be able to help me on this
Logged

vtverdohleb

  • Level 5 Member
  • *****
  • Posts: 712
    • Add-Ons for D-Link NAS
Re: Add-on "PlexMedia Server v.0.9.12.3" for D-Link NAS
« Reply #4 on: June 17, 2015, 07:38:05 AM »

  • Why is it when i add a library, the language selection is always blank, sometimes at takes lots of retry before the list is shown.

Language selection must not be empty. Often this problem is caused high CPU load. The CPU in the NAS is pretty weak and when Plex scans'd better not touch it ;)
The only solution is to wait for the list appears in the selected language. It may take from several seconds to several minutes. Depends on the load of the CPU.

Quote
  • When i go to the settings and and click Server there are times that it shows the server settings and there are times that it says "Server settings are unavailable."

This is likely also related to CPU load. Strongly recommend not to do anything on the NAS until the scan files.

Quote
  • When i did able to set-up a folder containing videos and when i tried accessing it on my TV player, the video (which can be played by the TV when accessed using the normal sharing of the device) will not play and will say that the server is not accessible, though there are times that the video is played by the TV without any problem.

The CPU load.

Quote
  • While on the configuration page, there are times that the server will suddenly disconnect saying  "We're sorry, but we can't reach this server." even though i can still navigate within the Plex Server interface.

Resources DNS-320L is not designed for such a resource intensive program like Plex. You need to deal with these recurrent problems or to use another DLNA server. For Example Twonky.
Logged
Add-on Application questions and issues, please include the following minimal information in your post:
* ShareCenter Model
* Add-on Name
* Add-on Version
* Detailed Description of your Issue
Donate: http://dlink.vtverdohleb.org.ua/Add-On/donate.php

PacketBlaster

  • Level 1 Member
  • *
  • Posts: 12
Re: Add-on "PlexMedia Server v.0.9.12.3" for D-Link NAS
« Reply #5 on: June 17, 2015, 04:57:42 PM »

You want to save the contents of the directory /mnt/HD/HD_a2/Nas_Prog/Plex/Library

omg. I've been re-adding my whole library after every upgrade. Great to know!

Seems to be running a lot smoother now too at 9.12.3. Thanks again!
Logged

enigmatic28

  • Level 1 Member
  • *
  • Posts: 19
Re: Add-on "PlexMedia Server v.0.9.12.3" for D-Link NAS
« Reply #6 on: June 17, 2015, 07:58:12 PM »

Hi vtverdohleb,

Thanks for the response.
I would probably guess it is not recommended to use Plex while the My Surveillance application is running since that is the only application that is constantly running on my 320L.

Yup, i would re-install Twonky and use it since it is working fine on what i need.

Thanks again for your work.
« Last Edit: June 17, 2015, 07:59:53 PM by enigmatic28 »
Logged

Miaou63

  • Level 1 Member
  • *
  • Posts: 9
Re: Add-on "PlexMedia Server v.0.9.12.3" for D-Link NAS
« Reply #7 on: June 18, 2015, 01:02:02 AM »

Hi guys,

I did whats next to update :
- saved my library
- stopped plex
- updated
- copied my library (took several hours with winscp is it normal ?)
- started plex .. It never started again. I tried to reboot my 320l

Any idea? Did i do something wrong ?
Logged
DNS-320L - 1.04.B12

remains

  • Level 1 Member
  • *
  • Posts: 3
Re: Add-on "PlexMedia Server v.0.9.12.3" for D-Link NAS
« Reply #8 on: June 18, 2015, 08:16:06 AM »

Thanks a lot for the Plex update, much appreciated!

I want to upgrade but of course need to backup my Library folder first, however I have a problem because my Mapped Network Drive does not show the Nas_Prog folder. I have also tried WinSCP but the Nas_Prog folder does not show in there either!

Is there some setting to unhide this folder? All of the other folders on HD_a2 are visible!
Logged

PacketBlaster

  • Level 1 Member
  • *
  • Posts: 12
Re: Add-on "PlexMedia Server v.0.9.12.3" for D-Link NAS
« Reply #9 on: June 18, 2015, 02:37:19 PM »

Thanks a lot for the Plex update, much appreciated!

I want to upgrade but of course need to backup my Library folder first, however I have a problem because my Mapped Network Drive does not show the Nas_Prog folder. I have also tried WinSCP but the Nas_Prog folder does not show in there either!

Is there some setting to unhide this folder? All of the other folders on HD_a2 are visible!

The folder is hidden, but you should still be able to access it by typing in the name. (\\NAS IP\Volume_1\Nas_Prog\Plex). I don't have access to the NAS_Prog folder from Windows, but I can still get to \Nas_Prog\Plex. Hope that helps. I also had issues when trying to copy it back to the Library folder after upgrading, assuming because I didnt have access. I used sshd (another plugin) to SSH into the NAS and edit the permissions using chmod.

Hi guys,

I did whats next to update :
- saved my library
- stopped plex
- updated
- copied my library (took several hours with winscp is it normal ?)
- started plex .. It never started again. I tried to reboot my 320l

Any idea? Did i do something wrong ?


Did it say it installed successfully? What happens when you try to start it? I believe I've had this issue when trying to upgrade before, but all I did was try again.
Logged

remains

  • Level 1 Member
  • *
  • Posts: 3
Re: Add-on "PlexMedia Server v.0.9.12.3" for D-Link NAS
« Reply #10 on: June 18, 2015, 03:15:51 PM »

The folder is hidden, but you should still be able to access it by typing in the name. (\\NAS IP\Volume_1\Nas_Prog\Plex). I don't have access to the NAS_Prog folder from Windows, but I can still get to \Nas_Prog\Plex. Hope that helps. I also had issues when trying to copy it back to the Library folder after upgrading, assuming because I didnt have access. I used sshd (another plugin) to SSH into the NAS and edit the permissions using chmod.

Perfect, thank you so much! I've struggled with this for a couple of months now (I'm new to NAS!) and didn't even think of trying this which is actually pretty simple! Thanks again, off to start the Library copy now! :)

Logged

Miaou63

  • Level 1 Member
  • *
  • Posts: 9
Re: Add-on "PlexMedia Server v.0.9.12.3" for D-Link NAS
« Reply #11 on: June 18, 2015, 10:09:08 PM »

Hi guys,

I did whats next to update :
- saved my library
- stopped plex
- updated
- copied my library (took several hours with winscp is it normal ?)
- started plex .. It never started again. I tried to reboot my 320l

Any idea? Did i do something wrong ?


Did it say it installed successfully? What happens when you try to start it? I believe I've had this issue when trying to upgrade before, but all I did was try again.

Hi PacketBlaster,

Yeah I guess it was installed successfully. When I tried to start Plex nothing happened at all and the PMS service was not running in the resource monitor.
That's not a big deal I reinstalled the app and now its working.
My problem now is that it takes several hours to copy the library, almost as long a rebuilding it from the beginning...

Logged
DNS-320L - 1.04.B12

PacketBlaster

  • Level 1 Member
  • *
  • Posts: 12
Re: Add-on "PlexMedia Server v.0.9.12.3" for D-Link NAS
« Reply #12 on: June 19, 2015, 11:09:02 AM »

Hi PacketBlaster,

Yeah I guess it was installed successfully. When I tried to start Plex nothing happened at all and the PMS service was not running in the resource monitor.
That's not a big deal I reinstalled the app and now its working.
My problem now is that it takes several hours to copy the library, almost as long a rebuilding it from the beginning...

Yeah that's probably just because of how Windows talks to the NAS. It takes longer to discover and size all of the files then it does to actually copy over. It might take just as long as rescanning your Library, but copying it over saves your watched/unwatched and on deck files, which is why I do it. Glad to hear it is at least working for you now though.
Logged

josu

  • Level 2 Member
  • **
  • Posts: 42
Add-on "PlexMedia Server v.0.9.12.3" for D-Link NAS
« Reply #13 on: June 21, 2015, 07:14:32 AM »

first of all, my thanks for all your support. I have notice that in my plex 0.92.1 rlease home page , it suggest to download and upgrade a version of 0.9.12.3
 what do you think about it? I dont want to crash my dns, so I ask to the masters...8)

Install the suggestion from plex web server on my dns 320lw?
suggested link is https://plex.tv/downloads/latest/1?channel=16&build=linux-qnap-arm&distro=qnap&X-Plex-Token=rp5K5Bcn9Fu8PRz1s9yc

upgrade only from vertv version launched? from http://dlink2.vtverdohleb.org.ua/Add-On/DNS-320L%20Plex%20Package%20v1.07_06162015_UA

« Last Edit: June 21, 2015, 07:35:01 AM by josu »
Logged

Miaou63

  • Level 1 Member
  • *
  • Posts: 9
Re: Add-on "PlexMedia Server v.0.9.12.3" for D-Link NAS
« Reply #14 on: June 21, 2015, 08:28:29 AM »

Hi Josu,

I'm not one of the masters but i'm pretty sure you have to use vtverdohleb's version which has been built specifically for the DNS320L. Your first link is destined to qnap Nas.

Since I've updated to 9.12.3 I haven't experienced any trouble.
Logged
DNS-320L - 1.04.B12
Pages: [1] 2