• October 21, 2020, 04:00:00 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: 1 2 [3] 4

Author Topic: Add-on "ownCloud v8.0.0.7" for D-Link NAS  (Read 37267 times)

suis49

  • Level 1 Member
  • *
  • Posts: 5
Re: Add-on "ownCloud v8.0.0.7" for D-Link NAS
« Reply #30 on: September 15, 2015, 01:21:09 PM »

Hi,

I Have the same problem as EricG (August 18).
But where can I find config/config.php ?
Owncloud Installation Path is :    /Volume_1/Nas_Prog/owncloud, but when I display /Volume_1/ (with windows explorer or with the Sharecenter web interface, admin mode)  I don't see Nas_Prog.

Thanks for helping ?
« Last Edit: September 15, 2015, 01:28:41 PM by suis49 »
Logged
DNS 320L, Firmware 1.04

philphil61

  • Level 3 Member
  • ***
  • Posts: 256
Re: Add-on "ownCloud v8.0.0.7" for D-Link NAS
« Reply #31 on: September 15, 2015, 01:36:07 PM »

Hi,

I Have the same problem as EricG (August 18).
But where can I find config/config.php ?
Owncloud Installation Path is :    /Volume_1/Nas_Prog/owncloud, but when I display /Volume_1/ (with windows explorer or with the Sharecenter web interface, admin mode)  I don't see Nas_Prog.

Thanks for helping ?

You need to install QuiXplorer of AjaxXplorer to access those folders

vtverdohleb's site where links to many D Link addons appears to be down for me so I cannot post live links.  That in mind if you want QuiXplorer urgently - pm me as I can quickly upload my copy and send a link.

Just found my old discussion about QuiXplorer with vtverdohleb and he's kindly posted links in that discussion

He's a top bloke


http://forums.dlink.com/index.php?topic=62991.msg256547#msg256547  <<  look here
« Last Edit: September 15, 2015, 01:40:25 PM by philphil61 »
Logged

BigD87

  • Level 1 Member
  • *
  • Posts: 21
Re: Add-on "ownCloud v8.0.0.7" for D-Link NAS
« Reply #32 on: September 16, 2015, 06:26:38 AM »

philphil 61 you inadvertently helped with one of my issues. Finding the HD_a2/Nas_Prog/owncloud folder. I have installed QuiXplorer and up it pops.

Thank you!

EDIT: Managed to figure QuiXplorer out. Was being blocked by safari. So my domain is now trusted. But next issue.

" ERROR MySQL/MariaDB username and/or password not valid You need to enter either an existing account or the administrator."

I have no idea what that is ?!? Where would I find it or do i need to set it up elsewhere or should I just stick with SQLite?

I trie admin, admin and root, blank.

I am assuming that the first username and password is the admin admin combo. but I don't seem to be able to configure the database.

I am so close now. Any help greatly appreciated.

Regards



« Last Edit: September 16, 2015, 06:48:00 AM by BigD87 »
Logged
DNS-327L FW1.05

suis49

  • Level 1 Member
  • *
  • Posts: 5
Re: Add-on "ownCloud v8.0.0.7" for D-Link NAS
« Reply #33 on: September 16, 2015, 06:35:12 AM »

After some researches, I found the owncloud package 8.04, also posted by vtverdohleb, and now I can run Owncloud.

To philphil61: Thanks for QuiXplorer, it works fine.

next problem : in the admin parameters of owncloud, the version is 8.04. Clicking update gives the message "up to date" ??? How to upgrade to 8.1 ?
The funny is that clicking on help displays "help owncloud 8.1"
Does it exists a package for 8.1 ? didn't find it.

Some ideas ?
Logged
DNS 320L, Firmware 1.04

suis49

  • Level 1 Member
  • *
  • Posts: 5
Re: Add-on "ownCloud v8.0.0.7" for D-Link NAS
« Reply #34 on: September 16, 2015, 06:42:52 AM »

To BigD87 : try the package 2.04 for owncloud 8.04. Hope it will work also for You.
Logged
DNS 320L, Firmware 1.04

BigD87

  • Level 1 Member
  • *
  • Posts: 21
Re: Add-on "ownCloud v8.0.0.7" for D-Link NAS
« Reply #35 on: September 16, 2015, 07:32:21 AM »

Ah has own cloud port changed from 81 to 441 in v2.04?
Logged
DNS-327L FW1.05

suis49

  • Level 1 Member
  • *
  • Posts: 5
Re: Add-on "ownCloud v8.0.0.7" for D-Link NAS
« Reply #36 on: September 16, 2015, 08:22:28 AM »

Yes
Logged
DNS 320L, Firmware 1.04

vtverdohleb

  • Level 5 Member
  • *****
  • Posts: 712
    • Add-Ons for D-Link NAS
Re: Add-on "ownCloud v8.0.0.7" for D-Link NAS
« Reply #37 on: September 16, 2015, 08:33:54 AM »

Ah has own cloud port changed from 81 to 441 in v2.04?

HTTP = 81
HTTPS = 441
Logged
Add-on Application questions and issues, please include the following minimal information in your post:
* ShareCenter Model
* Add-on Name
* Add-on Version
* Detailed Description of your Issue
Donate: http://dlink.vtverdohleb.org.ua/Add-On/donate.php

philphil61

  • Level 3 Member
  • ***
  • Posts: 256
Re: Add-on "ownCloud v8.0.0.7" for D-Link NAS
« Reply #38 on: September 16, 2015, 10:19:34 AM »

After some researches, I found the owncloud package 8.04, also posted by vtverdohleb, and now I can run Owncloud.

To philphil61: Thanks for QuiXplorer, it works fine.

next problem : in the admin parameters of owncloud, the version is 8.04. Clicking update gives the message "up to date" ??? How to upgrade to 8.1 ?
The funny is that clicking on help displays "help owncloud 8.1"
Does it exists a package for 8.1 ? didn't find it.

Some ideas ?

Without wanting to tread on toes or undermine the excellent work vtverdohleb does for D Link NAS owners I will add only that vtverdohleb compiles (AFAIK meaning uses computer programming to make these addons function for us to use on our NAS) and I also assume this is a hobby for him and has little time outside work or other commitments to add more, update older etc.

Therefore based on what I understand above and from my knowledge of this forum etc I'm assuming the update needs to be compiled and is therefore not workable.  Of course I could be wrong  ;)

HTH
Logged

BigD87

  • Level 1 Member
  • *
  • Posts: 21
Re: Add-on "ownCloud v8.0.0.7" for D-Link NAS
« Reply #39 on: September 29, 2015, 02:05:38 AM »

Argh.

After successfully getting OwnCloud up and running and enjoying seamless syncing from my server, pc, mobile, laptop and iPad I have a power cut at home over the weekend. Now I cannot log onto my own cloud instance.

I would get the following error

"Internal Server Error
The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log."

Perhaps foolishly I had a look at the log and my config file. My trusted domains had vanished from my config file so I used QuiXplorer to add them in like I did initially and now whenever I try to log in, from my local IP and drink.ddns address it gives me an error
"Parse error: syntax error, unexpected '\' (T_NS_SEPARATOR), expecting identifier (T_STRING) in /mnt/HD/HD_a2/Nas_Prog/owncloud/owncloud/config/config.php on line 3"
However I didn't amend anything in line 3 of the config/php.

So I uninstalled Owncloud and restarted my DNS-327L and re-installed the own cloud add-on. I still get the same error:

"Parse error: syntax error, unexpected '\' (T_NS_SEPARATOR), expecting identifier (T_STRING) in /mnt/HD/HD_a2/Nas_Prog/owncloud/owncloud/config/config.php on line 3"

On a new install, I haven't even touched the config.php. I wondered if it was getting left behind. So unistalled the add-on restarted the NAS, went in with QuiXplorer and Owncloud folder isn't there so the config.php is gone. Re-install own cloud click on Launch interface and I get the "Parse error" still.

I had read a previous response to the "internal server error" being to do with the SQL so I tried to run the fix they suggest but whenever I try to log in with myPHPadmin I get "#2002 Cannot log in to the MySQL server" error.

EDIT: I have tried every combination of what is the standard admin/admin root/admin etc etc and all the possible combinations I might have inadvertently changed it to and I still get  "#2002 Cannot log in to the MySQL server" error and my own cloud gives me "Parse error: syntax error, unexpected '\' (T_NS_SEPARATOR), expecting identifier (T_STRING) in /mnt/HD/HD_a2/Nas_Prog/owncloud/owncloud/config/config.php on line 3" from a fresh own cloud install.

I am thinking I am a lost cause and going to admit defeat and that I should nuke my DNS-327L and do a hard reset to flush out all the settings etc and restart from scratch, unless some-one can give me some advice to the contrary?

As always I look forward to your help and suggestions, you've all been so helpful up until now. who would have thought a little power cut would cause this much trouble.
« Last Edit: September 29, 2015, 05:28:20 AM by BigD87 »
Logged
DNS-327L FW1.05

BigD87

  • Level 1 Member
  • *
  • Posts: 21
Re: Add-on "ownCloud v8.0.0.7" for D-Link NAS
« Reply #40 on: April 15, 2016, 01:06:29 AM »

A little update on my last post.

I reset the DNS-327L and reinstalled everything and since then own cloud has been working like a dream. Problem solved...

Until I added a second hard drive the other weekend and used the prompt to configure it to RAID 1 without erasing the existing Data.

During the following week my own cloud install had been using 99% CPU resources and the same RAM. The eventually was causing my DNS to crash. The fan was going / all lights on the front and the network lights round the back were flashing like mad. I could type in my dlinkddns and local IP and the sharecenter login page would start to load but would never finish. The only way to get it responsive was to pull the power plug as holding down the power button did nothing.

Restart, scan disc, all fine. Couple of hours later crash. I shut down the own cloud app and the share centre has been fine running for a couple of days no stability issues.

I remoted in to own cloud with Quixplorer to look at the config.php file and all of the amendments I had made to trusted domains etc were gone along with my changes to file size limits in the light (something) file too. I am back in the same boat as before in my previous post. Does anyone else have this issue where own cloud seems incredibly easy to get corrupted? Last time it was a power failure, this time it is a switch to RAID 1.

I know that if i reset the box and start from scratch I can get it working but will have to repeat this is maybe another 6 months or less.

If I disable the app (done) and then delete in from the add-in page on the dns-327L am I then safe to go in with quixplorer and delete any own cloud folders left so that I can install it from scratch?

Thanks for any input. I notice this thread has kind of died.

Bit of a ramble I know but thanks in advance.
Logged
DNS-327L FW1.05

Lentzeris

  • Level 1 Member
  • *
  • Posts: 2
Re: Add-on "ownCloud v8.0.0.7" for D-Link NAS
« Reply #41 on: May 23, 2016, 10:16:08 PM »

I would like to enable "Server-side Encryption" App, but it says that "This app cannot be installed because the following dependencies are not fulfilled:
The library openssl is not available." How can I solve this?
Logged

vtverdohleb

  • Level 5 Member
  • *****
  • Posts: 712
    • Add-Ons for D-Link NAS
Re: Add-on "ownCloud v8.0.0.7" for D-Link NAS
« Reply #42 on: May 25, 2016, 10:29:59 AM »

I would like to enable "Server-side Encryption" App, but it says that "This app cannot be installed because the following dependencies are not fulfilled:
The library openssl is not available." How can I solve this?

not enough information
Logged
Add-on Application questions and issues, please include the following minimal information in your post:
* ShareCenter Model
* Add-on Name
* Add-on Version
* Detailed Description of your Issue
Donate: http://dlink.vtverdohleb.org.ua/Add-On/donate.php

Lentzeris

  • Level 1 Member
  • *
  • Posts: 2
Re: Add-on "ownCloud v8.0.0.7" for D-Link NAS
« Reply #43 on: May 25, 2016, 11:07:19 AM »

ShareCenter Model: DNS-320L Firmware 1.07
Add-on Name: DNS-320L owncloud Package v2.03_04222015_UA
The next version (2.04) does not work at all, so I am using this instead.
Logged

vtverdohleb

  • Level 5 Member
  • *****
  • Posts: 712
    • Add-Ons for D-Link NAS
Re: Add-on "ownCloud v8.0.0.7" for D-Link NAS
« Reply #44 on: May 25, 2016, 12:18:11 PM »

ShareCenter Model: DNS-320L Firmware 1.07
Add-on Name: DNS-320L owncloud Package v2.03_04222015_UA
The next version (2.04) does not work at all, so I am using this instead.

To do this, the device is still weak, and real-time encryption? no.
Logged
Add-on Application questions and issues, please include the following minimal information in your post:
* ShareCenter Model
* Add-on Name
* Add-on Version
* Detailed Description of your Issue
Donate: http://dlink.vtverdohleb.org.ua/Add-On/donate.php
Pages: 1 2 [3] 4