• October 21, 2020, 12:20:06 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: 1 2 3 [4]

Author Topic: Add-on "ownCloud v8.0.0.7" for D-Link NAS  (Read 37264 times)

faroutxxx

  • Level 1 Member
  • *
  • Posts: 4
Re: Add-on "ownCloud v8.0.0.7" for D-Link NAS
« Reply #45 on: December 08, 2016, 03:55:55 PM »

I have an internal server error I hope someone can direct me to a solution please?

DNS-320L owncloud Package v2.04_07012015_UA

Quote
Internal Server Error
The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.

Technical details
Remote Address: 192.168.0.55
Request ID: 31c8426db534ce926b641aa8d9fc5895

/mnt/HD/HD_a2/Nas_Prog/owncloud/owncloud/data/owncloud.log

Quote
{"reqId":"31c8426db534ce926b641aa8d9fc5895","remoteAddr":"192.168.0.55","app":"index","message":"Exception: {\"Message\":\"An exception occurred while executing 'SELECT \\\"configvalue\\\", \\\"appid\\\" FROM \\\"oc_appconfig\\\" WHERE \\\"configkey\\\" = ?' with params [\\\"enabled\\\"]:\\n\\nSQLSTATE[HY000]: General error: 1 no such table: oc_appconfig\",\"Code\":0,\"Trace\":\"#0 \\\/mnt\\\/HD\\\/HD_a2\\\/Nas_Prog\\\/owncloud\\\/owncloud\\\/3rdparty\\\/doctrine\\\/dbal\\\/lib\\\/Doctrine\\\/DBAL\\\/DBALException.php(116): Doctrine\\\\DBAL\\\\Driver\\\\AbstractSQLiteDriver->convertException('An exception oc...', Object(Doctrine\\\\DBAL\\\\Driver\\\\PDOException))\\n#1 \\\/mnt\\\/HD\\\/HD_a2\\\/Nas_Prog\\\/owncloud\\\/owncloud\\\/3rdparty\\\/doctrine\\\/dbal\\\/lib\\\/Doctrine\\\/DBAL\\\/Connection.php(836): Doctrine\\\\DBAL\\\\DBALException::driverExceptionDuringQuery(Object(Doctrine\\\\DBAL\\\\Driver\\\\PDOSqlite\\\\Driver), Object(Doctrine\\\\DBAL\\\\Driver\\\\PDOException), 'SELECT \\\"configv...', Array)\\n#2 \\\/mnt\\\/HD\\\/HD_a2\\\/Nas_Prog\\\/owncloud\\\/owncloud\\\/lib\\\/private\\\/db\\\/connection.php(113): Doctrine\\\\DBAL\\\\Connection->executeQuery('SELECT \\\"configv...', Array, Array, NULL)\\n#3 \\\/mnt\\\/HD\\\/HD_a2\\\/Nas_Prog\\\/owncloud\\\/owncloud\\\/lib\\\/private\\\/appconfig.php(259): OC\\\\DB\\\\Connection->executeQuery('SELECT `configv...', Array)\\n#4 \\\/mnt\\\/HD\\\/HD_a2\\\/Nas_Prog\\\/owncloud\\\/owncloud\\\/lib\\\/private\\\/app.php(219): OC\\\\AppConfig->getValues(false, 'enabled')\\n#5 \\\/mnt\\\/HD\\\/HD_a2\\\/Nas_Prog\\\/owncloud\\\/owncloud\\\/lib\\\/private\\\/app.php(71): OC_App::getEnabledApps()\\n#6 \\\/mnt\\\/HD\\\/HD_a2\\\/Nas_Prog\\\/owncloud\\\/owncloud\\\/lib\\\/base.php(551): OC_App::loadApps(Array)\\n#7 \\\/mnt\\\/HD\\\/HD_a2\\\/Nas_Prog\\\/owncloud\\\/owncloud\\\/lib\\\/base.php(1039): OC::init()\\n#8 \\\/mnt\\\/HD\\\/HD_a2\\\/Nas_Prog\\\/owncloud\\\/owncloud\\\/index.php(34): require_once('\\\/mnt\\\/HD\\\/HD_a2\\\/N...')\\n#9 {main}\",\"File\":\"\\\/mnt\\\/HD\\\/HD_a2\\\/Nas_Prog\\\/owncloud\\\/owncloud\\\/3rdparty\\\/doctrine\\\/dbal\\\/lib\\\/Doctrine\\\/DBAL\\\/Driver\\\/AbstractSQLiteDriver.php\",\"Line\":58}","level":4,"time":"2016-12-08T23:35:03+00:00"}
Logged

vtverdohleb

  • Level 5 Member
  • *****
  • Posts: 712
    • Add-Ons for D-Link NAS
Re: Add-on "ownCloud v8.0.0.7" for D-Link NAS
« Reply #46 on: December 10, 2016, 10:21:12 AM »

the problem is probably in this:
SQLSTATE[HY000]: General error: 1 no such table: oc_appconfig

Why - I do not know, I can only assume - database corruption or not startup MySQL.
Such a problem can not be resolved through a forum. Faster and easier - reinstall the add-on.
Pre necessarily somewhere to store the data downloaded in "owncloud".
Logged
Add-on Application questions and issues, please include the following minimal information in your post:
* ShareCenter Model
* Add-on Name
* Add-on Version
* Detailed Description of your Issue
Donate: http://dlink.vtverdohleb.org.ua/Add-On/donate.php

sfynx

  • Level 1 Member
  • *
  • Posts: 9
Re: Add-on "ownCloud v8.0.0.7" for D-Link NAS
« Reply #47 on: January 23, 2017, 08:36:08 AM »

Hi, i have a DNS-320L, i installed DNS-320L owncloud Package v3 , after inserting key and restarting addon when i try to launch interface to configure it, all i get is 503 - Service Not Available, what am i doing wrong?
Logged

vtverdohleb

  • Level 5 Member
  • *****
  • Posts: 712
    • Add-Ons for D-Link NAS
Re: Add-on "ownCloud v8.0.0.7" for D-Link NAS
« Reply #48 on: January 28, 2017, 12:07:57 AM »

For ownCloud addon v3.x requires preinstalled addon PHP.
Logged
Add-on Application questions and issues, please include the following minimal information in your post:
* ShareCenter Model
* Add-on Name
* Add-on Version
* Detailed Description of your Issue
Donate: http://dlink.vtverdohleb.org.ua/Add-On/donate.php

sfynx

  • Level 1 Member
  • *
  • Posts: 9
Re: Add-on "ownCloud v8.0.0.7" for D-Link NAS
« Reply #49 on: January 30, 2017, 02:41:52 PM »

Thank you very mutch, that solved it =)
Logged

sfynx

  • Level 1 Member
  • *
  • Posts: 9
Re: Add-on "ownCloud v8.0.0.7" for D-Link NAS
« Reply #50 on: January 31, 2017, 02:08:35 PM »

So after sorting out ddns and port forwarding i still cant access owncloud, using poramor.dlinkddns.com:441 does not work, using poramor.dlinkddns.com:81 does, but that's not in https so not good for mobile app. Not shure what i'm still missing =(
Logged

freakingvitor

  • Level 1 Member
  • *
  • Posts: 8
Re: Add-on "ownCloud v8.0.0.7" for D-Link NAS
« Reply #51 on: February 01, 2017, 05:15:54 PM »

i've installed php addon

but it seens to be broken... doenst show the elephant on nas 320l with 1.07 firmware.

i just have to install owncloud and launch to it work?

When i used fun plug it worked. but now i want to use in new firmware.

I'm using the 2.04v owncloud, but i have de 3.x

how to proceed?
Logged

amadeuw

  • Level 1 Member
  • *
  • Posts: 1
Re: Add-on "ownCloud v8.0.0.7" for D-Link NAS
« Reply #52 on: February 08, 2017, 12:06:15 PM »

I have this error in log when I try to run OwnCloud "DNS-320L owncloud Package v2.04_07012015_UA"

ERROR:
Erro Interno do Servidor
O servidor encontrou um erro interno e não conseguiu concluir o seu pedido.
Entre em contato com o administrador do servidor se este erro reaparece várias vezes, por favor, inclua os detalhes técnicos abaixo em seu relatório.
Mais detalhes podem ser encontrados no log do servidor.

Detalhes técnicos
Endereço Remoto: 10.0.0.10
ID do Pedido: 370f04cbcbe7bf82c8bbdc41cdfccc0f

MY REAL REMOTE ADDRESS IS NOT FIXED, AND THE IP IS: 10.0.0.8 ... I dont no why is calling to the : 10.0.0.10 ...

HD_a2 » Nas_Prog » owncloud » owncloud » data
LOG
{"reqId":"7e682ec99386c25ccef07a0eacfeb32e","remoteAddr":"10.0.0.10","app":"index","message":"Exception: {\"Message\":\"An exception occurred while executing 'SELECT \\\"configvalue\\\", \\\"appid\\\" FROM \\\"oc_appconfig\\\" WHERE \\\"configkey\\\" = ?' with params [\\\"enabled\\\"]:\\n\\nSQLSTATE[HY000]: General error: 1 no such table: oc_appconfig\",\"Code\":0,\"Trace\":\"#0 \\\/mnt\\\/HD\\\/HD_a2\\\/Nas_Prog\\\/owncloud\\\/owncloud\\\/3rdparty\\\/doctrine\\\/dbal\\\/lib\\\/Doctrine\\\/DBAL\\\/DBALException.php(116): Doctrine\\\\DBAL\\\\Driver\\\\AbstractSQLiteDriver->convertException('An exception oc...', Object(Doctrine\\\\DBAL\\\\Driver\\\\PDOException))\\n#1 \\\/mnt\\\/HD\\\/HD_a2\\\/Nas_Prog\\\/owncloud\\\/owncloud\\\/3rdparty\\\/doctrine\\\/dbal\\\/lib\\\/Doctrine\\\/DBAL\\\/Connection.php(836): Doctrine\\\\DBAL\\\\DBALException::driverExceptionDuringQuery(Object(Doctrine\\\\DBAL\\\\Driver\\\\PDOSqlite\\\\Driver), Object(Doctrine\\\\DBAL\\\\Driver\\\\PDOException), 'SELECT \\\"configv...', Array)\\n#2 \\\/mnt\\\/HD\\\/HD_a2\\\/Nas_Prog\\\/owncloud\\\/owncloud\\\/lib\\\/private\\\/db\\\/connection.php(113): Doctrine\\\\DBAL\\\\Connection->executeQuery('SELECT \\\"configv...', Array, Array, NULL)\\n#3 \\\/mnt\\\/HD\\\/HD_a2\\\/Nas_Prog\\\/owncloud\\\/owncloud\\\/lib\\\/private\\\/appconfig.php(259): OC\\\\DB\\\\Connection->executeQuery('SELECT `configv...', Array)\\n#4 \\\/mnt\\\/HD\\\/HD_a2\\\/Nas_Prog\\\/owncloud\\\/owncloud\\\/lib\\\/private\\\/app.php(219): OC\\\\AppConfig->getValues(false, 'enabled')\\n#5 \\\/mnt\\\/HD\\\/HD_a2\\\/Nas_Prog\\\/owncloud\\\/owncloud\\\/lib\\\/private\\\/app.php(71): OC_App::getEnabledApps()\\n#6 \\\/mnt\\\/HD\\\/HD_a2\\\/Nas_Prog\\\/owncloud\\\/owncloud\\\/lib\\\/base.php(551): OC_App::loadApps(Array)\\n#7 \\\/mnt\\\/HD\\\/HD_a2\\\/Nas_Prog\\\/owncloud\\\/owncloud\\\/lib\\\/base.php(1039): OC::init()\\n#8 \\\/mnt\\\/HD\\\/HD_a2\\\/Nas_Prog\\\/owncloud\\\/owncloud\\\/index.php(34): require_once('\\\/mnt\\\/HD\\\/HD_a2\\\/N...')\\n#9 {main}\",\"File\":\"\\\/mnt\\\/HD\\\/HD_a2\\\/Nas_Prog\\\/owncloud\\\/owncloud\\\/3rdparty\\\/doctrine\\\/dbal\\\/lib\\\/Doctrine\\\/DBAL\\\/Driver\\\/AbstractSQLiteDriver.php\",\"Line\":58}","level":4,"time":"2017-02-08T19:52:13+00:00"}
Logged

freakingvitor

  • Level 1 Member
  • *
  • Posts: 8
Re: Add-on "ownCloud v8.0.0.7" for D-Link NAS
« Reply #53 on: February 10, 2017, 02:42:16 PM »

i'm having the connection refused error on port 81 or 441.

How to solve it ?

Thanx
Logged

vtverdohleb

  • Level 5 Member
  • *****
  • Posts: 712
    • Add-Ons for D-Link NAS
Re: Add-on "ownCloud v8.0.0.7" for D-Link NAS
« Reply #54 on: February 11, 2017, 12:00:22 PM »

I have this error in log when I try to run OwnCloud "DNS-320L owncloud Package v2.04_07012015_UA"

I have written many times that specifically DNS-320L model regular MySQL does not run on system startup. So embedded in the firmware, the reason is unknown to me. I run MySQL from the addon, but NAS heavy load, he may not be able to start before the database installation. The easiest way to solve the problem - a temporary stop "heavy" add-ons and reinstall your ownCloud.

i'm having the connection refused error on port 81 or 441.

This topic has the requirements specified by the moderator in the "cap" and duplicated in my signature. Questions with the content type "i'm having ... error" without specifying the required information - ignored.
Logged
Add-on Application questions and issues, please include the following minimal information in your post:
* ShareCenter Model
* Add-on Name
* Add-on Version
* Detailed Description of your Issue
Donate: http://dlink.vtverdohleb.org.ua/Add-On/donate.php

freakingvitor

  • Level 1 Member
  • *
  • Posts: 8
Re: Add-on "ownCloud v8.0.0.7" for D-Link NAS
« Reply #55 on: February 14, 2017, 01:41:33 PM »

dear vtverdohleb,

I'm using de v 2.04  version of owncloud on my nas 320l and the connection refused on port 441 and port 81.
The last version 3.xx (8.0.0.7) i have the serial number, but when i try to activate it, returns to the same page as if i did not activated
I dont know how to solve this problem and did not see another member with the same issue.

I use nas 320L.
Logged

sfynx

  • Level 1 Member
  • *
  • Posts: 9
Re: Add-on "ownCloud v8.0.0.7" for D-Link NAS
« Reply #56 on: February 16, 2017, 01:44:54 AM »

Finally got it running on DNS320L, it's a bit slow when uploading, but other than that it's working great. Thank you.
Logged
Pages: 1 2 3 [4]