• April 19, 2019, 09:42:26 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Pages: [1] 2 3

Author Topic: 880L Crashes and Reboots When Connecting to 5GHz With QOS Enabled  (Read 16614 times)

square_eyes

  • Level 2 Member
  • **
  • Posts: 32

Edit: Amazingly, whilst on the phone to support, during the long waits I started rehashing some of my troubleshooting. I discovered that disabling QOS allowed me to get on to 5GHz. I am certain I had tried all my previous tests in isolation. But now I'm able to get on (for at least 30 minutes so far), with a static IP for the 880L. So I have to say at this point that this is a QOS issue, only made apparent when my Macbook Pro connects to 5GHz.
----

Fatal, repeatable DIR-880L bug for me.

FW:1.02, HW: A1, Macbook Pro Retina 2014, OSX 10.10.1, Huawei Spark HG630b Modem

Repeatable bug: After a factory reset, and no other router config, adding a device to one of the QOS options (saving and rebooting), results in my Macbook pro causing a fatal router crash when it tries to connect on 5GHz. The router continues to crash and reboot as long as the MBP is trying to connect on 5GHz. Switching to 2.4GHz restores peace in the world. I have tested a couple of other 5GHz devices and they don't have the same issue.

Previous post...

  • Factory wipe then, Settings -> Internet -> "My Internet connection is" -> Dynamic IP (DHCP) - 5Ghz works fine
  • Then... Settings -> Internet -> "My Internet connection is" -> Static IP - Connecting to 5GHz with my laptop crashes and reboots the router. 2.4 works fine (when it finally recovers). Changing back to Dynamic IP (DHCP) does not resolve the issue. A factory reset is required, and setting must stay as DHCP to be able to use 5GHz

Background:
My modem does not "support" bridge mode, and I need the D-Link to handle port forwarding. As such I have been asked to keep the modem on a separate subnet and turn off DCHP and WiFi. This is actually what Huawei calls bridge mode when you call support. In spite of me telling them that it's not truly bridge mode, the morons just keep sending me the same copy paste email instructions. Over and over. A smart user on Stack Exchange suggested using DMZ to forward inbound connections to the 880L. This works fine! But the 880L needs to have a static IP. When I set one up as described above (outside the modem's DHCP range) inbound connections are correctly sent to the 880L, which then handles the port forwarding. There's one problem, connecting via 5GHz from my laptop crashes the modem. Staying on 2.4, everything works as it should. Setting the connection to DHCP means I can't have a static IP. Stupid Huawei doesn't have address reservation either. I found this bug out through extensive trial and error, starting from a factory reset and configuring one option a day to see what broke the router.

Other notes:
  • Connecting via 5GHz from other devices does not seem to crash the router.
  • OSX 10.10.1, Yosemite, has known WiFI issues, although I can't find anyone else with this one
  • My MBP can successfully hold a connection on a different 5GHZ AC network
  • I purchased this router for 5GHz AC because my laptop doesn't have Ethernet >:(. I share the house with many people and multiple (around 15) devices, all but one on 2.4. So please don't tell me to "just use 2.4".

Sorry for the double posts (I have removed them). This forum seems to have an issue with Firefox. i.e. hitting submit takes you to the home page and post is not shown, when it's apparently there.
« Last Edit: March 12, 2015, 02:48:05 AM by square_eyes »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47208
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology

Link>Welcome!

  • Link>What Firmware version is currently loaded? Found on the routers web page under status.
  • What region are you located?
  • Has a Factory Reset been performed?
  • Was a Factory Reset performed before and after any firmware updates then set up from scratch?
>FW Update Process
  • Was the router working before any firmware updates?

Internet Service Provider and Modem Configurations
  • What ISP Modem service link speeds UP and Down do you have?
  • Check cable between Modem and Router, swap out to be sure. Link> Cat6 is recommended.
  • Check ISP MTU requirements, Cable is usually 1500, DSL is around 1492 down to 1472. Call the ISP and ask. Link>Checking MTU Values
  • If the ISP modem has a built in router, it's best to bridge the modem. Having 2 routers on the same line can cause connection problems: Link>Double NAT and How NAT Works. To tell if the modem is bridged or not, look at the routers web page, Status/Device Info/Wan Section, if there is a 192.168.0.# address in the WAN IP address field, then the modem is not bridged. If the modem can't be bridged then see if the modem has a DMZ option and input the IP address the router gets from the modem and put that into the modems DMZ. Also check the routers DHCP IP address maybe conflicting with the ISP modems IP address of 192.168.0.1. Check to see if this is the same on the ISP modem, and if modem can't be bridged, change the DIR router to 192.168.1.1 or .0.254.

You may want to check with your ISP to see if they support using a stand alone modem. It's highly recommended to use a stand alone modem with external routers such as the DIR-880L

I've been using my Mac Book Pro 2007 with OSX 10.10.1 and haven't seen any issues on either radio...

The reset or rebooting of the router is a symptom of the router either mis-configured or some form of interference....
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

square_eyes

  • Level 2 Member
  • **
  • Posts: 32

Most of what you asked is in my post. Here are the other bits...

  • Region: New Zealand
  • Was the router working before any firmware updates?: The first thing I did to the router was update the firmware and factory reset
  • Speed is currently 7mbs down and 1mbs up
  • MTU: Modem is supplied by the ISP, and pre configured to thier optimal settings
« Last Edit: January 13, 2015, 12:02:12 PM by square_eyes »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47208
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology

I recommend that you phone contact your regional D-Link support office and ask for help and information regarding this. We find that phone contact has better immediate results over using email.
Let us know how it goes please.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

square_eyes

  • Level 2 Member
  • **
  • Posts: 32

Did that. Got told their servers are down and they can't help me at the moment. Funny too, the first 3-4 times I called Huawei to get "bridging" instructions I got told the same thing of their servers.

The guys that invented telephone networks, and ensured near on 99.9% up-time would be rolling in their graves if they saw today's enterprise networking service-level. Let alone our pokey, over priced, consumer grade routers and switches ;D ;D ;D

I'll be sure to report any progress.
Logged

square_eyes

  • Level 2 Member
  • **
  • Posts: 32
Re: 880L Crashes and Reboots When Connecting to 5GHz With QOS Enabled
« Reply #5 on: January 13, 2015, 08:35:58 PM »

Please see my edit on the first post. I stumbled on finding the real root cause, QOS, rehashing some troubleshooting steps while on hold at the D-link call centre.

To my amazement, when I explained this to the L1 tech he had the audacity to ask me what the problem was then, and why don't I just disable QOS.

Makes my blood boil. Is it not unreasonable that a feature on the side of the box, one of the main reasons that I purchased the unit for, works correctly as advertised? Not that it's any of their business, but I run an audio networking service that requires high availability, I want it to have the highest priority of all of my traffic, in a busy household.

Note that this is after several factory resets. And I notice there is another post about this so I'm guessing it's a firmware issue. I'm waiting for a L2 to call back in 24 hrs. But as they never called me back the first time, I'm not holding my breath.
« Last Edit: January 13, 2015, 08:47:47 PM by square_eyes »
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47208
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: 880L Crashes and Reboots When Connecting to 5GHz With QOS Enabled
« Reply #6 on: January 14, 2015, 08:01:13 AM »

This maybe a faulty router or a problem with the Apple LT.

So far I've been using the 880L and haven't seen any issues with the latest FW and on OSX 10.10.1 using my LT however your HW is newer than mine so could be the difference.

Do other 5Ghz devices work with the router? I'll put my Mac Book Pro in the QoS and see what happens. Normally the only devices I put there is my 2 game consoles.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

square_eyes

  • Level 2 Member
  • **
  • Posts: 32
Re: 880L Crashes and Reboots When Connecting to 5GHz With QOS Enabled
« Reply #7 on: January 14, 2015, 05:14:38 PM »

My Galaxy S5 has no issue connecting on 5GHz with QOS enabled. And my MBP as no issue (after 24hrs) with QOS disabled. I have spoken to L2 of both manufacturers, with varying degrees of helpfulness, who both suggest it's the other's fault.

Likely not relevant, but I'll put it here. I'm also having an issue with my MBP where hot swapping USB 2 devices locks up all USB input (including the built in keyboad and trackpad). Just in case there is a link.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47208
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: 880L Crashes and Reboots When Connecting to 5GHz With QOS Enabled
« Reply #8 on: January 14, 2015, 08:02:09 PM »

Any chance you can test out a different MBP? If your seeing other issues with your MBP, could be an issue with the MBP itself. Testing of another could help confirm either way...
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47208
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

jgatl

  • Level 1 Member
  • *
  • Posts: 6
Re: 880L Crashes and Reboots When Connecting to 5GHz With QOS Enabled
« Reply #10 on: January 19, 2015, 05:32:02 AM »

I'm having this same issue.  I have one device setup for QoS (Ooma phone).  Modem reboots most often when everyone is home (roughly 10 devices on wifi) under load, and phone (only device with QoS) is being used.   

Firmware: 1.02, 11/11/2014 14:04
Region:  US
Factory reset:  Yes
Reset before/after:  Yes
FW Update Process: Router was brand new and immediately updated when received, so no data here

Internet Service Provider and Modem Configurations
ISP:  Comcast Cable, 59.6Mbps down, 12.62 up
Cable:  Brand new Cat 6.  have swapped
No MTU requirements from Comcast
Modem is standalone, Motorola SB6141
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47208
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: 880L Crashes and Reboots When Connecting to 5GHz With QOS Enabled
« Reply #11 on: January 19, 2015, 08:57:07 AM »

QoS is meant for two ir more devices. Also if you have a VoIP device like Ooma, remove it from QoS and place it in the DMZ. Most VoIP devices dont need to be on QoS and work better in the DMZ.

I'm having this same issue.  I have one device setup for QoS (Ooma phone).  Modem reboots most often when everyone is home (roughly 10 devices on wifi) under load, and phone (only device with QoS) is being used.   

Firmware: 1.02, 11/11/2014 14:04
Region:  US
Factory reset:  Yes
Reset before/after:  Yes
FW Update Process: Router was brand new and immediately updated when received, so no data here

Internet Service Provider and Modem Configurations
ISP:  Comcast Cable, 59.6Mbps down, 12.62 up
Cable:  Brand new Cat 6.  have swapped
No MTU requirements from Comcast
Modem is standalone, Motorola SB6141
« Last Edit: January 19, 2015, 09:11:50 AM by FurryNutz »
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

jgatl

  • Level 1 Member
  • *
  • Posts: 6
Re: 880L Crashes and Reboots When Connecting to 5GHz With QOS Enabled
« Reply #12 on: January 19, 2015, 09:44:11 AM »

QoS is meant for two or more devices. Also if you have a VoIP device like Ooma, remove it from QoS and place it in the DMZ. Most VoIP devices dont need to be on QoS and work better in the DMZ.

I have roughly 20 devices on the network, but really the Ooma is the only one I need prioritized.  Do I need to hard code the IP for that device when I assign it to the DMZ?  It's behind a switch (not plugged directly into router)?  And would it have to be plugged directly into the router or can it be plugged into a switch?

Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 47208
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: 880L Crashes and Reboots When Connecting to 5GHz With QOS Enabled
« Reply #13 on: January 19, 2015, 09:47:50 AM »

Yes, give a Reserved IP address for the Ooma and set it into the DMZ. No you don't need to connect it directly to the router.
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!

jgatl

  • Level 1 Member
  • *
  • Posts: 6
Re: 880L Crashes and Reboots When Connecting to 5GHz With QOS Enabled
« Reply #14 on: January 20, 2015, 05:25:20 AM »

Thanks for support.  Took 4 steps to (hopefully) resolve my reboot issues:
1.  Replaced my cable modem (SB6141) with a Zoom 5341J:  Users from Comcast forums state the 5341J is very stable. 
2.  Upgraded firmware to 1.02 B13. 
3.  Reserved IP address for Ooma under connected clients
4.  Enabled DMZ mapping to Ooma reserved IP address

I've also set the system logs to write out to my mac file server (which also has a reserved IP address). 

So far no reboots (with 20 connected clients, wireless and wired), and I've got a pretty sophisticated monitoring system (3 kids that are constantly connected to the internet). 
Logged
Pages: [1] 2 3