• December 14, 2018, 10:41:29 PM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  

News:

This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DWA-552 requires reinsertion to PCI slot after boot  (Read 2426 times)

darkice

  • Level 1 Member
  • *
  • Posts: 1
DWA-552 requires reinsertion to PCI slot after boot
« on: December 26, 2014, 11:13:32 AM »

Hi,

The Problem
In order for my card to start working I have to remove it from the PCI slot and reinsert it after I have booted my PC.

The Details
  • My card was working fine, then one day my motherboard decided to stop working so I got that replaced and I just did a fresh install of Windows 7 Ultimate 64-bit.
  • The chipset on my previous board overheated and essentially had a meltdown.
  • I have all of the drivers installed for the motherboard.
  • I installed the DWA-552 driver through the device manager by selecting the card and doing a manual driver install for the hardware. I selected DWA-552 which was listed under D-Link Corporation. Upon installation I get an error code 10, which states that Windows could not start the device. While the PC is still running I remove the card from the PCI slot and re-insert it, then run a scan for new hardware, under device manager, and the card works fine. (I'm posting this using the card.)
  • Note: I've tried installing the driver through the cd and I reach a point in the installation which says to insert the card if it has not already been inserted. If the card is already inserted and I click the next button the installation wizard closes out and nothing happens. If I insert the card at that point the installation works sometimes, and other times the wizard simply closes out. When the installation goes through, the card works, but after rebooting I still have to reinsert the card after starting up.

Thoughts
Since the motherboard is brand new I don't think it's likely that the PCI rail is to blame.
I think the card was damaged when my previous motherboard failed.

Thanks

Logged

davevt31

  • Level 8 Member
  • ***
  • Posts: 1402
Re: DWA-552 requires reinsertion to PCI slot after boot
« Reply #1 on: December 26, 2014, 12:52:51 PM »

If you are pulling out the card and reinserting it WHILE the computer is on you are going to damage the card and the motherboard.  DO NOT ever remove or insert cards while the system is on.  I would say since the card doesn't show up right that you have toasted it.
Logged

FurryNutz

  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 46300
  • D-Link Global Forum Moderator
    • New DIR-890L Router with SmartConnect™ Technology
Re: DWA-552 requires reinsertion to PCI slot after boot
« Reply #2 on: January 06, 2015, 07:33:51 AM »

Please ensure that you are fully turning OFF the computer before removing or inserting any PCI cards in to the PC. As stated by Dave, you will incur damage to the PC, motherboard and cards if you attempt to remove or insert them into the slots while the PC is ON. Very bad.  ::)
Logged
"Nothing Funny about It...." We are not here to Impress anyone! You have a be a COMPETENT user first to under stand COMPETENT help!