• February 25, 2021, 09:20:26 AM
  • Welcome, Guest
Please login or register.

Login with username, password and session length
Advanced search  


This Forum Beta is ONLY for registered owners of D-Link products in the USA for which we have created boards at this time.

Author Topic: DCS-2330L Camera & R7000 Router - Can't Record to Network or local FTP storage  (Read 10207 times)


  • Level 1 Member
  • *
  • Posts: 1

(PROBLEM: Can't record to Network Storage Location or local FTP)

Thanks for reading! :)

First I'd like to say never, ever, ever in my life have I had such a hard time setting up something as I have with this camera. It's completely unforgiving. It's also apparent this piece of firmware has ZERO logic behind it. For example if you want to go to dlink.com you can type in your browser http://www.dlink.com or www.dlink.com , or dlink.com or you can even  get creative and type WwW.DLiNk.com or dLINk.com , even throwing in forward slashes at the end if you want. Pretty much whatever you want within reason and you'll arrive at the website you want to visit.

NOT with this camera though. It has to be done exactly! But unfortunately the camera doesn't tell you the rules of the game beforehand, and throw in (or so I've read) "test error" which some users have reported doesn't actually mean a failure, and at times the need to reboot the camera after setting up the storage, and you have a ridiculously frustrating experience.

Anyways sorry for the rant, I like the camera, but please dlink have some compassion for your customers and make things slightly easier. I read on this forum a network engineer by trade couldn't even get his camera to record to local network storage!

Okay that's out of the way.  ;D Let me explain my problem and what I want to do.

I have a Netgear Nighthawk (R7000) router using updated stock firmware with a 32GB sandisk "cruzer" flash drive connected to the router formatted in NTFS.

On the main "live video" tab, I can get it to record video at my leisure by selecting the network drive. So the camera WILL write to it. But setting it up in the "event setup", specifying the drive/network folder will fail. I must have tried at least 50 different combinations. Here are links to some (at least in my laymen mind) pertinent information regarding how the router is setup. Perhaps someone could guide me on how to set this up. If I get this to work I'll edit my main post and title, so hopefully I might be able to help someone else out if someone decides to help me.

Thank you!  :)






  • Level 3 Member
  • ***
  • Posts: 194

On the main "live video" tab, I can get it to record video at my leisure by selecting the network drive. So the camera WILL write to it. But setting it up in the "event setup", specifying the drive/network folder will fail.

I don't understand this part.  I'm not aware of any way to get the camera to record something from the Live Video page.  It will show you on that page if it is recording due to a condition you've set being met, e.g. a motion detection event or a scheduled recording.  But to get it to record anything, you have to go into Event Setup and configure, at minimum, one recording destination.  And your options there are the local SD card (if you've got one inserted in the camera) or your network share.  And then you have to set up an event or a manual recording using that destination.  Since you say that part fails, I suspect your camera has never successfully recorded anything to your network drive.  

Am I missing something?

EDIT: I was missing something.  I forgot that if you use IE (which I don't) you get a few extra buttons on the Live Video page, including one for recording.
« Last Edit: June 21, 2014, 08:56:04 PM by cmontyburns »


  • Level 2 Member
  • **
  • Posts: 26

@MAttdk83, have you tried using you network storage location's IP address instead of its network name?  that worked for me.
DLINK DCS-942L & DCS-2330L, Asus RT-N66U router


  • Level 2 Member
  • **
  • Posts: 26

for FTP, try the following....

Server Address: 192.168.X.XXX
User Name: [your user name]
Password: [your password]
Port: 21
Remote Folder Name: folder_name/subfolder_name

Passive Mode: unchecked

worked for me.  make sure you don't add any extra slashes or colons anywhere.  the syntax is very specific.
DLINK DCS-942L & DCS-2330L, Asus RT-N66U router


  • Level 1 Member
  • *
  • Posts: 23

ceglia - I am envious. I can't get ftp to do anything on the DCS-2330L. Has anyone else figured out what the ftp problem is?

I have a DCS-2132L that FTPs across a local network to a server, and it works fine.

This DCS-2330L is otherwise working fine. It is on the local network, it can be pinged, it is running in D-ViewCam. The onboard setup runs fine, along with the live view on the camera. I can send URL commands and acquire stills and video.

The DCS-2330L, however, doesn't even write any log entries while yielding the infamous "TEST ERROR" result when testing the ftp configuration on the camera. I have been through an assortment of configuration variations in an attempt to troubleshoot. The bottom line is that the DCS-2330L ftp routine is not doing anything. We can't debug a problem when the camera is choosing to not send any ftp commands whatsoever.

Yes, I have tried everything: a different ftp account on the client, and using the same ftp account as the DCS-2132L; firewall on and off; wireless vs. ethernet cable; server IP address vs name as suggested above. No difference. The camera log still does not record the ftp test event, meaning the camera did not try to connect, so of course the ftp client does not record any login attempts because none came in to the server. (An ftp test on the 2132L yields an ftp login/success line in the camera log, and a corresponding line in the ftp client log.)  If there was a login attempt in the ftp client, then I could debate if there is a target file path string error. The ftp test does not even get that far, and besides, I am using the DCS-2132L ftp config as a template. In other words, I know the ftp configuration in the 2330L is correct, routers are fine, the server is ok, the ftp client is configured correctly, the firewall is not in the way. Everything suggests the 2330L has a firmware problem.

Here's the kicker. I bought the 2330L last week. It came with firmware version 1.01.06, and I am tempted to move it backwards to 1.00.04 - an undesireable route that is likely to cause heartburn.

All that said - is anyone else still having ftp trouble, or perhaps found a quirky way around the failure of 2330L ftp to work?

***** EDIT: Solved. *****

My fault.

Using FileZilla as ftp client. I forgot there for IP filters, there are global filters and user account filters. I had changed the user account IP filters, but not the global IP filters. Adding the 2330L to the global IP filters allowed the camera to access and write via FTP.

Then, adding or changing a target ftp directory in the camera's ftp configuration required an immediate camera reboot for the correct target ftp path to take effect. But this reboot requirement was not consistent. It seems that rebooting is the safe method each time.

In FileZilla, changing target (home) directories for ftp accounts, and changing IP filter entries, each required a pgm restart to take effect. (Ouch. Lost some time there.)

Without doing the above tasks, the camera would not do ftp writes, and there was no indication as to why.

That said, whether ftp writes are successful or not, the 2330L is not writing ftp events to the camera log. On both the 942Ls and 2132L, ftp actions are adding log entries - whether they are fails or successful - making debug easier.
« Last Edit: January 02, 2015, 04:31:44 PM by RiverWay »


  • Level 2 Member
  • **
  • Posts: 82

See my problem with the R7000 and Dlink DCS-933L Cam:




  • Poweruser
  •   ▲
    ▲ ▲
  • *****
  • Posts: 49521
  • D-Link Global Forum Moderator
    • Router Troubleshooting

He seems to have solve it as he mentioned in the post...
See my problem with the R7000 and Dlink DCS-933L Cam:


Cable: 1Gb/50Mb>NetGear CAX80>DIR-882>HP 24pt Gb Switch. COVR-1202/2202/3902,DIR-2660/80,3xDGL-4500s,DIR-857,835,827,815,890L,880L,868L,836L,810L,685,657,3x655s,645,628,601,DNR-202L,DNS-345,DCS-933L,936L,960L and 8000LH.